Results 1 to 8 of 8

Thread: Unable to log in after installing anaconda

  1. #1

    Default Unable to log in after installing anaconda

    Hi,

    After installing Anaconda in root, I restarted the computer and tried to log in as root. After I keyed in the password at the log in page, the "setting" icon beside the "sign in" button started spinning, and the screen turns black, and then the log in page appears again. In other words, I am unable to log in, and it is not due to a wrong password.

    However, I am able to log in with another created account.

    I have tried restarting the computer a couple of times.

    What do I need to do to log in as root again?

    Thank you.

  2. #2

    Default Re: Unable to log in after installing anaconda

    Quote Originally Posted by by79 View Post
    What do I need to do to log in as root again?
    See
    https://forums.opensuse.org/showthre...r-not-starting
    https://forums.opensuse.org/showthre...all-qdbus-qt5)
    https://forums.opensuse.org/showthre...call-qdbus-qt5
    https://forums.opensuse.org/showthre...call-qdbus-qt5
    (found by searching the forum for "anaconda") and probably others.

    In short, anaconda comes with its own Qt5, and that can cause problems as it "overrides" the system's one.

    To fix it, remove the lines that the anaconda installer added to the user's .bashrc .

    You should not log in as root anyway though, and especially not to a graphical desktop.

  3. #3

    Default Re: Unable to log in after installing anaconda

    Hi,

    Following the discussions at: https://forums.opensuse.org/showthre...call-qdbus-qt5

    1) Login to IceWM

    2)
    Code:
    qdbus-qt5
    qtpaths --binaries-dir
    which qtpaths
    grep anaconda /etc/profile* /etc/bash* ~/.profile* ~/.bash*
    3) Output for which qdbus-qt5 looks strange
    Code:
    r3:~ # qdbus-qt5
    If 'qdbus-qt5' is not a typo you can use command-not-found to lookup the package that contains it, like this:
        cnf qdbus-qt5
    r3:~ # qtpaths --binaries-dir
    /root/anaconda3/bin
    r3:~ # which qtpaths
    /root/anaconda3/bin/qtpaths
    r3:~ # grep anaconda /etc/profile* /etc/bash* ~/.profile* ~/.bash*
    grep: /etc/profile.d: Is a directory
    grep: /etc/bash_completion.d: Is a directory
    grep: /root/.profile*: No such file or directory
    /root/.bash_history:anaconda-navigator
    /root/.bash_history:export PATH="$PATH:/home/r3/anaconda3/bin"
    /root/.bashrc:export PATH="/root/anaconda3/bin:$PATH"
    r3:~ #
    I guess the proposed solution :

    Code:
    1) - remove the PATH= line that the Anaconda installer added from your ~/.bashrc and set the path manually before running Anaconda 
    2) - copy or symlink qdbus-qt5 in /home/haib/anaconda3/bin
    Pardon me, how to do either?

    Code:
    You should not log in as root anyway though, and especially not to a graphical desktop.
    noted!

  4. #4

    Default Re: Unable to log in after installing anaconda

    Quote Originally Posted by by79 View Post
    3) Output for which qdbus-qt5 looks strange
    Code:
    r3:~ # qdbus-qt5
    If 'qdbus-qt5' is not a typo you can use command-not-found to lookup the package that contains it, like this:
        cnf qdbus-qt5
    Apparently it's not installed. It normally would be in /usr/bin/ so it should be found even with the Anaconda installer's changes.

    What desktop are you actually using to which you cannot login anymore? That is vital in trying to troubleshoot the problem.

    The threads I mentioned were about problems with KDE/Plasma, which of course relies heavily on Qt5, and cannot be started at all without qdbus-qt5.

    Code:
    r3:~ # qtpaths --binaries-dir
    /root/anaconda3/bin
    r3:~ # which qtpaths
    /root/anaconda3/bin/qtpaths
    r3:~ # grep anaconda /etc/profile* /etc/bash* ~/.profile* ~/.bash*
    grep: /etc/profile.d: Is a directory
    grep: /etc/bash_completion.d: Is a directory
    grep: /root/.profile*: No such file or directory
    /root/.bash_history:anaconda-navigator
    /root/.bash_history:export PATH="$PATH:/home/r3/anaconda3/bin"
    /root/.bashrc:export PATH="/root/anaconda3/bin:$PATH"
    r3:~ #
    So that's exactly the same as in the other threads.
    Not surprising, as that's what the anaconda installer does. (and I consider this as bug in the anaconda installer, unfortunately they seem to not want to change it...)


    I guess the proposed solution :

    Code:
    1) - remove the PATH= line that the Anaconda installer added from your ~/.bashrc and set the path manually before running Anaconda 
    2) - copy or symlink qdbus-qt5 in /home/haib/anaconda3/bin
    Pardon me, how to do either?
    Open the file /root/.bashrc in a text editor and remove this line:
    Code:
    export PATH="/root/anaconda3/bin:$PATH"
    or comment it out (i.e. "disable" it) by adding a '#' at the start of the line:
    Code:
    #export PATH="/root/anaconda3/bin:$PATH"
    #2 would only help with Plasma, but actually we added a workaround to startkde meanwhile (in Leap 42.3) to avoid this problem caused by the anaconda installer, so that's useless to try anyway.
    Last edited by wolfi323; 09-Jan-2018 at 03:15.

  5. #5

    Default Re: Unable to log in after installing anaconda

    Hi Wolfi323,

    Thanks, I am able to log in after commenting it out by adding a '#' at the start of the line.


    Code:
    Open the file /root/.bashrc in a text editor and remove this line:

    I am using GNOME by the way...and just for my future reference, the command to open and edit /root/.bashrc in text editor is:

    Code:
    gedit ~/.bashrc
    I am still learning the commands ......

    Thanks again!

  6. #6

    Default Re: Unable to log in after installing anaconda

    Quote Originally Posted by by79 View Post
    Thanks, I am able to log in after commenting it out by adding a '#' at the start of the line.
    Good!

    I am using GNOME by the way...
    Hm, that shouldn't be influenced by the custom Qt that anaconda comes with.

    Apparently there are other commands in /root/anaconda3/bin/ that would "clash" with the system's ones, I don't know as I never used or installed anaconda myself. (and I was only aware of that qtdbus-qt5 issue, that as I wrote is actually workarounded meanwhile in startkde)


    and just for my future reference, the command to open and edit /root/.bashrc in text editor is:

    Code:
    gedit ~/.bashrc
    I am still learning the commands ......
    Well, that's one option, there are of course many other text editors available too (both GUI and text mode).

    But you can also just run one (gedit e.g.) from the application menu (like you would normally run other applications), and then click on "Open File" or similar. .bashrc is a hidden file though, so you may have to turn on the display of hidden files in the file dialog (if possible).

  7. #7

    Default Re: Unable to log in after installing anaconda

    Thanks Wolfi323!

    To launch Anaconda, I will also need to make some changes to the bashrc file. I just follow the discussion below:

    https://forums.opensuse.org/showthre...light=anaconda



    Will need to insert:

    Code:
    export PATH="$PATH:/home/by79/anaconda3/bin"

  8. #8

    Default Re: Unable to log in after installing anaconda

    Quote Originally Posted by by79 View Post
    Will need to insert:

    Code:
    export PATH="$PATH:/home/by79/anaconda3/bin"
    That will only help if you installed it as user "by79", but you said you installed it as root.

    That line shouldn't break anything though, as it will only search Anaconda's directory for things that are not in the system's path.

    OTOH, you could just manually run the original command before starting Anaconda, or create a start script that does both.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •