Results 1 to 7 of 7

Thread: Wine 3.0~rc4-1.2: Cannot Configure

  1. #1

    Default Wine 3.0~rc4-1.2: Cannot Configure

    Performed zypper dup to update my Tumbleweed installations to openSUSE-release 20180104-1.2, and this also updated to Wine 3.0~rc4-1.2.

    Any attempt to configure this Wine update on multiple AMD CPU systems results in a totally frozen PC. Have never encountered issues configuring any preceding version of Wine.

    Short of waiting and hoping that a fix will be forthcoming soon, is there a way to downgrade to Wine 3.0~rc3-1.1, which presented no such problems. My wife is steaming now that she's dead in the water as far as using her old Quickbooks accounting package.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,236
    Blog Entries
    15

    Default Re: Wine 3.0~rc4-1.2: Cannot Configure

    Quote Originally Posted by sblass View Post
    Performed zypper dup to update my Tumbleweed installations to openSUSE-release 20180104-1.2, and this also updated to Wine 3.0~rc4-1.2.

    Any attempt to configure this Wine update on multiple AMD CPU systems results in a totally frozen PC. Have never encountered issues configuring any preceding version of Wine.

    Short of waiting and hoping that a fix will be forthcoming soon, is there a way to downgrade to Wine 3.0~rc3-1.1, which presented no such problems. My wife is steaming now that she's dead in the water as far as using her old Quickbooks accounting package.
    Hi
    It's a known issue with the kernel update and spectre/meltdown fixes. Fire up YaST Boot Loader and add the kernel command line option;

    Code:
    nopti
    Reboot and should be good to go.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Wine 3.0~rc4-1.2: Cannot Configure

    Thank you very much, Malcolm.

    Vielen Dank, mille grazie, muchas gracias, etc.

    The nopti kernel command line option did the trick. All is well with the world once again.

  4. #4

    Default Re: Wine 3.0~rc4-1.2: Cannot Configure

    Okay - my frustration level has just been ratcheted upwards another 2 points. Once again I cannot configure Wine without crashing the system!

    I used zypper dup to update two AMD PC's today, bringing the new kernel-default 4.14.12-1.4 and Wine 3.0-rc5-1.2. Not immediately wanting to find myself in the doghouse once again, I avoided (wisely so, it turns out) updating my wife's AMD desktop PC. The results from the two PC's...

    1. AMD FX-8310 Desktop PC (my Kdenlive rendering system)
    - Rebooted after the update, and then tried to configure Wine, resulting in a frozen system.
    - Rebooted system and used YaST boot loader and removed the nopti kernel command line option
    - Rebooted system and was able to configure Wine (seemingly!)
    - All subsequent attempts to run/configure Wine result in a hung system -- despite Wine seemingly having been configured in the previous step

    2. AMD Turion II P540 (yes it's old but it's still running like a top!)
    - Rebooted after the update, and then tried to configure Wine, resulting in a frozen system.
    - Rebooted system and used YaST boot loader and removed the nopti kernel command line option
    - Rebooted system, and then tried to configure Wine, resulting in a frozen system -- this PC hangs when configuring Wine with or without nopti kernel command line option!

    I have no clue what's wrong, but it might be a good idea, until we reach some stabilization, to have something textual included in the Addidtional rpm output:, which follows a kernel-default update, that could outline any temporarily required kernel comand line option changes.

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,236
    Blog Entries
    15

    Default Re: Wine 3.0~rc4-1.2: Cannot Configure

    Hi
    If you create a test user and login as that user can you configure wine?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6

    Default Re: Wine 3.0~rc4-1.2: Cannot Configure

    Quote Originally Posted by malcolmlewis View Post
    Hi
    If you create a test user and login as that user can you configure wine?
    Sadly, no.

    With nopti: immediately freezes machine

    without nopti: machine freezes shortly after the avoid-this-like-the-plague query to install Mono

  7. #7

    Default Re: Wine 3.0~rc4-1.2: Cannot Configure

    Quote Originally Posted by sblass View Post
    Sadly, no.

    With nopti: immediately freezes machine

    without nopti: machine freezes shortly after the avoid-this-like-the-plague query to install Mono
    The current 4.14.12 kernel is known to have problems that cannot be "fixed" with nopti (especially regarding 32bit apps like wine on AMD CPUs).

    Switch back to the previous kernel (4.14.11) and keep using nopti, or update to the latest one from Kernel:stable, which includes a fix already (but should appear soon in Tumbleweed too).

    See https://bugzilla.opensuse.org/show_b...?id=1074869#c8
    Last edited by wolfi323; 10-Jan-2018 at 01:55.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •