Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Bluetooth is turned on but no adapters are found?

  1. #1

    Question Bluetooth is turned on but no adapters are found?

    Hello openSUSE forums! And Happy New Year to everyone.

    I've had this issue since I switched over to openSUSE & haven't particularly cared until now. I've been wanting to connect a Bluetooth keyboard to my laptop where I have LEAP 42.3 installed.

    When I go to connect using the Bluetooth icon in my task bar it states "No Adapters Available." However, hwinfo in the terminal and Hardware Information in YaST both seem to recognize my Bluetooth device; so this makes me believe it's not a driver issue. I've got the Knsole hwinfo output below.

    In Windows my BT works fine. There isn't a specific Bluetooth on/off switch on my laptop (I have an Airplane Mode switch that turns everything wireless off). Due to me playing around & mucking up something with my prior openSUSE install I had to reinstall from scratch, so I'm working with a brand new 42.3 install w/o additional software (except Steam) and I've completed all of the zypper updates via Konsole.

    Can someone point me in the direction of additional troubleshooting or have some ideas on what might be the problem?
    Thanks a ton!

    Code:
    46: USB 00.0: 11500 Bluetooth Device
      [Created at usb.122]
      Unique ID: zFuK.tx4ZIeIPK4B
      Parent ID: k4bc.2DFUsyrieMD
      SysFS ID: /devices/pci0000:00/0000:00:14.0/usb1/1-8/1-8:1.0
      SysFS BusID: 1-8:1.0
      Hardware Class: bluetooth
      Model: "Qualcomm Atheros AR3012 Bluetooth 4.0"
      Hotplug: USB
      Vendor: usb 0x0cf3 "Qualcomm Atheros Communications"
      Device: usb 0x3004 "AR3012 Bluetooth 4.0"
      Revision: "0.01"
      Speed: 12 Mbps
      Module Alias: "usb:v0CF3p3004d0001dcE0dsc01dp01icE0isc01ip01in00"
      Driver Info #0:
        Driver Status: ath3k is active
        Driver Activation Cmd: "modprobe ath3k"
      Driver Info #1:
        Driver Status: btusb is active
        Driver Activation Cmd: "modprobe btusb"
      Config Status: cfg=new, avail=yes, need=no, active=unknown
      Attached to: #40 (Hub)
    YaST Hardware Information:
    https://imgur.com/a/yJSId

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,732

    Default AW: Bluetooth is turned on but no adapters are found?

    Maybe Firmware is missing?

    Please post:
    Code:
    rfkill list all

  3. #3

    Default Re: Bluetooth is turned on but no adapters are found?

    Doesn't appear as if rfkill is blocking it.

    Code:
    0: dell-rbtn: Wireless LAN
            Soft blocked: no
            Hard blocked: no
    1: phy0: Wireless LAN                                                                                                                                                                                                                                                          
            Soft blocked: no                                                                                                                                                                                                                                                       
            Hard blocked: no

  4. #4
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,558

    Default Re: Bluetooth is turned on but no adapters are found?

    maybe a read though the following link would help

    http://askubuntu.com/questions/63233...king-on-ubuntu

    it worked on a laptop hp-17-g105 (Pavilion)

  5. #5

    Thumbs up Re: Bluetooth is turned on but no adapters are found?

    Hey keellambert,
    Thanks for the suggestion. I went through the first & top rated answer, but since my Bluetooth isn't a Broadcom it didn't match up 1:1 with the advice given. I did my best to follow the directions & fill in the missing pieces, but that hasn't worked out for me. I can't quite find the right VID & PID numbers to complete the process.

    The second option for automating the process seems to be Broadcomm only advice.

    The third option I went through & thought I was making some headroom as besides the file names, all of the files types seem to match up correctly. Unfortunately in doing that all I did was stop openSUSE from seeing my WiFi & Bluetooth both, entirely. Luckily, I was able to roll back those changes.

    I think I'm going to have to settle for a 4th option which is to use a little USB Bluetooth receiver I found hidden in one of my drawers (always nice to keep little electronic trinkets around, eh?). openSUSE recognized it immediately and allowed me to pair my Logitech M720 Triathlon mouse. Not quite what I was hoping to use for a final solution but if it works, it works.

    Thanks a ton everyone for the assistance!

  6. #6
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,558

    Default Re: Bluetooth is turned on but no adapters are found?

    Hi Jim

    Quote Originally Posted by Jim_Survak View Post
    I can't quite find the right VID & PID numbers to complete the process.
    So the hwinfo contained in

    Vendor: usb 0x0cf3 "Qualcomm Atheros Communications"
    Device: usb 0x3004 "AR3012 Bluetooth 4.0"

    did not help?

  7. #7

    Default Re: Bluetooth is turned on but no adapters are found?

    There’s nothing in the .inf file which has the “0x3004” part. I’m happy to keep working on it though, despite’s my initial frustrations if you might have an idea of where to look.

  8. #8
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,732

    Default AW: Bluetooth is turned on but no adapters are found?

    Waht does this show, as root:
    Code:
    journalctl -b | grep -Ei 'firmware|blue|ath3k'

  9. #9
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,558

    Default Re: Bluetooth is turned on but no adapters are found?

    have a look at this

    https://bbs.archlinux.org/viewtopic.php?id=201646

    item #22

    for more recent info see

    https://bugs.launchpad.net/ubuntu/+s...z/+bug/1542743

    item #35

    best of luck

  10. #10

    Default Re: AW: Bluetooth is turned on but no adapters are found?

    Quote Originally Posted by Sauerland View Post
    Waht does this show, as root:
    Code:
    journalctl -b | grep -Ei 'firmware|blue|ath3k'
    Code:
    Jan 10 00:23:30 linux-v6gw kernel: [Firmware Bug]: ACPI(PEGP) defines _DOD but not _DOS
    Jan 10 00:23:32 linux-v6gw kernel: Bluetooth: Core ver 2.21
    Jan 10 00:23:32 linux-v6gw kernel: Bluetooth: HCI device and connection manager initialized
    Jan 10 00:23:32 linux-v6gw kernel: Bluetooth: HCI socket layer initialized
    Jan 10 00:23:32 linux-v6gw kernel: Bluetooth: L2CAP socket layer initialized
    Jan 10 00:23:32 linux-v6gw kernel: Bluetooth: SCO socket layer initialized
    Jan 10 00:23:32 linux-v6gw kernel: [Firmware Bug]: battery: (dis)charge rate invalid.
    Jan 10 00:23:32 linux-v6gw kernel: Bluetooth: hci0: BCM: chip id 73
    Jan 10 00:23:32 linux-v6gw kernel: usb 2-8: Direct firmware load for ar3k/AthrBT_0x00000200.dfu failed with error -2
    Jan 10 00:23:32 linux-v6gw kernel: Bluetooth: Patch file not found ar3k/AthrBT_0x00000200.dfu
    Jan 10 00:23:32 linux-v6gw kernel: Bluetooth: Loading patch file failed
    Jan 10 00:23:32 linux-v6gw kernel: ath3k: probe of 2-8:1.0 failed with error -2
    Jan 10 00:23:32 linux-v6gw kernel: usbcore: registered new interface driver ath3k
    Jan 10 00:23:32 linux-v6gw kernel: Bluetooth: hci0: linux-v6gw
    Jan 10 00:23:32 linux-v6gw kernel: Bluetooth: hci0: BCM20702B0 (002.001.014) build 0000
    Jan 10 00:23:32 linux-v6gw kernel: bluetooth hci0: Direct firmware load for brcm/BCM20702B0-19ff-0239.hcd failed with error -2
    Jan 10 00:23:32 linux-v6gw kernel: Bluetooth: hci0: BCM: Patch brcm/BCM20702B0-19ff-0239.hcd not found
    Jan 10 00:23:32 linux-v6gw kernel: ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/cal-pci-0000:01:00.0.bin failed with error -2
    Jan 10 00:23:33 linux-v6gw systemd[1]: Starting Bluetooth service...
    Jan 10 00:23:33 linux-v6gw bluetoothd[1012]: Bluetooth daemon 5.41
    Jan 10 00:23:33 linux-v6gw systemd[1]: Started Bluetooth service.
    Jan 10 00:23:33 linux-v6gw systemd[1]: Reached target Bluetooth.
    Jan 10 00:23:33 linux-v6gw bluetoothd[1012]: Starting SDP server
    Jan 10 00:23:33 linux-v6gw kernel: Bluetooth: BNEP (Ethernet Emulation) ver 1.3
    Jan 10 00:23:33 linux-v6gw kernel: Bluetooth: BNEP filters: protocol multicast
    Jan 10 00:23:33 linux-v6gw kernel: Bluetooth: BNEP socket layer initialized
    Jan 10 00:23:33 linux-v6gw bluetoothd[1012]: Bluetooth management interface 1.10 initialized
    Jan 10 00:23:33 linux-v6gw bluetoothd[1012]: Failed to obtain handles for "Service Changed" characteristic
    Jan 10 00:23:33 linux-v6gw bluetoothd[1012]: Sap driver initialization failed.
    Jan 10 00:23:33 linux-v6gw bluetoothd[1012]: sap-server: Operation not permitted (1)
    Jan 10 00:23:33 linux-v6gw NetworkManager[1032]: <info>  monitoring kernel firmware directory '/lib/firmware'.
    Jan 10 00:23:33 linux-v6gw NetworkManager[1032]: <info>  Loaded device plugin: NMBluezManager (/usr/lib64/NetworkManager/libnm-device-plugin-bluetooth.so)
    Jan 10 00:23:33 linux-v6gw NetworkManager[1032]: <info>  use BlueZ version 5
    Jan 10 00:23:36 linux-v6gw bluetoothd[1012]: Endpoint registered: sender=:1.30 path=/MediaEndpoint/A2DPSource
    Jan 10 00:23:36 linux-v6gw bluetoothd[1012]: Endpoint registered: sender=:1.30 path=/MediaEndpoint/A2DPSink
    Jan 10 00:23:36 linux-v6gw kernel: Bluetooth: RFCOMM TTY layer initialized
    Jan 10 00:23:36 linux-v6gw kernel: Bluetooth: RFCOMM socket layer initialized
    Jan 10 00:23:36 linux-v6gw kernel: Bluetooth: RFCOMM ver 1.11
    Jan 10 00:23:55 linux-v6gw bluetoothd[1012]: GATT service objects disabled
    Jan 10 00:23:55 linux-v6gw bluetoothd[1012]: bt_uhid_send: Invalid argument (22)
    Jan 10 00:23:55 linux-v6gw bluetoothd[1012]: bt_uhid_send: Invalid argument (22)
    Jan 10 00:23:55 linux-v6gw bluetoothd[1012]: bt_uhid_send: Invalid argument (22)
    Jan 10 00:23:55 linux-v6gw bluetoothd[1012]: bt_uhid_send: Invalid argument (22)
    Jan 10 00:23:55 linux-v6gw bluetoothd[1012]: bt_uhid_send: Invalid argument (22)
    Jan 10 00:23:55 linux-v6gw bluetoothd[1012]: bt_uhid_send: Invalid argument (22)
    Jan 10 00:23:55 linux-v6gw bluetoothd[1012]: bt_uhid_send: Invalid argument (22)
    Jan 10 00:23:55 linux-v6gw bluetoothd[1012]: bt_uhid_send: Invalid argument (22)
    Jan 10 00:23:55 linux-v6gw bluetoothd[1012]: bt_uhid_send: Invalid argument (22)
    Jan 10 00:23:55 linux-v6gw bluetoothd[1012]: bt_uhid_send: Invalid argument (22)
    Jan 10 00:23:55 linux-v6gw bluetoothd[1012]: bt_uhid_send: Invalid argument (22)
    Jan 10 00:23:55 linux-v6gw kernel: hid-generic 0005:046D:B015.0003: input,hidraw2: BLUETOOTH HID v0.07 Keyboard [M720 Triathlon] on 98:58:8A:04:DE:E5                                                                                                                   
    Jan 10 08:58:03 linux-v6gw bluetoothd[1012]: GATT service objects disabled
    Jan 10 09:00:54 linux-v6gw systemd[1]: bluetooth.target: Unit not needed anymore. Stopping.
    Jan 10 09:00:54 linux-v6gw systemd[1]: Stopped target Bluetooth.
    Jan 10 09:00:54 linux-v6gw bluetoothd[1012]: Endpoint unregistered: sender=:1.30 path=/MediaEndpoint/A2DPSource
    Jan 10 09:00:54 linux-v6gw bluetoothd[1012]: Endpoint unregistered: sender=:1.30 path=/MediaEndpoint/A2DPSink
    Jan 10 09:00:54 linux-v6gw dbus[864]: [system] Rejected send message, 10 matched rules; type="error", sender=":1.30" (uid=1000 pid=2103 comm="/usr/bin/pulseaudio --start --log-target=syslog ") interface="(unset)" member="(unset)" error name="org.bluez.MediaEndpoint1.Error.NotImplemented" requested_reply="0" destination=":1.8" (uid=0 pid=1012 comm="/usr/lib/bluetooth/bluetoothd ")
    Jan 10 09:00:54 linux-v6gw dbus[864]: [system] Rejected send message, 10 matched rules; type="error", sender=":1.30" (uid=1000 pid=2103 comm="/usr/bin/pulseaudio --start --log-target=syslog ") interface="(unset)" member="(unset)" error name="org.bluez.MediaEndpoint1.Error.NotImplemented" requested_reply="0" destination=":1.8" (uid=0 pid=1012 comm="/usr/lib/bluetooth/bluetoothd ")
    Jan 10 09:00:54 linux-v6gw dbus[864]: [system] Rejected send message, 10 matched rules; type="error", sender=":1.30" (uid=1000 pid=2103 comm="/usr/bin/pulseaudio --start --log-target=syslog ") interface="(unset)" member="(unset)" error name="org.bluez.MediaEndpoint1.Error.NotImplemented" requested_reply="0" destination=":1.8" (uid=0 pid=1012 comm="/usr/lib/bluetooth/bluetoothd ")
    Jan 10 09:00:54 linux-v6gw dbus[864]: [system] Rejected send message, 10 matched rules; type="error", sender=":1.30" (uid=1000 pid=2103 comm="/usr/bin/pulseaudio --start --log-target=syslog ") interface="(unset)" member="(unset)" error name="org.bluez.MediaEndpoint1.Error.NotImplemented" requested_reply="0" destination=":1.8" (uid=0 pid=1012 comm="/usr/lib/bluetooth/bluetoothd ")

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •