Results 1 to 3 of 3

Thread: Static IP address overlaid by DHCP

  1. #1

    Default Static IP address overlaid by DHCP

    I'm trying to run my Raspberry PI 3 as an application server and need a wired Static IP address. I used Wicked under Yast to set the IP address and everything works fine. I come back later and the Pi's IP address has changed to a DCHP administered address. I check with Yast and it shows my static address, but IFCONFIG shows the DHCP address, which also responds to ping. There seems to be a similar problem with Raspbian and the Pi 3. I'm fairly new to the Pi and openSUSE.

    Any ideas?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,325
    Blog Entries
    15

    Default Re: Static IP address overlaid by DHCP

    Quote Originally Posted by rgschmi View Post
    I'm trying to run my Raspberry PI 3 as an application server and need a wired Static IP address. I used Wicked under Yast to set the IP address and everything works fine. I come back later and the Pi's IP address has changed to a DCHP administered address. I check with Yast and it shows my static address, but IFCONFIG shows the DHCP address, which also responds to ping. There seems to be a similar problem with Raspbian and the Pi 3. I'm fairly new to the Pi and openSUSE.

    Any ideas?
    Hi
    I would suggest switching to Leap 42.3 since 42.2 goes EOL in a few weeks

    Under YaST Network Settings highlight your device and then tab to edit. Under the address tab it's set to Statically Assigned IP Address check box? Under Hostname/DNS it's all configured (hostname, domain, DNS and Domain Search) and Set Hostname via DHCP is set to no. Under Routing tab the default gateway is set?

    If you restart the network also, does it reset to the static address;
    Code:
    rcnetwork restart
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Static IP address overlaid by DHCP

    rgschmi,

    Thank you for posting as the issue is kicking my tail on latest (Leap 42.3) build of several Pi 2 B's. Had everything in place last weekend, and returned home to find DHCP. NMAP was helpful, tried both wicked and network manager (not sure of name) but as you stated; its become DHCP, yet ifconfig displays selected static, as well YAST displaying my settings.
    -Lukn

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •