Results 1 to 4 of 4

Thread: Dual Monitor is off after returning from suspend.

  1. #1
    Join Date
    Jun 2016
    Location
    NY
    Posts
    17

    Default Dual Monitor is off after returning from suspend.

    I've upgraded from Leap 42.1 to 42.3 and am having a problem with my second monitor not coming back up after I suspend using [WIN]L. I was surprised when I installed 42.3 that both monitors were found and configured. Under 42.1 I needed to install the AMD fglrx driver to get both monitors to work properly.

    I have AMD FX6800 PC with an AMD Radeon HD7770 graphics card. Leap 42.3 64-bit. Two monitors plugged into the card. The system boots fine, however when I suspend and return after a long time the 2nd monitor is not being driven. Over short time periods it both monitors return from suspend. The monitors are identical 1920x1080 @60Hz Samsung models. One is connected through a DVI cable. The one that fails is connected using a mini display port out to dvi adapter to drive dvi into the monitor. Both monitors and their connections worked under Leap 42.1 with AMD fglrx driver. Rebooting the system without powering off results in both monitors being driven.

    Any ideas on what to do would be appreciated. Thanks.

  2. #2
    Join Date
    Jun 2016
    Location
    NY
    Posts
    17

    Default Re: Dual Monitor is off after returning from suspend.

    Quote Originally Posted by ksanger View Post
    I've upgraded from Leap 42.1 to 42.3 and am having a problem with my second monitor not coming back up after I suspend using [WIN]L. I was surprised when I installed 42.3 that both monitors were found and configured. Under 42.1 I needed to install the AMD fglrx driver to get both monitors to work properly.

    I have AMD FX6800 PC with an AMD Radeon HD7770 graphics card. Leap 42.3 64-bit. Two monitors plugged into the card. The system boots fine, however when I suspend and return after a long time the 2nd monitor is not being driven. Over short time periods it both monitors return from suspend. The monitors are identical 1920x1080 @60Hz Samsung models. One is connected through a DVI cable. The one that fails is connected using a mini display port out to dvi adapter to drive dvi into the monitor. Both monitors and their connections worked under Leap 42.1 with AMD fglrx driver. Rebooting the system without powering off results in both monitors being driven.

    Any ideas on what to do would be appreciated. Thanks.
    I have no solution. Note I use Gnome GUI.

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: Dual Monitor is off after returning from suspend.

    There seem to be numerous display port issues described like this if one searches "display port monitor off after resume" and similar. Does power-cycling the monitor help in such a situation?

  4. #4
    Join Date
    Jun 2016
    Location
    NY
    Posts
    17

    Default Re: Dual Monitor is off after returning from suspend.

    Quote Originally Posted by deano_ferrari View Post
    There seem to be numerous display port issues described like this if one searches "display port monitor off after resume" and similar. Does power-cycling the monitor help in such a situation?
    Power cycling the monitor does not work. Rebooting works.

    I fixed this by upgrading from two 22" 1080P monitors to one 40" 4K UHDTV being driven by hdmi. Now using one "monitor" instead of two with twice the number of displayed pixels. Unfortunately the AMD Radeon HD7770 only supports 30 Hz at 4K resolution. But I'm not gaming and I'll live with it for a while.
    Last edited by ksanger; 21-Jan-2018 at 15:55. Reason: spelling error

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •