Results 1 to 7 of 7

Thread: Firefox and Thunderbird do not recognize newly established network connection

  1. #1

    Default Firefox and Thunderbird do not recognize newly established network connection

    Hi,

    I experience a problem where Firefox and Thunderbird (but no other programs) will not not recognize a newly established internet connection after it was lost. I have no proxy set. Chrome works flawlessly.

    Anyone experiencing the same problem?

    Thanks!

  2. #2

    Default Re: Firefox and Thunderbird do not recognize newly established network connection


  3. #3

    Default Re: Firefox and Thunderbird do not recognize newly established network connection

    Quote Originally Posted by Karut View Post
    Hi,

    I experience a problem where Firefox and Thunderbird (but no other programs) will not not recognize a newly established internet connection after it was lost. I have no proxy set. Chrome works flawlessly.

    Anyone experiencing the same problem?

    Thanks!
    Yes, me only with firefox, I didn't try with thunderbird

  4. #4

    Default Re: Firefox and Thunderbird do not recognize newly established network connection

    A workaround for Firefox being connected right after booting is presented here. Works for me. Obviously the problem occurs not only directly after boot.

    Good to know its not just me...

  5. #5
    Join Date
    Jan 2017
    Location
    Russia
    Posts
    21

    Default Re: Firefox and Thunderbird do not recognize newly established network connection

    3 months ago I've updated my main stationary PC from Leap 42.2 to Tumbleweed. Leap used Wicked service as default network setting for wired connection. It slowed down the boot time, but anyway, worked.
    After update, which brought the Network manager as default I began experiencing the described problems. For wired connection it does not ask any password and do not trigger kwallet.

    Reading the mentioned topic I've checked settings for default "Wired connection 1" and it is in 'All users may connect to this network' state by default.
    Switching to Wicked resolved the problem with the price of some seconds during boot. But, as I understand, Wicked is no more under development.

    This must be a widely reproduced bug, I wonder why it is not reported before...

  6. #6
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    2,238

    Default Re: Firefox and Thunderbird do not recognize newly established network connection

    Quote Originally Posted by pier_andreit View Post
    Yes, me only with firefox, I didn't try with thunderbird
    +1, not using Thunderbird here.
    I didn't investigate further, just restarting Firefox when it occasionally happens (e.g. when walking from one WiFi access point to another).
    Tumbleweed Gnome on i7 4720HQ + Geforce GTX960M
    testing Leap 15.3

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,681
    Blog Entries
    3

    Default Re: Firefox and Thunderbird do not recognize newly established network connection

    The firefox "File" menu has a setting for "Work offline". Maybe you just have to toggle that.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •