Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: KDE's audio volume is empty

  1. #1

    Default KDE's audio volume is empty

    I've just installed LEAP 42.3 and

    KDE System Settings > Hardware > Multimedia > Audio Volume

    is completely empty (even after configuring the sound card through YAST). I had the same problem with LEAP 42.2 but back then some fiddling around managed to solve the problem (somehow).

    NOTE: Sound works fine. Test sounds, music and video all work; I've gone the multimedia guide.

    So the audio volume in the system tray is the only thing that doesn't do its job. How can I solve this?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,698
    Blog Entries
    1

    Default Re: KDE's audio volume is empty

    Quote Originally Posted by ae_lex View Post
    I've just installed LEAP 42.3 and

    KDE System Settings > Hardware > Multimedia > Audio Volume

    is completely empty (even after configuring the sound card through YAST). I had the same problem with LEAP 42.2 but back then some fiddling around managed to solve the problem (somehow).

    NOTE: Sound works fine. Test sounds, music and video all work; I've gone the multimedia guide.

    So the audio volume in the system tray is the only thing that doesn't do its job. How can I solve this?
    Is PulseAudio running? Check with
    Code:
    setup-pulseaudio --status
    or
    Code:
    ps -A|grep pulse
    If necessary enable it with
    Code:
    sudo setup-pulseaudio --enable
    Do you now have mixer devices present? Can you play a test sound via PulseAudio successfully?
    Code:
    paplay /usr/share/sounds/alsa/test.wav
    If not, try removing any existing user configuration
    Code:
    rm -f ~/rm -rf ~/.config/pulse
    then kill the daemon with
    Code:
    pulseaudio -k
    It will respawn automatically by default. Any different?

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,668
    Blog Entries
    3

    Default Re: KDE's audio volume is empty

    Quote Originally Posted by ae_lex View Post
    KDE System Settings > Hardware > Multimedia > Audio Volume

    is completely empty (even after configuring the sound card through YAST).
    I just tried that.

    I found two things there. I found "Notification Sounds" (set to 0%),
    and I found "virt-manager: playback" set to 73%.

    I happened to be running "virt-manager". If I were not running that, then I would have only had "Notification Sounds". And if I had disabled notification sounds, then it would not be surprising if there was nothing there.

    So I started playing some music with Amarok. And that immediately showed up in the Audio Volume window.

    So my question: were you actually playing any sounds at the time you opened the audio volume window?
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,698
    Blog Entries
    1

    Default Re: KDE's audio volume is empty

    Quote Originally Posted by nrickert View Post
    I just tried that.

    I found two things there. I found "Notification Sounds" (set to 0%),
    and I found "virt-manager: playback" set to 73%.

    I happened to be running "virt-manager". If I were not running that, then I would have only had "Notification Sounds". And if I had disabled notification sounds, then it would not be surprising if there was nothing there.

    So I started playing some music with Amarok. And that immediately showed up in the Audio Volume window.

    So my question: were you actually playing any sounds at the time you opened the audio volume window?
    Output devices should still be present though. The OP needs to clarify a little more perhaps.

  5. #5

    Default Re: KDE's audio volume is empty

    Quote Originally Posted by deano_ferrari View Post
    Is PulseAudio running? Check with
    Code:
    setup-pulseaudio --status
    Yes. It says "enabled".

    Quote Originally Posted by deano_ferrari View Post
    Do you now have mixer devices present? Can you play a test sound via PulseAudio successfully?
    Code:
    paplay /usr/share/sounds/alsa/test.wav
    That plays fine.

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,698
    Blog Entries
    1

    Default Re: KDE's audio volume is empty

    So far, so good....and is it the 'Device' mixers that are missing from the KDE mixer?

  7. #7

    Default Re: KDE's audio volume is empty

    Quote Originally Posted by deano_ferrari View Post
    Output devices should still be present though. The OP needs to clarify a little more perhaps.
    As for the applications tab: it's not showing anything when I'm playing music or video. It remains empty. Thanks nrickert for making me check that.

    As for the devices tab: that's empty as well. This was the problem I noticed.

    Quote Originally Posted by deano_ferrari View Post
    So far, so good....and is it the 'Device' mixers that are missing from the KDE mixer?
    Yes.

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,698
    Blog Entries
    1

    Default Re: KDE's audio volume is empty

    Post the output of
    Code:
    pacmd list-sinks
    *This should be representative of the output mixer device(s) available to you.

    You can also use the PA volume control GUI
    Code:
    pavucontrol
    If not present, it can be installed with
    Code:
    zypper in pavucontrol

  9. #9

    Default Re: KDE's audio volume is empty

    So I was checking

    KDE System Settings > Hardware > Multimedia > Audio and Video

    and I noticed the "Audio Hardware Setup" tab is missing (in the fresh profile compared to the old profile).

  10. #10

    Default Re: KDE's audio volume is empty

    Quote Originally Posted by deano_ferrari View Post
    Post the output of
    Code:
    pacmd list-sinks
    *This should be representative of the output mixer device(s) available to you.

    You can also use the PA volume control GUI
    Code:
    pavucontrol
    If not present, it can be installed with
    Code:
    zypper in pavucontrol
    Code:
    No PulseAudio daemon running, or not running as session daemon.
    pavucontrol wasn't installed so I installed it

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •