Results 1 to 3 of 3

Thread: configuring wifi on installation (Usability)

  1. #1
    Join Date
    Jun 2016
    Location
    German-speaking Europe
    Posts
    24

    Lightbulb configuring wifi on installation (Usability)

    Hello everyone

    When I recently installed Leap again and around a month ago Tumbleweed, I though (again), that I found the Installer options for the networking part unnecessarily complicated. Perhaps there are good reasons for this being as it is. Or just no one took some time to change anything here (e.g. having other priorities in life, which is absolutely legitimate).
    At least for the simple case of a home user installing and connecting to a home network via wifi, it’s overly complicated. At least unfamiliar users have an unnecessarily hard time with that. Is there something I can read up on this or are there plans for changing something? (Or reasons to leave it as it is?). I didn’t check a pre-release of Leap 15 yet. If desired I would be willing to contribute, but my programming skills are “novice” level, nor do I have any knowledge about the inner workings or YAST or anything associated with it, but would be willing to learn.
    Any hints or information appreciated. And in general, big thanks to everyone’s hard work and passion that went into this great distribution!
    With best wishes,
    Simon

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: configuring wifi on installation (Usability)

    The problems mostly are due to hardware that requires proprietary drivers. openSUSE is as it is named is open source only and does not come with any proprietary software. If you need such you must install it.

  3. #3

    Default Re: configuring wifi on installation (Usability)

    Here are the notes that just used today to get my wi-fi up and running on opensuse 42.3
    I am using verizon wifi.

    Plug in WIFI to computer via usb cable

    when possible install broadcom thru YAST

    (1)
    Yast > Network Settings > Global Options > General Network Settings > change from Wicked to NetworkManager Service
    (2) Control Center All Settings > Network (ON) > WI-FI > enter wifi password

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •