Page 5 of 5 FirstFirst ... 345
Results 41 to 48 of 48

Thread: Nvidia driver problems

  1. #41

    Default Re: Nvidia driver problems

    Quote Originally Posted by V_idocq View Post
    Of course, the repository is more convenient, but I tried and it does not go with the Driver 384.98
    The repo has been updated meanwhile (to 384.111), so hopefully the RPMs work again.

    Changelog:
    -------------------------------------------------------------------
    Mon Jan 8 14:40:45 UTC 2018 - sndirsch@suse.com

    - update to latest long lived branch version 384.111
    * Added support for the following GPUs:
    + GeForce MX130
    + GeForce MX110
    + GeForce GTX 1050 Ti with Max-Q Design
    + Quadro P500
    * Fixed a regression that prevented displays connected via some types of
    passive adapters (e.g. DMS-59 to VGA or DVI) from working correctly.
    The regression was introduced with driver version 384.98.
    * Fixed a bug that caused Quadro M2200 GPUs to enter the lowest available
    PowerMizer performance level when under load.
    - supersedes patches delete_read_kernel.patch, kernel-4.14.9-buildfix.patch

    -------------------------------------------------------------------
    Tue Jan 2 15:11:44 UTC 2018 - sndirsch@suse.com

    - kernel-4.14.9-buildfix.patch
    * Fix build with kernel 4.14.9
    - BuildRequires: libelf-devel no longer needed
    Last edited by wolfi323; 09-Jan-2018 at 04:33. Reason: added changelog entries

  2. #42
    Join Date
    Dec 2014
    Location
    Roma
    Posts
    62

    Default Re: Nvidia driver problems

    Quote Originally Posted by dragoncello21 View Post
    the new nvidia 384.111 came out but I can not install them because it does not let me enter init 3, why?

    why not let me enter init 3

  3. #43
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,743

    Default Re: Nvidia driver problems

    As root??? error messages?????

    Get to run level 3 from boot menu???

  4. #44

    Default Re: Nvidia driver problems

    Quote Originally Posted by gogalthorp View Post
    Get to run level 3 from boot menu???
    Right, I would suggest that too.

    Press 'e' at the boot menu and append the digit '3' at the end of the line starting with "linux" or "linuxefi".
    Your system will boot to text mode ("run level 3") then.

    And just to avoid possible misunderstandings here: this is only needed when installing "the hard way", i.e. using nvidia's .run installer.
    The driver RPM packages in the nvidia repo can be installed just fine in a graphical session.

  5. #45
    Join Date
    Apr 2017
    Location
    Piemont
    Posts
    274

    Default Re: Nvidia driver problems

    Quote Originally Posted by dragoncello21 View Post
    why not let me enter init 3
    I login Ctrl + Alt + F2, and then install the Nvidia.run Driver

    Quote Originally Posted by wolfi323 View Post
    The repo has been updated meanwhile (to 384.111), so hopefully the RPMs work again.

    Changelog:
    Thanks wolfi323 I had already seen the update last night, but I was tired.
    I confirm that now with the update of the Repo the Nvidia Drivers work with the new 4.14.11 kernel
    loyalty returns to those who practice it

  6. #46
    Join Date
    Dec 2014
    Location
    Roma
    Posts
    62

    Default Re: Nvidia driver problems

    yes as root do the command to enter init 3 but it remains there without errors, I install the drivers, in run,
    now it is not necessary to load the drives on the nvidia repo 384.111 and they are also good with the 4.14.12 kernel
    thank you

  7. #47

    Default Re: Nvidia driver problems

    Quote Originally Posted by dragoncello21 View Post
    yes as root do the command to enter init 3 but it remains there without errors
    That's actually normal if you switch to text mode with Ctrl+Alt+Fx and run init 3 there.
    As you are in text mode already, you won't notice any changes done by init 3.

    The X session (which is still running in the background) should get terminated anyway, best to logout there first though.

  8. #48

    Default Re: Nvidia driver problems

    Pretty sure driver 390.12 took down my system today. Locked my screen and everything froze except the mouse. No lock screen appeared. Killed screenlocker from console with "loginctl unlock-sessions", but now black screen for X. "init 3" hung from console as root. "reboot" worked. My system came back up because I use ext4. :^)

Page 5 of 5 FirstFirst ... 345

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •