Results 1 to 3 of 3

Thread: Gigabyte GA990FX-Gaming Motherboard -- OpenSUSE Leap 42.3 -- USB 2.0 Ports Non-functional, 3.0 Fine

  1. #1
    Join Date
    Oct 2016
    Location
    USA
    Posts
    92

    Default Gigabyte GA990FX-Gaming Motherboard -- OpenSUSE Leap 42.3 -- USB 2.0 Ports Non-functional, 3.0 Fine

    Good day, all, and a happy new year. I have recently installed OpenSUSE Leap 42.3 on my father's computer, and one of very few unexpected behaviours comes from the USB 2.0 ports. They do not work once it is booted into OpenSUSE. They work well in the BIOS (Gigabyte GA990FX-Gaming motherboard), and in windows, but not once booted into Linux. The 3.0 are normal. I did some searching online and found some mention of the IOMMU controller on Gigabyte AMD motherboards having something to do with this, and indeed, when I enabled the IOMMU controller in the BIOS, the USB 2.0 ports functioned as expected, but both the USB 3.0 ports and the network card became non-functional. Under YAST's hardware probe, all of the USB ports show up as either XHCI or EHCI root hubs, so I decided to mess around with the XHCI and EHCI handoff settings in BIOS, and I could find no configuration that made any difference to the USB situation.

    The hardware is all relatively recent; AMD FX 6300 CPU, 32GB DDR3 RAM, 120GB SSD boot disk, and as mentioned, a Gigabyte GA990FX-Gaming motherboard.

    I am grateful for your taking the time to read this, and will be yet more so for any advice which is offered.

    Take care!
    --Henry Wilson

  2. #2
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,140

    Default Re: Gigabyte GA990FX-Gaming Motherboard -- OpenSUSE Leap 42.3 -- USB 2.0 Ports Non-functional, 3.0 F

    Quote Originally Posted by Amlypygid View Post
    so I decided to mess around with the XHCI and EHCI handoff settings in BIOS, and I could find no configuration that made any difference to the USB situation.
    In the BIOS set:

    Enable XHCI Handoff

    Disable EHCI Handoff

    Enable IOMMU


    Add the following to the kernel command line: (Yast -> Boot Loader -> Kernel Parameters)

    Code:
    amd_iommu=on iommu=pt
    Regards, Paul

    Tumbleweed (Snapshot: 20190716) KDE Plasma 5
    Leap 15.0 KDE Plasma 5
    [Non-Tumbling Tumblweed (20150508) KDE 4 - Resurrected]

  3. #3
    Join Date
    Oct 2016
    Location
    USA
    Posts
    92

    Default Re: Gigabyte GA990FX-Gaming Motherboard -- OpenSUSE Leap 42.3 -- USB 2.0 Ports Non-functional, 3.0 F

    Thanks, tannington, this worked. The only thing odd that it caused was a change in the boot order of my drives -- the list was completely reorganized, and I could not put it back in the original order. OpenSUSE Secure Boot kept rising to the top, and I had to remove it so that windows, which my dad still hasn't completely been freed from, will be the default option. That was easy enough, though.

    Thanks so much, and have a great year,
    --Henry Wilson

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •