Results 1 to 5 of 5

Thread: rng-tools configuration

  1. #1

    Default rng-tools configuration

    Hi there,

    I am trying to configure a usb true random number generator from ubld.it. I have been following their instructions as shown on their website http://ubld.it/products/support/truerng-install-guide. The problem is, I cannot find the configuration for the rng-tools initscript. Do you guys know where to locate it?

    Thanks for all your help
    Ron

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,352
    Blog Entries
    15

    Default Re: rng-tools configuration

    Hi and welcome to the Forum
    We use systemd these days so it a service file no init scripts;
    Code:
    systemctl status rng-tools (is it running?)
    systemctl start rng-tools (if not start it)
    systemctl enable rng-tools (for it to start on boot)
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: rng-tools configuration

    Hi Malcolm,

    Thanks for replying and providing information regarding rng-tools. I have another question. How do I modify the rng-tools to set the input source for random data as following HRNGDEVICE=/dev/TrueRNG?

    Thanks,
    Ron

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,352
    Blog Entries
    15

    Default Re: rng-tools configuration

    On Tue 02 Jan 2018 10:46:02 AM CST, undbund wrote:

    Hi Malcolm,

    Thanks for replying and providing information regarding rng-tools. I
    have another question. How do I modify the rng-tools to set the input
    source for random data as following HRNGDEVICE=/dev/TrueRNG?

    Thanks,
    Ron


    Hi
    I would suggest editing the service file and adding your option in
    the [service] part;

    Code:
    Environment=HRNGDEVICE=/dev/TrueRNG
    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.3|GNOME 3.20.2|4.4.103-36-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  5. #5

    Thumbs up Re: rng-tools configuration

    It is working !!!

    Thanks for your time and help Malcolm

    Cheers!
    Ron

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •