Results 1 to 5 of 5

Thread: Kernel 4.4.103 & Qualcomm Atheros Device

  1. #1
    Join Date
    Jun 2008
    Location
    Melbourne, AU
    Posts
    23

    Question Kernel 4.4.103 & Qualcomm Atheros Device

    Brought new laptop today...WiFi works, but LAN doesn't. Seen other posts about Qualcomm and support in older kernels, and their links to sites with issues or 404 responses....so they're not overly helpful.

    Code:
    :~ # lspci -nnk | grep -A3 Ethernet
    3d:00.0 Ethernet controller [0200]: Qualcomm Atheros Device [1969:e0b1] (rev 10)
            Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:11ad]
    3e:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32)
            Subsystem: Bigfoot Networks, Inc. Device [1a56:1535]

  2. #2
    Join Date
    Jun 2008
    Location
    Melbourne, AU
    Posts
    23

    Default Re: Kernel 4.4.103 & Qualcomm Atheros Device

    Quote Originally Posted by ScorpionSting View Post
    Brought new laptop today...WiFi works, but LAN doesn't. Seen other posts about Qualcomm and support in older kernels, and their links to sites with issues or 404 responses....so they're not overly helpful.

    Code:
    :~ # lspci -nnk | grep -A3 Ethernet
    3d:00.0 Ethernet controller [0200]: Qualcomm Atheros Device [1969:e0b1] (rev 10)
            Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:11ad]
    3e:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32)
            Subsystem: Bigfoot Networks, Inc. Device [1a56:1535]
    Code:
      P: /devices/pci0000:00/0000:00:1d.5/0000:3d:00.0
      E: DEVPATH=/devices/pci0000:00/0000:00:1d.5/0000:3d:00.0
      E: ID_PCI_CLASS_FROM_DATABASE=Network controller
      E: ID_PCI_SUBCLASS_FROM_DATABASE=Ethernet controller
      E: ID_VENDOR_FROM_DATABASE=Qualcomm Atheros
      E: MODALIAS=pci:v00001969d0000E0B1sv00001462sd000011ADbc02sc00i00
      E: PCI_CLASS=20000
      E: PCI_ID=1969:E0B1
      E: PCI_SLOT_NAME=0000:3d:00.0
      E: PCI_SUBSYS_ID=1462:11AD
      E: SUBSYSTEM=pci
      E: USEC_INITIALIZED=4954883

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: Kernel 4.4.103 & Qualcomm Atheros Device

    Switching to a newer kernel is might be necessary, but in the meantime try adding the product and vendor ID like this
    Code:
    modprobe alx
    Code:
    echo 1969 e0b1 > /sys/bus/pci/drivers/alx/new_id
    Does that work? It won't survive a reboot, but can be added to a boot script if it works.

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,728

    Default AW: Kernel 4.4.103 & Qualcomm Atheros Device

    Maybe this Repo (s)
    https://build.opensuse.org/package/s...heros-ethernet

    Depends on your current kernel, when updated this Repo:
    https://download.opensuse.org/reposi...p_42.3_Update/

    Otherwise if a fresh not updated System this one:
    https://download.opensuse.org/reposi...USE_Leap_42.3/
    After that the Update Repo above.

  5. #5
    Join Date
    Jun 2008
    Location
    Melbourne, AU
    Posts
    23

    Default Re: Kernel 4.4.103 & Qualcomm Atheros Device

    Quote Originally Posted by deano_ferrari View Post
    Switching to a newer kernel is might be necessary, but in the meantime try adding the product and vendor ID like this
    Code:
    modprobe alx
    Code:
    echo 1969 e0b1 > /sys/bus/pci/drivers/alx/new_id
    Does that work? It won't survive a reboot, but can be added to a boot script if it works.
    Thanks, that got eth0 up...will script it for now until an updated kernel comes out.

    Will skip next post's suggestion as don't want to risk other issues that may occur

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •