Hi folks,
I'm running OpenSUSE Tumbleweed, here's some quick details about the system:
Code:
bog@linuxSuSe ~ [0]$ uname -a
Linux linuxSuSe 4.14.4-1-default #1 SMP PREEMPT Tue Dec 5 14:58:24 UTC 2017 (b29439c) x86_64 x86_64 x86_64 GNU/Linux
bog@linuxSuSe ~ [0]$ cat /etc/os-release
NAME="openSUSE Tumbleweed"
# VERSION="20171222 "
ID=opensuse
ID_LIKE="suse"
VERSION_ID="20171222"
PRETTY_NAME="openSUSE Tumbleweed"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:tumbleweed:20171222"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://www.opensuse.org/"
Starting about 1 month ago, i've begun to experience a peculiar problem with the zypper package manager.
Opening the visual package manager from Yast and selecting a few changes to make, then click apply, everything seems to go well, packages get downloaded, installed, packages marked for deletion get deleted.
But at the end I get an empty summary view. The problem is if I click continue I will see all the packages back in the manager exactly as they were before I applied the changes.
Now if I select the same changes again and click apply, it will run again (same packages will download and install again), but I will get warnings during delete package phase because they were already deleted, but somehow the package manager forgot about that. If i ignore all delete warnings, I will get a correct summary 2nd time, and everything will be ok, the packages will show up as installed / deleted back in the list.

Running zypper manually from command line doesn't have this problem.

What can I do to fix this, it's a big issue when doing many changes at a time because I have to go back and redo them again each time.