Results 1 to 6 of 6

Thread: (12/2017 ver.) cups does not print

  1. #1

    Default (12/2017 ver.) cups does not print

    I have many computers running opensuse tumbleweed. I just did a clean install on my laptop, using the current Tumbleweed iso. CUPS and YAST printer tool can find and install my printers that are on the local LAN. But, the printers do not respond and test pages do not print. I can't ping the printers via IP address and I can't find the printers via IP address in the CUPS or YAST add printer tools. I have turned the laptop firewall off via YAST. (Printers could not be "found" while firewall was on. I normally install via socket://[IP]:9100, but that is not working either. I can print from other computers on the same network, to the same printers identified by the laptop CUPS install.

    I removed and reinstalled all cups-related files, it didn't help. It seems like there may be some sort of firewall problem, but I am unable to identify it.

    Any ideas what else to do?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,698
    Blog Entries
    1

    Default Re: (12/2017 ver.) cups does not print

    Quote Originally Posted by daltrey View Post
    I have many computers running opensuse tumbleweed. I just did a clean install on my laptop, using the current Tumbleweed iso. CUPS and YAST printer tool can find and install my printers that are on the local LAN. But, the printers do not respond and test pages do not print.
    This may well be due to an incorrect printer driver.

    I can't ping the printers via IP address and I can't find the printers via IP address in the CUPS or YAST add printer tools. I have turned the laptop firewall off via YAST. (Printers could not be "found" while firewall was on.
    That is as expected. For CUPS 'auto-detection' to work when configuring it is best to stop the firewall temporarily since it relies on printer broadcasts (eg Avahi, SNMP) to work.

    Any ideas what else to do?
    The first thing to do is provide printer model details.

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,698
    Blog Entries
    1

    Default Re: (12/2017 ver.) cups does not print

    BTW, can you ping the target printer successfully by its configured IP address?

    What does an nmap scan return for the given printer IP address?
    Code:
    nmap <Printer IP address>

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,698
    Blog Entries
    1

    Default Re: (12/2017 ver.) cups does not print

    Oops - I missed your opening comments about not being able to ping the network printers by IP address. This implies a networking issue to sort (rather than a CUPS configuration issue). Do you have connectivity to the LAN? Can you at least ping the gateway router?

    What do the following return?
    Code:
    ip address
    Code:
    ip route
    Are the printers configured with known valid static IP addresses?

  5. #5

    Default Re: (12/2017 ver.) cups does not print [SOLVED]

    [I didn't see a way to edit my original post as "Solved", so I am putting it here.]

    Correct deduction - NETWORKING PROBLEM, solved by restarting my cable modem. Simple when you know the modem might be a problem, not easy when you don't. By process of elimination, I discovered the problem was only on the wireless card -- ethernet would work -- and then, that it was also on the same network card in the Win10 dual boot. I had checked my login to the modem looking for some sort of firewall or filtering, but could not find anything and couldn't find anything in the manual. I verified the wireless problem was isolated to my laptop by connecting via another laptop. Somewhere, I found a reference to "resetting the router/modem" -- and why this should be, I do not know. But, it worked. After resetting modem, I could ping all the devices on the LAN (same as I could via ethernet or via other computers) and so problem solved.

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,698
    Blog Entries
    1

    Default Re: (12/2017 ver.) cups does not print [SOLVED]

    Yes, always pays to make sure you have network connectivity first.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •