Results 1 to 4 of 4

Thread: tuxmath does not speedup

  1. #1

    Default tuxmath does not speedup

    Hi all

    This problem has followed me every since upgrading from Opensuse 13.2 to Leap. That's why we kept a laptop on 13.2. Yesterday, said laptop stopped working. So here I go:

    Systems: Lenovo x250, x260, L540 and T500, all running 42.3 smoothly, kept updated daily. We use de_CH language and number formats.

    Tuxmath:
    rpm -qa | grep tuxmath
    tuxmath-2.0.3-2.2.x86_64

    Attempts to solve the problem:
    1. I changed "speedup_factor = 1,00" to speedup_factor = 1.50" parameter in "usershome/.tuxmath/options". That should give a considerable and noticeable boost, in vain. To my surprise the file was still at "speedup_factor = 1,00".
      Conclusion: tuxmath either copies the file "options" from somewhere or composes it new based on some configuration file placed where?
    2. "cd / && find -name tuxmath*" pointed me to "./usr/share/tuxmath". In subdir "missions" there is a file named "options". I thought, I got it. Checked for / changed to the following parameters:
      Code:
      allow_speedup = 1
      use_feedback = 0
      speedup_factor = 1.80
      Thinking I had the solution, I deleted "usershome/.tuxmath/options" and started tuxmath again, ran arcade/ranger: in vain, same speed through 10 waves. I checked for the above mentioned contents after the test play and they still were there.
    3. Digging deeper, I found in subdir "./usr/share/tuxmath/missions/arcade/" files for the different skill levels:
      Code:
      /usr/share/tuxmath/missions/arcade # ls 
      ace  commando  ranger  scout  space_cadet
      So I changed te parameters as listed above, saved, verified, they are as set, deleted "usershome/.tuxmath/options", test play, again in vain. One thing, that I noted though:
      In "usershome/.tuxmath/options, decimals are as "1,00" (note the comma) where in "/usr/share/tuxmath/missions/arcade" they are as "1.80" (note the dot).
      So, either tuxmath sees the specified "1.80" and conerts it to "1.00" (the default value), maybe because it cannot convert "1.80" correctly (bug or laguage setup problem?), or there must be another place or way tuxmath gets its options file together or from.


    I definitely need help here, which is greatly appreciated.

    greez and thanks in advance
    chris

  2. #2

    Default Re: tuxmath does not speedup

    Hi all
    No one can help?
    greez
    chris

  3. #3
    Join Date
    Jun 2008
    Location
    Saint-Petersburg, Russia
    Posts
    69

    Default Re: tuxmath does not speedup

    Editing /usr/share/tuxmath/missions/arcade/space_cadet works for me. I changed this line
    Code:
    speed = 10.00
    and Play Arcade Game -> Space Cadet did really speed up

  4. #4

    Default Re: tuxmath does not speedup

    Hi
    It does set the basic speed up. However increasing the speed on a per wave basis does not happen.

    My feeling is, it has to do with the the "." (dots => de_CH) and "," (comma => de_DE) in the number format. These differ in de_CH Swiss use "." dots, Germans use "," .

    Greez
    chris
    PS: we are meanwhile on Leap 15.0

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •