Results 1 to 4 of 4

Thread: Verwijderen van niet bestaande programma's

  1. #1

    Default Verwijderen van niet bestaande programma's

    Als ik upgrade krijg ik melding van programma's die verwijderd worden, echter daar staan er ook bij die niet geinstalleerd staan blijkbaar. Ik krijg dus foutmeldingen. Hoe krijg ik dit opgelost?
    Ik heb het tussen de codetags geplaatst.

    Code:
    fred@localhost:~> sudo zypper dup
    [sudo] wachtwoord voor root:  
    Waarschuwing: U staat op het punt een distributie-update uit te voeren met alle installatiebronnen ingeschakeld. Verzeker u ervan dat alle installatiebronnen compatibel zijn met elkaar voordat u verder gaat. Zie 'man zypper' voor meer informatie over dit commando.
    Gegevens van installatiebron laden...
    Lezen van geïnstalleerde pakketten...
    Distributie-upgrades berekenen...
    
    De volgende 8 pakketten zullen worden VERWIJDERD:
      bundle-lang-common-en bundle-lang-common-nl bundle-lang-gnome-en bundle-lang-gnome-nl bundle-lang-kde-en bundle-lang-kde-nl libreoffice-branding-upstream libreoffice-icon-theme-galaxy
    
    8 te verwijderen pakketten.
    Na de bewerking zal 32,6 MiB worden vrijgemaakt.
    Doorgaan? [j/n/...? alle opties tonen] (j): 
    (1/8) Verwijderen van bundle-lang-common-en-13.2-58.1.noarch ............................................................................................................................................................................................................[fout]
    Verwijderen van (64658)bundle-lang-common-en-13.2-58.1.noarch(@System) is mislukt:
    Fout: Subprocess failed. Error: RPM is mislukt: error: package bundle-lang-common-en-13.2-58.1.noarch is not installed
    
    Afbreken, opnieuw, negeren? [a/o/n] (a): n
    (2/8) Verwijderen van bundle-lang-common-nl-13.2-58.1.noarch ............................................................................................................................................................................................................[fout]
    Verwijderen van (64660)bundle-lang-common-nl-13.2-58.1.noarch(@System) is mislukt:
    Fout: Subprocess failed. Error: RPM is mislukt: error: package bundle-lang-common-nl-13.2-58.1.noarch is not installed
    
    Afbreken, opnieuw, negeren? [a/o/n] (a): n
    (3/8) Verwijderen van bundle-lang-gnome-en-13.2-58.1.noarch .............................................................................................................................................................................................................[fout]
    Verwijderen van (64662)bundle-lang-gnome-en-13.2-58.1.noarch(@System) is mislukt:
    Fout: Subprocess failed. Error: RPM is mislukt: error: package bundle-lang-gnome-en-13.2-58.1.noarch is not installed
    
    Afbreken, opnieuw, negeren? [a/o/n] (a): n
    (4/8) Verwijderen van bundle-lang-gnome-nl-13.2-58.1.noarch .............................................................................................................................................................................................................[fout]
    Verwijderen van (64664)bundle-lang-gnome-nl-13.2-58.1.noarch(@System) is mislukt:
    Fout: Subprocess failed. Error: RPM is mislukt: error: package bundle-lang-gnome-nl-13.2-58.1.noarch is not installed
    
    Afbreken, opnieuw, negeren? [a/o/n] (a): n
    (5/8) Verwijderen van bundle-lang-kde-en-13.2-58.1.noarch ...............................................................................................................................................................................................................[fout]
    Verwijderen van (64667)bundle-lang-kde-en-13.2-58.1.noarch(@System) is mislukt:
    Fout: Subprocess failed. Error: RPM is mislukt: error: package bundle-lang-kde-en-13.2-58.1.noarch is not installed
    
    Afbreken, opnieuw, negeren? [a/o/n] (a): n
    (6/8) Verwijderen van bundle-lang-kde-nl-13.2-58.1.noarch ...............................................................................................................................................................................................................[fout]
    Verwijderen van (64669)bundle-lang-kde-nl-13.2-58.1.noarch(@System) is mislukt:
    Fout: Subprocess failed. Error: RPM is mislukt: error: package bundle-lang-kde-nl-13.2-58.1.noarch is not installed
                                                                                                                                                                                                                                                                                    
    Afbreken, opnieuw, negeren? [a/o/n] (a): n
    (7/8) Verwijderen van libreoffice-branding-upstream-5.4.2.2-1.2.noarch ..................................................................................................................................................................................................[fout]
    Verwijderen van (66027)libreoffice-branding-upstream-5.4.2.2-1.2.noarch(@System) is mislukt:
    Fout: Subprocess failed. Error: RPM is mislukt: error: package libreoffice-branding-upstream-5.4.2.2-1.2.noarch is not installed
                                                                                                                                                                                                                                                                                    
    Afbreken, opnieuw, negeren? [a/o/n] (a): n
    (8/8) Verwijderen van libreoffice-icon-theme-galaxy-5.4.2.2-1.2.noarch ..................................................................................................................................................................................................[fout]
    Verwijderen van (66035)libreoffice-icon-theme-galaxy-5.4.2.2-1.2.noarch(@System) is mislukt:
    Fout: Subprocess failed. Error: RPM is mislukt: error: package libreoffice-icon-theme-galaxy-5.4.2.2-1.2.noarch is not installed
                                                                                                                                                                                                                                                                                    
    Afbreken, opnieuw, negeren? [a/o/n] (a): n
    fred@localhost:~>                                                
    

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,803

    Default Re: Verwijderen van niet bestaande programma's

    Hallo,

    Dit lijkt een beetje alsof je zypper en/of rpm database(s) de kluts kwijt is/zijn. Je kunt ze opnieuw opbouwen met
    Code:
    rpm --rebuilddb
    en
    Code:
    zypper clean -a
    Probeer dat eens.
    Henk van Velden

  3. #3

    Default Re: Verwijderen van niet bestaande programma's

    Ik heb zojuist dit gedaan. Het lijkt erop dat ze nu weg zijn. Even in de gaten houden wanneer er weer updates gaan komen of dit weer optreedt. Mocht dat zo zijn dan plaats ik dat hier.

    Voor zover bedankt.

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Verwijderen van niet bestaande programma's

    Quote Originally Posted by satshow View Post
    Ik heb zojuist dit gedaan. Het lijkt erop dat ze nu weg zijn. Even in de gaten houden wanneer er weer updates gaan komen of dit weer optreedt. Mocht dat zo zijn dan plaats ik dat hier.

    Voor zover bedankt.
    Na deze actie zou 't niet meer voor moeten komen. Meestal onstaat dit fenomeen door het niet ( kunnen ) afronden van een update sessie.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •