Results 1 to 5 of 5

Thread: mktexfmt [ERROR]: -user mode but path setup is -sys type, bailing out.

  1. #1

    Default mktexfmt [ERROR]: -user mode but path setup is -sys type, bailing out.

    Hi,

    i installed texlive from here https://software.opensuse.org/package/texlive and texstudio with zypper. Everything is updated.

    But when trying to compile i geht the error

    mktexfmt [ERROR]: -user mode but path setup is -sys type, bailing out.

    does anyone have an idea what todo here?

  2. #2

    Default Re: mktexfmt [ERROR]: -user mode but path setup is -sys type, bailing out.

    I've had the same problem on a fresh install (from opensuse-Tumbleweed DVD)

    I temporarily fixed it as follows, but clearly this is not an ideal solution. (Any help with fixing the install would be greatly appreciated.)

    I've removed all files related to texmf in /etc, /usr and /var. I've then installed texlive-2015 from openSUSE Leap 42.2 repository via YaST. The installation in YaST stopped when running the update scripts in /var/adm/update-scripts with error 127 (file not found). I've looked at the files in that folder and all of them seem to link to "/usr/share/texmf/texconfig/zypper.py", which does not exist in that folder.

    I've then changed the group of "/var/lib/texmf" and "/etc/texmf" to "mktex" and ran (as superuser) "texconfig rehash", "fmtutil --all" and once more "texconfig rehash". Now LaTeX works, but whenever I have to install a texlive package, I get the error 127 during installation and I have to run "texconfig rehash" again.

    BTW: I had the same error 127 with texlive-2016.

  3. #3

    Default Re: mktexfmt [ERROR]: -user mode but path setup is -sys type, bailing out.

    I've got the same issue after installing latex after updating to Tumblweed 20171231. I was also getting some errors related to ls-R, but those were fixed after running:

    Code:
    sudo texconfig
    and selecting "REHASH".

    But still have the same error:
    Code:
    pdflatex responses.tex
    This is pdfTeX, Version 3.14159265-2.6-1.40.18 (TeX Live 2017/TeX Live for SUSE Linux) (preloaded format=pdflatex)
     restricted \write18 enabled.
    
    kpathsea: Running mktexfmt pdflatex.fmt
    mktexfmt [ERROR]: -user mode but path setup is -sys type, bailing out.
    I can't find the format file `pdflatex.fmt'!
    make: *** [Makefile:2: responses.pdf] Error 1

  4. #4

    Default Re: mktexfmt [ERROR]: -user mode but path setup is -sys type, bailing out.


  5. #5

    Default Re: mktexfmt [ERROR]: -user mode but path setup is -sys type, bailing out.

    Form the bugzilla, this sequence of commands fixed things for me:

    Code:
    su
    mkdir /run/texlive
    touch /var/run/texlive/run-hyphen
    touch /var/run/texlive/run-fmtutil.language
    touch /var/run/texlive/run-fmtutil.refresh
    /usr/share/texmf/texconfig/update

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •