Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Errors compiling nvidia proprietary drivers

  1. #1
    Join Date
    Nov 2011
    Location
    Murcia, Spain
    Posts
    38

    Exclamation Errors compiling nvidia proprietary drivers

    Hi, I'm trying to install the proprietary drivers from Nvidia through the so-called hard way, but I failed so far.

    First, I can not install the package libglvnd-devel, which seems to be part of the procedure. This package just doesn't exist in my repos. Whatever, I continue and then I boot in text mode. [Side question, is there a way less convoluted to do this than editing the target of systemd and rebooting?] When I run the script, I get some errors (I attach the log file below). I do not see anything obvious, such as package missing or similar. Any idea on how to debug this issue?

    Link to the log file.

    Thanks!

  2. #2

    Default AW: Errors compiling nvidia proprietary drivers

    Quote Originally Posted by onturenio View Post
    Hi, I'm trying to install the proprietary drivers from Nvidia through the so-called hard way, but I failed so far.

    First, I can not install the package libglvnd-devel, which seems to be part of the procedure. This package just doesn't exist in my repos.
    This only exists in Tumbleweed. (and in future Leap versions starting with 15.0)

    On 42.3, you need to uninstall the package drm-kmp-default, which contains updated video kernel modules (backported from kernel 4.9) that break nvidia's compilation.

    As mentioned here:
    https://en.opensuse.org/SDB:NVIDIA_the_hard_way

    Btw, why are you not just installing the rpm packages? (the easy way)
    Would save you much trouble...


    Side question, is there a way less convoluted to do this than editing the target of systemd and rebooting?
    Press 'e' at the boot menu and append 3 to the line starting with "linux" (or "linuxefi").

  3. #3

    Default Re: Errors compiling nvidia proprietary drivers

    PS: Seems you are using Kernel 4.14.3?
    The nvidia driver you try to install apparently doesn't support that kernel though, judging from the compiler errors.

    Why not use the standard kernel?
    Especially when you want to install the nvidia driver...
    Last edited by wolfi323; 23-Dec-2017 at 15:37.

  4. #4

    Default Re: Errors compiling nvidia proprietary drivers

    Quote Originally Posted by wolfi323 View Post
    PS: Seems you are using Kernel 4.14.3?
    The nvidia driver you try to install apparently doesn't support that kernel though, judging from the compiler errors.
    And this would confirm it:
    https://github.com/NixOS/nixpkgs/issues/32330

    If you want to stick with kernel 4.14.3, you should rather try to install the *latest* nvidia driver version, which is either 384.98 (for the long-lived branch, I don't know whether that one would work with this kernel though) or 387.34 (short-lived branch).

  5. #5

    Default Re: Errors compiling nvidia proprietary drivers

    PPS: It seems you need this patch, for 384.98 at least:
    https://build.opensuse.org/package/v...patch?expand=1
    (that's part of the rpm package)

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,721

    Default AW: Errors compiling nvidia proprietary drivers

    Nvidia 387.34 and Kernel 4.14 are working here without patching:
    Code:
    nvidia-settings -v
    
    nvidia-settings:  version 387.34  (buildmeister@swio-display-x64-rhel04-15)  Tue Nov 21 03:30:38 PST
    2017
      The NVIDIA X Server Settings tool.
    
      This program is used to configure the NVIDIA Linux graphics driver.
      For more detail, please see the nvidia-settings(1) man page.
    Code:
    uname -a
    Linux linux64 4.14.8-2.g3f42b52-default #1 SMP PREEMPT Thu Dec 21 10:54:37 UTC 2017 (3f42b52) x86_64 x86_64 x86_64 GNU/Linux

  7. #7
    Join Date
    Nov 2011
    Location
    Murcia, Spain
    Posts
    38

    Default Re: Errors compiling nvidia proprietary drivers

    Hi, fast answer from my phone. I'm using a non-standard kernel because I have to for other hardware issues. I have a recent laptop and it's giving me many headaches. The card is a GeForce 1050Ti, so I though the packed drivers are not suitable in this case. I had to blacklist Nouveau to have an usable system, by the way...

    To answer your comment, I do not have the drm... package you mentioned, but I have something related to kmp related to virtualbox. Anyway that doesn't seem to be the primary reason for the problem.

    First I tried using the nvidia repos, but it has broken the X's. After installing some packages, the system does not boot any graphical system. To fix it, I tried to deinstall everything related to nvidia, but I can not get it back to work as before installing the drivers. The screen is just blank without further messages. I have tried to compile again the drivers the hard way, this time with the --no-drm option and it does compile and install it. But after an optimistic reboot, the system is again not able to start the X's, although the nvidia driver seems now to be loaded.

    Some ideas to debug this lack of graphical system before I give up and reinstall from scratch?

  8. #8

    Default Re: Errors compiling nvidia proprietary drivers

    Quote Originally Posted by onturenio View Post
    To answer your comment, I do not have the drm... package you mentioned, but I have something related to kmp related to virtualbox. Anyway that doesn't seem to be the primary reason for the problem.
    If you installed the nvidia rpm packages before, drm-kmp-default will already have been uninstalled automatically.
    And no, the virtualbox kmp package does not cause a problem for the nvidia installation.

    Some ideas to debug this lack of graphical system before I give up and reinstall from scratch?
    Well, I also suggested using the *latest* nvidia driver, or patch it to build with kernel 4.14.

    I have no idea whether it will work if you build it with --no-drm though.

    Also, you probably need to run mkinitrd to rebuild the initrd (or try to disable plymouth with the "plymouth.enable=0" kernel option), plymouth loads the graphics driver very early on boot and that can lead to problems if it is not the "right" one (and it might load nouveau if the blacklist is not in the initrd as well).

    Adding "nomodeset" to the kernel options should make even more sure

    Otherwise, please post /var/log/Xorg.0.log that should show what's going wrong (if X fails to start).

  9. #9

    Default Re: Errors compiling nvidia proprietary drivers

    FYI, the recently released latest long-term branch version 384.111 should compile fine with the latest 4.14.x (i.e. 4.14.9 or higher) kernel versions as well, without having to patch it.

  10. #10
    Join Date
    Nov 2011
    Location
    Murcia, Spain
    Posts
    38

    Default Re: Errors compiling nvidia proprietary drivers

    Thanks for the hint. I tried several things, but I eventually gave up and switched to Tumbleweed. The old kernel in 42.3 was giving me too many headaches. Now almost all works better, but I'm still struggling with the Nvidia drivers. But that is matter of other post.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •