Results 1 to 10 of 10

Thread: Need help restoring windows 7 boot after TW install.

  1. #1

    Default Need help restoring windows 7 boot after TW install.

    Hi everyone,
    After installing Tumbleweed in a HD that already had Windows 7 installed, I cannot boot from windows 7 as it is not listed.
    What should I do in order to restore windows?


    According to Boot Loader:
    * the only bootloader location that is checked is "Boot from Master Boot Record".
    * Boot Loader: GRUB2

    Some extra information, that might be useful
    Code:
    lsblk 
    NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
    sda      8:0    0 465.8G  0 disk 
    ├─sda1   8:1    0     1K  0 part 
    ├─sda3   8:3    0 195.2G  0 part 
    ├─sda4   8:4    0   6.9G  0 part [SWAP]
    ├─sda5   8:5    0    40G  0 part /var/tmp
    └─sda6   8:6    0 223.7G  0 part /home
    sr0     11:0    1  1024M  0 rom

    Code:
    sudo parted -l
    Model: ATA TOSHIBA MK5065GS (scsi)
    Disk /dev/sda: 500GB
    Sector size (logical/physical): 512B/512B
    Partition Table: msdos
    Disk Flags: 
    
    Number  Start   End     Size    Type      File system     Flags
     1      1049kB  283GB   283GB   extended                  boot, lba, type=0f
     5      2097kB  43.0GB  43.0GB  logical   btrfs           type=83
     6      43.0GB  283GB   240GB   logical   xfs             type=83
     3      283GB   493GB   210GB   primary   ntfs            type=07
     4      493GB   500GB   7340MB  primary   linux-swap(v1)  type=82
    thanks in advance

  2. #2
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    4,029

    Default Re: restoring windows boot

    Quote Originally Posted by santiagorf View Post
    Hi everyone,
    After installing Tumbleweed in a HD that already had Windows 7 installed, I cannot boot from windows 7 as it is not listed.
    What should I do in order to restore windows?


    According to Boot Loader:
    * the only bootloader location that is checked is "Boot from Master Boot Record".
    * Boot Loader: GRUB2

    Some extra information, that might be useful
    Code:
    lsblk 
    NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
    sda      8:0    0 465.8G  0 disk 
    ├─sda1   8:1    0     1K  0 part 
    ├─sda3   8:3    0 195.2G  0 part 
    ├─sda4   8:4    0   6.9G  0 part [SWAP]
    ├─sda5   8:5    0    40G  0 part /var/tmp
    └─sda6   8:6    0 223.7G  0 part /home
    sr0     11:0    1  1024M  0 rom

    Code:
    sudo parted -l
    Model: ATA TOSHIBA MK5065GS (scsi)
    Disk /dev/sda: 500GB
    Sector size (logical/physical): 512B/512B
    Partition Table: msdos
    Disk Flags: 
    
    Number  Start   End     Size    Type      File system     Flags
     1      1049kB  283GB   283GB   extended                  boot, lba, type=0f
     5      2097kB  43.0GB  43.0GB  logical   btrfs           type=83
     6      43.0GB  283GB   240GB   logical   xfs             type=83
     3      283GB   493GB   210GB   primary   ntfs            type=07
     4      493GB   500GB   7340MB  primary   linux-swap(v1)  type=82
    thanks in advance
    ... did you make a backup to another drive before you installed TW?
    "Take a Walk on a Sunny Day, Greet everyone along the way, and Make Somebody Smile, Today"
    Gerry Jack Macks"Walk On A Sunny Day" GerryJackMacks.net

  3. #3

    Default Re: restoring windows boot

    I didn't do any back up as I didn't have any valuable data on Windows 7.
    If possible I want to avoid the burden of not only installing again W7, MS Office, etc, but also having to restore TW boot after a windows install.

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,779

    Default Re: Need help restoring windows 7 boot after TW install.

    The title of this thread is changed after a request of the OP.
    Henk van Velden

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,779

    Default Re: Need help restoring windows 7 boot after TW install.

    I do not know if this has initiated your problem, but your partitioning is a bit strange.

    Normally a disk starts with some primary partitions of which the last one is then the extended partition that covers the rest of the disk. Inside that extended there are then the logical partitions. In your case that should have been in the sequence: primary 1, primary 2, primary and extended 3 that then has logical 5 and logical 6.

    In your case it the sequence is: primary and extended 1 that then has logical 5 and logical 6, primary 3, primary 4.

    Now, I have seen more occasions of adventurous partitioning , but this disk must have quite a history of partitioning and re-partitioning to arrive at such a mixed up situation.

    Can we assume btw that 3 is the Windows system?
    Henk van Velden

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,779

    Default Re: restoring windows boot

    Quote Originally Posted by Fraser_Bell View Post
    ... did you make a backup to another drive before you installed TW?
    The original title of this thread was confusing.

    The questions is not to restore the Windows 7 OS on it's partition(s) (it apparently is still there), but to make Grub showing it in it's list and being able to boot it.
    Henk van Velden

  7. #7

    Default Re: Need help restoring windows 7 boot after TW install.

    Quote Originally Posted by hcvv View Post
    I do not know if this has initiated your problem, but your partitioning is a bit strange.
    Can we assume btw that 3 is the Windows system?
    I know the partitioning is not very tidy. Before installing TW, I had another distro installed (I'm not very good at managing disks)
    Yes, sda3 is the windows system.

  8. #8

    Default Re: Need help restoring windows 7 boot after TW install.

    What about boot-repair?
    Do you think is it worth giving a try?

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Need help restoring windows 7 boot after TW install.

    Quote Originally Posted by santiagorf View Post
    What about boot-repair?
    Do you think is it worth giving a try?
    There's a couple of things you can do:
    1. Use YaST - System - Bootloader. Make sure the option "Probe for other OS's" is checked and press OK, OK. Reboot and see if os-prober has found your Windows install
    2. Boot from an install medium in Rescue mode.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  10. #10
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    4,029

    Default Re: Need help restoring windows 7 boot after TW install.

    Quote Originally Posted by hcvv View Post
    I do not know if this has initiated your problem, but your partitioning is a bit strange.
    Yes, this is what threw me off. It certainly is not standard for a PC shipped with Windows, and guessing it was such a machine, I assumed somehow Windows was completely blown away. To me, it looked like even the Factory Recovery partition was blown out, along with the Windows System partition, so I knew of no other solution than restore from a backup (or completely re-install Windows from external media).

    Can we assume btw that 3 is the Windows system?
    You were ahead of me on this. I assumed it was a Windows Data partition, not Windows System.

    Glad to hear from OP that sda3 is Windows System, can now be an easy recovery, when Knurpht's latest suggestion gets an answer.
    Last edited by hcvv; 30-Dec-2017 at 02:10. Reason: repaired QUOTE tag
    "Take a Walk on a Sunny Day, Greet everyone along the way, and Make Somebody Smile, Today"
    Gerry Jack Macks"Walk On A Sunny Day" GerryJackMacks.net

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •