Hi,
I upgraded from Leap 42.2 to 43.3 today. I am using the latest KDE (KDE Plasma: 5.11.4, KDE Frameworks: 5.40.0, Qt Version: 5.10.0). After the upgrade, I am unable to open Kmail or Kontact. When I try to open Kmail in Konsole, I get the following message
Code:
userj@user-laptop:~> kmail
Pass a valid window to KWallet::Wallet::openWallet().
The kwalletd service has been registered
org.kde.pim.kidentitymanagement: IdentityManager: There was no default identity. Marking first one as default.
org.kde.pim.messagelist: Saved theme loading failed
org.kde.pim.messagelist: Saved theme loading failed
org.kde.pim.messagelist: Saved theme loading failed
org.kde.pim.webengineviewer:  It's not necessary to check database now
[22992:23033:1220/224511.462610:ERROR:gl_implementation.cc(246)] Failed to load /usr/bin/libGLESv2.so: /usr/bin/libGLESv2.so: cannot open shared object file: No such file or directory
this does not work on a KActionCollection containing actions!
QDBusConnection: name 'org.kde.kwalletd5' had owner '' but we thought it was ':1.60'
org.kde.akonadi.ETM: GEN true false false
org.kde.akonadi.ETM: collection: QVector()
org.kde.akonadi.ETM: 
org.kde.akonadi.ETM: Subtree:  3 QSet(50, 3, 48, 49, 46, 47)
org.kde.akonadi.ETM: Fetch job took  344 msec
org.kde.akonadi.ETM: was collection fetch job: collections: 6
org.kde.akonadi.ETM: first fetched collection: "Local Folders"
org.kde.akonadi.ETM: collection: QVector()
org.kde.akonadi.ETM: Fetch job took  377 msec
org.kde.akonadi.ETM: was collection fetch job: collections: 6
org.kde.akonadi.ETM: first fetched collection: "Search"
org.kde.akonadi.ETM: Fetch job took  33 msec
org.kde.akonadi.ETM: was collection fetch job: collections: 0
[22992:23033:1220/224512.207379:ERROR:gl_surface_qt.cpp(701)] Requested OpenGL implementation is not supported. Implementation: 0
Received signal 11 SEGV_MAPERR 000000000000
#0 0x7f62dd5f8af7 <unknown>
#1 0x7f62dc3a541e <unknown>
#2 0x7f62dd5f8e8d <unknown>
#3 0x7f62f2359950 <unknown>
#4 0x7f62dc406f41 <unknown>
#5 0x7f62dc407d05 <unknown>
#6 0x7f62de0255f4 <unknown>
#7 0x7f62de032d6c <unknown>
#8 0x7f62de03899c <unknown>
#9 0x7f62de039941 <unknown>
#10 0x7f62de02be00 <unknown>
#11 0x7f62de0308ba <unknown>
#12 0x7f62de0302c2 <unknown>
#13 0x7f62de031f35 <unknown>
#14 0x7f62dd679771 <unknown>
#15 0x7f62dd614450 <unknown>
#16 0x7f62dd615c6e <unknown>
#17 0x7f62dd616c49 <unknown>
#18 0x7f62dd617019 <unknown>
#19 0x7f62dd633808 <unknown>
#20 0x7f62dd64e6b6 <unknown>
#21 0x7f62dd649a1d <unknown>
#22 0x7f62e815d744 start_thread
#23 0x7f62f240eaad __clone
  r8: 0000000000000003  r9: 00007f6244000078 r10: 00007f6244000070 r11: 0000000000000005
 r12: 0000000000000000 r13: 00007f62617f8c20 r14: 00007f62617f8c70 r15: 00007f624400eb70
  di: 0000000000000000  si: 0000000000000000  bp: 00007f62617f8a60  bx: 00007f624400eb70
  dx: 0000000000000000  ax: 00007f62e22cccc8  cx: 00007f62617f8890  sp: 00007f62617f8890
  ip: 00007f62dc406f41 efl: 0000000000010206 cgf: 0000000000000033 erf: 0000000000000004
 trp: 000000000000000e msk: 0000000000000000 cr2: 0000000000000000
[end of stack trace]
Calling _exit(1). Core file will not be generated.
user@user-laptop:~>
I did not have this problem in Leap 42.2 with KDE Plasma: 5.11. I don't know what went wrong during the upgrade. Any help is appreciated. Thanks