Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: User manager's administrator box is unchecked after installation

  1. #1
    Join Date
    Dec 2017
    Location
    Portugal
    Posts
    35

    Question User manager's administrator box is unchecked after installation

    Howdy

    I hope that I am in the right section of the forums to report this issue.
    When I reached the local user's section of the installer, I chose the default option that makes my primary username's password have administrative permissions. However, after the installation, the user manager's administrator box is unchecked
    Is it normal to happen or is it a bug?

    Thanks in advance!

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,729

    Default Re: User manager's administrator box is unchecked after installation

    I do not quite understand what you mean.

    As far as I know, the installer offers you as default to have the same password used for root and for the user you are asked to create there. Which is btw for many seen as a bad situation that should not have been made the default.

    It means that when you are asked for the root password (e.g. when starting YaST or a Terminal in "administrator mode"), you have to use the same password as you used to login with the normal user. That may be easy for your memory, but is not very secure.

    I have no idea what you mean with "the user manager's administrator box", or where you see such a thing.
    Henk van Velden

  3. #3

    Default Re: User manager's administrator box is unchecked after installation

    Quote Originally Posted by pensador_13 View Post
    When I reached the local user's section of the installer, I chose the default option that makes my primary username's password have administrative permissions.
    No, it doesn't.

    It just sets the root's password to be the same as for your user account.

    They are not even synced though, if you later change your user password, root's password will stay the same.

    However, after the installation, the user manager's administrator box is unchecked
    Is it normal to happen or is it a bug?
    That's normal.

    There is only *one* "administrator", and that is root.

    Btw, that checkbox doesn't do what you probably think it would...
    And next time please also tell *what* "user manager" you mean here.
    I suppose it's the one in the desktop settings, but which desktop?

  4. #4
    Join Date
    Dec 2017
    Location
    Portugal
    Posts
    35

    Default Re: User manager's administrator box is unchecked after installation

    I am sorry if I was not detailed
    I tried to show a screenshot of the problem, but the Insert image button seems to only work with URL images.
    I am using KDE Plasma Desktop and the User Manager is in System Settings > Account Details > User Manager.

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,582

    Default Re: User manager's administrator box is unchecked after installation

    Point is you user does not have root privileges you stillmust become root to administer system and the dealt is to have root's and first user's passwords the same.

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,729

    Default Re: User manager's administrator box is unchecked after installation

    Quote Originally Posted by pensador_13 View Post
    I am sorry if I was not detailed
    I tried to show a screenshot of the problem, but the Insert image button seems to only work with URL images.
    I am using KDE Plasma Desktop and the User Manager is in System Settings > Account Details > User Manager.
    One way to post images is by uploading them to http://paste.opensuse.org/ and post the links here.

    You are now using openSUSE. One of the best things in openSUSE is YaST. YaST is the system management tool of openSUSE. Thus better use YaST. It has a user and group management module:
    YaST > Security and Users > Users and Group Management.
    Henk van Velden

  7. #7
    Join Date
    Dec 2017
    Location
    Portugal
    Posts
    35

    Default Re: User manager's administrator box is unchecked after installation

    So if I understood correctly, by default root's password = primary username's password, and if I only change my primary username's password, the root's password remains the same?
    Also, as root, I saw the content of /etc/sudoers and my primary username is not there, so by default my primary username is not allowed to use sudo?

  8. #8

    Default Re: User manager's administrator box is unchecked after installation

    Quote Originally Posted by pensador_13 View Post
    So if I understood correctly, by default root's password = primary username's password, and if I only change my primary username's password, the root's password remains the same?
    Yes.

    root is a user like any other (although with more powers of course).
    That installer option only decides how the root password is set initially. (if you deactivate it, you will be asked for a specific password for root during installation)

    Also, as root, I saw the content of /etc/sudoers and my primary username is not there, so by default my primary username is not allowed to use sudo?
    *Everybody* is allowed to use sudo on openSUSE (with the default settings).
    You need to know/supply the root password though.

    It's different in Ubuntu e.g., where only certain ("administrative") users are allowed to use sudo, and they need to supply their own password. The root account is completely disabled there.

    In openSUSE OTOH, you can even login as/switch to (with "su") being root. It's not a good idea to run a graphical session as root though.

    PS: I think the only thing that "Administrator" checkbox does in KDE's (and also GNOME's) user-manager is that it would allow to modify (or add/delete) other accounts (in the user-manager, otherwise you need to be root to do that anyway).
    Last edited by wolfi323; 23-Dec-2017 at 09:40.

  9. #9
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,180
    Blog Entries
    3

    Default Re: User manager's administrator box is unchecked after installation

    Quote Originally Posted by pensador_13 View Post
    I am using KDE Plasma Desktop and the User Manager is in System Settings > Account Details > User Manager.
    In simple terms, openSUSE is not Ubuntu. But you will soon get used to the differences.

    With Ubuntu, you could make a user an administrator. Technically, that added the user to the "wheel" group. There's also a "wheel" group in openSUSE. But it doesn't actually do much. If the KDE user manager allows you to set a user as administrator, that probably adds it to the "wheel" group. But, as I just said, that doesn't do much.

    In Ubuntu, the "sudo" command is configured to treat the "wheel" group specially. It does not have that configuration in openSUSE, though you could probably set that up.

    If you need to do something administrative, you can open "Terminal - Super User mode". That will prompt you for the root password. When you finished doing superuser stuff, just close that terminal. Some applications are setup to ask for the root password when you open them.
    openSUSE Leap 15.1; KDE Plasma 5;

  10. #10
    Join Date
    Dec 2017
    Location
    Portugal
    Posts
    35

    Default Re: User manager's administrator box is unchecked after installation

    Thank you all for your replies
    How can I mark this thread as solved?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •