installed scrapy


Code:
sudo zypper install python3-Scrapy
it was working but had some errors.


updated all the packages
Code:
    pip freeze --local | grep -v '^\-e' | cut -d = -f 1  | xargs -n1 pip install -U


    pip3 freeze --local | grep -v '^\-e' | cut -d = -f 1  | xargs -n1 pip3 install -U


    sudo zypper update && sudo zypper upgrade
whatever I do have the same error:


Code:
 martin@linux-vb3j:~/Documents/Python/scrapy/samples> scrapy
    Traceback (most recent call last):
      File "/usr/bin/scrapy", line 7, in <module>
        from scrapy.cmdline import execute
      File "/usr/lib64/python3.4/site-packages/scrapy/__init__.py", line 34, in <module>
        from scrapy.spiders import Spider
      File "/usr/lib64/python3.4/site-packages/scrapy/spiders/__init__.py", line 10, in <module>
        from scrapy.http import Request
      File "/usr/lib64/python3.4/site-packages/scrapy/http/__init__.py", line 10, in <module>
        from scrapy.http.request import Request
      File "/usr/lib64/python3.4/site-packages/scrapy/http/request/__init__.py", line 13, in <module>
        from scrapy.utils.url import escape_ajax
      File "/usr/lib64/python3.4/site-packages/scrapy/utils/url.py", line 15, in <module>
        from w3lib.url import _safe_chars, _unquotepath
    ImportError: cannot import name '_unquotepath'
    martin@linux-vb3j:~/Documents/Python/scrapy/samples>
w3lib is up to date:


Code:
    Requirement already satisfied: six>=1.4.1 in /usr/lib/python3.4/site-packages (from w3lib)
QUESTION: How do you install scrapy on openSUSE 42.3, can someone list their dependecies version?