Results 1 to 3 of 3

Thread: Online Update with Yast: Problems with distribution repositorys

  1. #1

    Default Online Update with Yast: Problems with distribution repositorys

    I usually use the graphical interface of YAST for online update.
    Recently I get the following error messages:
    Code:
    Datei '/repodata/repomd.xml' auf Medium 'http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/' nicht gefunden
    and
    Code:
    Datei '/repodata/repomd.xml' auf Medium 'http://download.opensuse.org/distribution/leap/42.3/repo/oss/' nicht gefunden
    which is weird, because I haven't changed my repository configuration for quite some time and I never had any problems or error messages.

    When I inspect those repositories via web interface, I notice that there is no
    Code:
    repodata
    directory and no
    Code:
    repomd.xml
    file either.

    Can those two repositories be fixed or is there a reason, why the corresponding
    Code:
    repomd.xml
    files were removed?

    Best regards
    Thomas

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,345
    Blog Entries
    3

    Default Re: Online Update with Yast: Problems with distribution repositorys

    This is usually a temporary error.

    You probably connected to a mirror, or were redirected to a mirror. And that mirror may have been updating at the time.

    Wait three or four hours, and try again.

    As for "repodata" -- that's usually found in a subdirectory, rather than at the top level.
    openSUSE Leap 15.1; KDE Plasma 5;

  3. #3

    Default Re: Online Update with Yast: Problems with distribution repositorys

    Quote Originally Posted by nrickert View Post
    As for "repodata" -- that's usually found in a subdirectory, rather than at the top level.
    Thanks for the hint. I found the "repodata" directory in a subdirectory "suse" below ".../oss" respectively ".../non-oss". Well, I did not change my repository configuration since installing Leap 42.3, so I suppose there was an adjustment in the directory structure of those repositories. Strange that I seem to be the only one to notice that.

    Anyway Yast does not complain any more, so I hope refreshing works properly.

    Best regards
    Thomas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •