Results 1 to 3 of 3

Thread: On power on after installation, system checks DMI pool data, then then prints GRUB and stops.

  1. #1
    Join Date
    Oct 2016
    Location
    USA
    Posts
    92

    Default On power on after installation, system checks DMI pool data, then then prints GRUB and stops.

    Good day, folks. Let me explain this chronologically, and as clearly as I can. To start, my original goal was to install OpenSUSE to replace Windows 10 on a desktop computer.

    I first burned the Leap 42.3 networked install image to a CD, backed up all of my data, and booted the computer to that CD.
    I chose the "Install" option, and simply chose defaults in every menu except for the partitioning one, where the only change that I made was to set the root partition to EXT4 rather than Btrfs. The result of this installation was that my system could not find any bootloader on the hard drive, and simply stopped after verifying DMI pool data. Booting from the installation CD, if I chose "boot from installed system," it would successfully boot into an otherwise functional installation of OpenSUSE, where I proceeded to use YaST2 to change the bootloader from "GRUB2 for EFI" to "GRUB2", and moved it to the MBR. The result of this was that my computer could boot to GRUB2, but GRUB2 reported that the commands "linuxefi" and "initrdefi" could not be understood.
    As an aside, I believe that I could get it working from this point by replacing all instances of those commands in the grub2 config files with their non-efi counterparts.

    I then tried to install OpenSUSE again, mostly the same way, but rather than overwrite previous partitions, I chose to re-use the ones I had created in the previous installation. The result was that booting straight to hard disk resulted in, after the check of dmi pool data, simply the word "GRUB" sitting there and the system doing nothing more. Booting into the installation cd then selecting boot installed system resulted in "GRUB" being printed and the system doing nothing more.

    I installed OpenSUSE a third time, this time overwriting all previous partitions, to similar results.

    At this point, I am quite confused as to what might be going on. So my question is this:
    What should I do at this point to get a properly booting system?
    What can I do, if that is too big a request, to get back to the results of the first installation I described?

    Thanks for reading, folks.
    --Henry Wilson

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,657

    Default Re: On power on after installation, system checks DMI pool data, then then prints GRUB and stops.

    Booting how????

    EFI or MBR?

    You must boot the installer in the mode you want to use ie if MBR you must use MBR/legacy boot of installer if EFI you boot in EFI mode

    If MBR boot you must have a MBR record ie install either generic or grub in MBR and the boot flag must be on the partition you boot to. If secure boot is on you need to check the secure boot box. grub2-efi is the required boot loader not just grub2

    EFI must have a small (100-300meg normally) EFI boot partition formatted FAT32 and mounted as /boot/efi. no boot flag needed.


    Defaults should be right if booted in the correct mode for how you wish to run the system unless you managed to change them.

  3. #3
    Join Date
    Oct 2016
    Location
    USA
    Posts
    92

    Default Re: On power on after installation, system checks DMI pool data, then then prints GRUB and stops.

    Gogalthorp,
    You're absolutely correct. I somehow had my BIOS set to boot CD's in EFI and the HDD from MBR... Not sure how I got that to happen.
    I managed to solve the problem by changing the Bootloader to MBR in the final page of the install.
    I likely could also have solved it by booting the CD without EFI.
    Thanks, and take care,
    --Henry Wilson

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •