Results 1 to 9 of 9

Thread: Wlan permanent switching between 2.4 and 5.1 GHz, how to stop this

  1. #1

    Default Wlan permanent switching between 2.4 and 5.1 GHz, how to stop this

    Hi,

    Thinkpad t460p

    at home I have a tp link router that supports 2 frequencies
    and my notebook can also do both

    the problem is, my wlan disconnects and reconnects very often,
    and after reconnect it always has the different frequency than before
    so I guess it does switching the frequency, but why?

    Can I pin the WLan, networkmanager, to one frequency?
    These reconnects are super annoying


    Code:
    /usr/sbin/hwinfo --wlan
    17: PCI 300.0: 0282 WLAN controller                             
      [Created at pci.378]
      Unique ID: y9sn._1zYJqZDqT9
      Parent ID: z8Q3.NMIGalQjZq7
      SysFS ID: /devices/pci0000:00/0000:00:1c.0/0000:03:00.0
      SysFS BusID: 0000:03:00.0
      Hardware Class: network
      Model: "Intel Wireless 8260"
      Vendor: pci 0x8086 "Intel Corporation"
      Device: pci 0x24f3 "Wireless 8260"
      SubVendor: pci 0x8086 "Intel Corporation"
      SubDevice: pci 0x0130 
      Revision: 0x3a
      Driver: "iwlwifi"
      Driver Modules: "iwlwifi"
      Device File: wlan0
      Features: WLAN
      Memory Range: 0xf2100000-0xf2101fff (rw,non-prefetchable)
      IRQ: 129 (no events)
      HW Address: e4:b3:18:7b:3a:b8
      Permanent HW Address: e4:b3:18:7b:3a:b8
      Link detected: yes
      WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 36 40 44 48 52 56 60 64 100 104 108 112 116 120 124 128 132 136 140
      WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 5.18 5.2 5.22 5.24 5.26 5.28 5.3 5.32 5.5 5.52 5.54 5.56 5.58 5.6 5.62 5.64 5.66 5.68 5.7
      WLAN encryption modes: WEP40 WEP104 TKIP CCMP
      WLAN authentication modes: open sharedkey wpa-psk wpa-eap
      Module Alias: "pci:v00008086d000024F3sv00008086sd00000130bc02sc80i00"
      Driver Info #0:
        Driver Status: iwlwifi is active
        Driver Activation Cmd: "modprobe iwlwifi"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
      Attached to: #9 (PCI bridge)

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,349
    Blog Entries
    15

    Default Re: Wlan permanent switching between 2.4 and 5.1 GHz, how to stop this

    Quote Originally Posted by a4z View Post
    Hi,

    Thinkpad t460p

    at home I have a tp link router that supports 2 frequencies
    and my notebook can also do both

    the problem is, my wlan disconnects and reconnects very often,
    and after reconnect it always has the different frequency than before
    so I guess it does switching the frequency, but why?

    Can I pin the WLan, networkmanager, to one frequency?
    These reconnects are super annoying


    Code:
    /usr/sbin/hwinfo --wlan
    17: PCI 300.0: 0282 WLAN controller                             
      [Created at pci.378]
      Unique ID: y9sn._1zYJqZDqT9
      Parent ID: z8Q3.NMIGalQjZq7
      SysFS ID: /devices/pci0000:00/0000:00:1c.0/0000:03:00.0
      SysFS BusID: 0000:03:00.0
      Hardware Class: network
      Model: "Intel Wireless 8260"
      Vendor: pci 0x8086 "Intel Corporation"
      Device: pci 0x24f3 "Wireless 8260"
      SubVendor: pci 0x8086 "Intel Corporation"
      SubDevice: pci 0x0130 
      Revision: 0x3a
      Driver: "iwlwifi"
      Driver Modules: "iwlwifi"
      Device File: wlan0
      Features: WLAN
      Memory Range: 0xf2100000-0xf2101fff (rw,non-prefetchable)
      IRQ: 129 (no events)
      HW Address: e4:b3:18:7b:3a:b8
      Permanent HW Address: e4:b3:18:7b:3a:b8
      Link detected: yes
      WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 36 40 44 48 52 56 60 64 100 104 108 112 116 120 124 128 132 136 140
      WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 5.18 5.2 5.22 5.24 5.26 5.28 5.3 5.32 5.5 5.52 5.54 5.56 5.58 5.6 5.62 5.64 5.66 5.68 5.7
      WLAN encryption modes: WEP40 WEP104 TKIP CCMP
      WLAN authentication modes: open sharedkey wpa-psk wpa-eap
      Module Alias: "pci:v00008086d000024F3sv00008086sd00000130bc02sc80i00"
      Driver Info #0:
        Driver Status: iwlwifi is active
        Driver Activation Cmd: "modprobe iwlwifi"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
      Attached to: #9 (PCI bridge)
    Hi
    That's all controlled by the router (probably set to auto) as it will search for the least channel that has interference. I would guess that's why it drops the connection as the router is possibly bouncing around. In the router you should be able to do a wireless scan and find a channel that's free and set the router to use that. If you can change the aerial position this may also help with channel interference.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Wlan permanent switching between 2.4 and 5.1 GHz, how to stop this

    thanks for the info, I found 2 settings, channel with and channel
    I do not know what to take for channel with, it's 20/40 for 2.4ghz and 20/40/80 for 5 ghz
    nothing to scan, but I chosen the first, lowest, channel
    the router is a tp link archer c9

    however, i still wonder if its possible to pin the wlan to one of both frequencies on the notebook, or is this also a router decision, what to assign?

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,349
    Blog Entries
    15

    Default Re: Wlan permanent switching between 2.4 and 5.1 GHz, how to stop this

    Quote Originally Posted by a4z View Post
    thanks for the info, I found 2 settings, channel with and channel
    I do not know what to take for channel with, it's 20/40 for 2.4ghz and 20/40/80 for 5 ghz
    nothing to scan, but I chosen the first, lowest, channel
    the router is a tp link archer c9

    however, i still wonder if its possible to pin the wlan to one of both frequencies on the notebook, or is this also a router decision, what to assign?
    Hi
    The router sets the channel, select on or the other 2.4 or 5....

    Are your wifi cards 1X1? If so set the bandwidth to 40 on 2.4GHz and 40 or 80 for 5.0Ghz that should get full speed
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: Wlan permanent switching between 2.4 and 5.1 GHz, how to stop this

    still disconnects, I do not believe that this is just the router,
    no problems on other notebooks with other os and distribution
    strange

    and it again hopped from 5.1 to 2.4 GHz, I think this is the OS on the notebook doing so

  6. #6

    Default Re: Wlan permanent switching between 2.4 and 5.1 GHz, how to stop this

    all 6 minutes change from one frequency to an other

    Code:
    ec 19 19:17:38 t460p.suse NetworkManager[1076]: <info>  (wlan0): roamed from BSSID 50:C7:BF:18:FA:17 (network_name) to (none) ((none))
    Dec 19 19:17:38 t460p.suse NetworkManager[1076]: <info>  (wlan0): supplicant interface state: completed -> authenticating
    Dec 19 19:17:38 t460p.suse NetworkManager[1076]: <info>  (wlan0): supplicant interface state: authenticating -> associated
    Dec 19 19:17:38 t460p.suse NetworkManager[1076]: <info>  (wlan0): supplicant interface state: associated -> 4-way handshake
    Dec 19 19:17:38 t460p.suse NetworkManager[1076]: <info>  (wlan0): supplicant interface state: 4-way handshake -> completed
    Dec 19 19:17:38 t460p.suse NetworkManager[1076]: <info>  (wlan0): roamed from BSSID (none) ((none)) to 50:C7:BF:18:FA:16 (network_name)
    Dec 19 19:23:35 t460p.suse NetworkManager[1076]: <info>  (wlan0): roamed from BSSID 50:C7:BF:18:FA:16 (network_name) to (none) ((none))
    Dec 19 19:23:35 t460p.suse NetworkManager[1076]: <info>  (wlan0): supplicant interface state: completed -> authenticating
    Dec 19 19:23:35 t460p.suse NetworkManager[1076]: <info>  (wlan0): supplicant interface state: authenticating -> associating
    Dec 19 19:23:35 t460p.suse NetworkManager[1076]: <info>  (wlan0): supplicant interface state: associating -> 4-way handshake
    Dec 19 19:23:35 t460p.suse NetworkManager[1076]: <info>  (wlan0): supplicant interface state: 4-way handshake -> completed
    Dec 19 19:23:35 t460p.suse NetworkManager[1076]: <info>  (wlan0): roamed from BSSID (none) ((none)) to 50:C7:BF:18:FA:17 (network_name)
    Dec 19 19:29:35 t460p.suse NetworkManager[1076]: <info>  (wlan0): roamed from BSSID 50:C7:BF:18:FA:17 (network_name) to (none) ((none))
    Dec 19 19:29:35 t460p.suse NetworkManager[1076]: <info>  (wlan0): supplicant interface state: completed -> authenticating
    Dec 19 19:29:35 t460p.suse NetworkManager[1076]: <info>  (wlan0): supplicant interface state: authenticating -> associated
    Dec 19 19:29:35 t460p.suse NetworkManager[1076]: <info>  (wlan0): supplicant interface state: associated -> 4-way handshake
    Dec 19 19:29:35 t460p.suse NetworkManager[1076]: <info>  (wlan0): supplicant interface state: 4-way handshake -> completed
    Dec 19 19:29:35 t460p.suse NetworkManager[1076]: <info>  (wlan0): roamed from BSSID (none) ((none)) to 50:C7:BF:18:FA:16 (network_name)
    Dec 19 19:31:35 t460p.suse NetworkManager[1076]: <info>  (wlan0): roamed from BSSID 50:C7:BF:18:FA:16 (network_name) to (none) ((none))
    Dec 19 19:31:35 t460p.suse NetworkManager[1076]: <info>  (wlan0): supplicant interface state: completed -> authenticating
    Dec 19 19:31:35 t460p.suse NetworkManager[1076]: <info>  (wlan0): supplicant interface state: authenticating -> associating
    Dec 19 19:31:35 t460p.suse NetworkManager[1076]: <info>  (wlan0): supplicant interface state: associating -> associated
    Dec 19 19:31:35 t460p.suse NetworkManager[1076]: <info>  (wlan0): supplicant interface state: associated -> 4-way handshake
    Dec 19 19:31:35 t460p.suse NetworkManager[1076]: <info>  (wlan0): supplicant interface state: 4-way handshake -> completed
    Dec 19 19:31:35 t460p.suse NetworkManager[1076]: <info>  (wlan0): roamed from BSSID (none) ((none)) to 50:C7:BF:18:FA:17 (network_name)
    Dec 19 19:37:38 t460p.suse NetworkManager[1076]: <info>  (wlan0): roamed from BSSID 50:C7:BF:18:FA:17 (network_name) to (none) ((none))
    Dec 19 19:37:38 t460p.suse NetworkManager[1076]: <info>  (wlan0): supplicant interface state: completed -> authenticating
    Dec 19 19:37:38 t460p.suse NetworkManager[1076]: <info>  (wlan0): supplicant interface state: authenticating -> associated
    Dec 19 19:37:38 t460p.suse NetworkManager[1076]: <info>  (wlan0): supplicant interface state: associated -> 4-way handshake
    Dec 19 19:37:38 t460p.suse NetworkManager[1076]: <info>  (wlan0): supplicant interface state: 4-way handshake -> completed
    Dec 19 19:37:38 t460p.suse NetworkManager[1076]: <info>  (wlan0): roamed from BSSID (none) ((none)) to 50:C7:BF:18:FA:16 (network_name)


    Code:
    t460p:~ # /usr/sbin/iwconfig
    lo        no wireless extensions.
    
    wlan0     IEEE 802.11abgn  ESSID:"network_name"  
              Mode:Managed  Frequency:2.412 GHz  Access Point: 50:C7:BF:18:FA:17   
              Bit Rate=144.4 Mb/s   Tx-Power=22 dBm   
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              Link Quality=61/70  Signal level=-49 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:3   Missed beacon:0
    
    eth0      no wireless extensions.
    
    t460p:~ # /usr/sbin/iwconfig
    lo        no wireless extensions.
    
    wlan0     IEEE 802.11abgn  ESSID:"network_name"  
              Mode:Managed  Frequency:5.18 GHz  Access Point: 50:C7:BF:18:FA:16   
              Bit Rate=144.4 Mb/s   Tx-Power=22 dBm   
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              Link Quality=61/70  Signal level=-49 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    
    eth0      no wireless extensions.

    this shall be done from the router? I do not think so

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: Wlan permanent switching between 2.4 and 5.1 GHz, how to stop this

    You can prevent unwanted roaming by editing your connection profile and locking it to a particular BSSID. (I note from the output you posted that the BSSID for the 2.412 GHz AP is 50:C7:BF:18:FA:17 for example, while the 5GHz AP is identified associated with 50:C7:BF:18:FA:16.)

    https://blogs.gnome.org/dcbw/2016/05...nd-wifi-scans/

    Hope this helps.

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,349
    Blog Entries
    15

    Default Re: Wlan permanent switching between 2.4 and 5.1 GHz, how to stop this

    Hi
    Your using network manager? Try setting the BSSID to either of the mac addresses for the AP depending on what frequency you want to use.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #9

    Default Re: Wlan permanent switching between 2.4 and 5.1 GHz, how to stop this

    thanks deano_ferrari and also malcolmlewis

    this looks very promising, have now a stable connections since more than half an hour!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •