Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: LibreOffice Wont Open

  1. #1

    Default LibreOffice Wont Open

    Libre office wont open sine the latest Tumbleweed update this past week. Here is the error when I try to launch libreoffice from the command line:

    beta~> libreoffice
    /usr/lib64/libreoffice/program/soffice.bin: relocation error: /usr/lib64/libgnutls.so.30: symbol nettle_rsa_pss_sha384_sign_digest_tr, version HOGWEED_4 not defined in file libhogweed.so.4 with link time reference

    beta~>

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,645
    Blog Entries
    14

    Smile Re: LibreOffice Wont Open

    How did you update? Looks like you used something else than the required 'zypper dup'.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: LibreOffice Wont Open

    Quote Originally Posted by Knurpht View Post
    How did you update? Looks like you used something else than the required 'zypper dup'.
    Hi, I used the YasT update tool and then when that did not fix it I used 'zypper dist-upgrade'. Thanks.

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,645
    Blog Entries
    14

    Default Re: LibreOffice Wont Open

    Quote Originally Posted by teamgh View Post
    Hi, I used the YasT update tool and then when that did not fix it I used 'zypper dist-upgrade'. Thanks.
    Don't use YaST to upgrade, or some desktop tool. On TW only use 'zypper dup'. Did that fix it? Did you reboot the system after the dup ?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: LibreOffice Wont Open

    Quote Originally Posted by Knurpht View Post
    Don't use YaST to upgrade, or some desktop tool. On TW only use 'zypper dup'. Did that fix it? Did you reboot the system after the dup ?
    I did reboot the system. A zypper update and looks like I have some problems lol

    [sudo] password for root:
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Retrieving repository 'openSUSE:FactoryowerPC' metadata ............................................................[error]
    Repository 'openSUSE:Factory owerPC' is invalid.
    [http-download.opensuse.org-1744d1fd|http://download.opensuse.org/reposit...rPC/standard/] Valid metadata not found at specified URL
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Warning: Skipping repository 'openSUSE:Factory owerPC' because of the above error.
    Repository 'devel:languages python3' is invalid.
    [http-download.opensuse.org-556283e3|http://download.opensuse.org/reposit...SUSE_Factory/] Repository type can't be determined.
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Warning: Skipping repository 'devel:languages python3' because of the above error.
    Some of the repositories have not been refreshed because of an error.
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    169 Problems:
    Problem: problem with installed package PlayOnLinux-4.2.10-10.1.noarch
    Problem: problem with installed package R-PKI-0.1.3-2.1.x86_64
    Problem: problem with installed package R-RCurl-1.95_4.3-2.1.x86_64
    Problem: problem with installed package R-RJSONIO-1.3_0-2.1.x86_64
    Problem: problem with installed package R-base64enc-0.1.3-2.1.x86_64
    Problem: problem with installed package R-bitops-1.0_6-2.1.x86_64
    Problem: problem with installed package R-digest-0.6.4-3.1.x86_64
    Problem: problem with installed package R-packrat-0.4.7.1-3.1.x86_64
    Problem: problem with installed package R-rsconnect-0.4.3-2.1.x86_64
    Problem: problem with installed package R-rstudioapi-0.1-2.1.x86_64
    Problem: problem with installed package R-yaml-2.1.13-2.1.x86_64
    Problem: problem with installed package cmake-3.7.0-277.1.x86_64
    Problem: problem with installed package edje-1.18.4-229.1.x86_64
    Problem: problem with installed package efl-1.18.4-229.1.x86_64
    Problem: problem with installed package elementary-1.18.4-229.1.x86_64
    Problem: problem with installed package elua-1.18.4-229.1.x86_64
    Problem: problem with installed package embryo-1.18.4-229.1.x86_64
    Problem: problem with installed package enlightenment-0.21.5-208.1.x86_64
    Problem: problem with installed package enlightenment-branding-openSUSE-0.1-31.2.x86_64
    Problem: problem with installed package enlightenment-profiles-openSUSE-20160622-52.4.noarch
    Problem: problem with installed package enlightenment-theme-dark-0.21.0-229.1.x86_64
    Problem: problem with installed package enlightenment-theme-openSUSE-20161020-129.9.noarch
    Problem: problem with installed package enlightenment-theme-openSUSE-ice-20161028-18.6.noarch
    Problem: problem with installed package enlightenment-theme-openSUSE-oliveleaf-20160922-16.21.noarch
    Problem: problem with installed package evas-generic-loaders-1.18.4-229.1.x86_64
    Problem: problem with installed package ffmpeg-3.3-6.8.1.x86_64
    Problem: problem with installed package g2clib-1.4.0-1.2.x86_64
    Problem: problem with installed package gdal-2.1.3-42.2.x86_64
    Problem: problem with installed package gdal-devel-2.1.3-43.1.x86_64
    Problem: problem with installed package grads-2.0.1-3.1.x86_64
    Problem: problem with installed package gstreamer-plugins-bad-1.8.3-5.5.4.x86_64
    Problem: problem with installed package gstreamer-plugins-libav-1.8.3-2.7.x86_64
    Problem: problem with installed package gstreamer-plugins-ugly-1.8.3-2.4.x86_64
    Problem: problem with installed package hdf5-1.10.0-43.3.x86_64
    Problem: problem with installed package k3b-2.9.90+git20170220.0453-8.15.x86_64
    Problem: problem with installed package k3b-codecs-2.9.90+git20170220.0453-8.15.x86_64
    Problem: problem with installed package k3b-lang-2.9.90+git20170220.0453-8.15.noarch
    Problem: problem with installed package kdenlive-16.12.3-14.1.x86_64
    Problem: problem with installed package lame-3.99.5-1016.1.x86_64
    Problem: problem with installed package libHalf12-2.2.0-3.1.x86_64
    Problem: problem with installed package libIex-2_2-12-2.2.0-3.1.x86_64
    Problem: problem with installed package liba52-0-0.7.4-13.2.x86_64
    Problem: problem with installed package libavcodec56-2.8.11-25.5.1.x86_64
    Problem: problem with installed package libavcodec57-3.3-6.8.1.x86_64
    Problem: problem with installed package libavdevice57-3.3-6.8.1.x86_64
    Problem: problem with installed package libavfilter6-3.3-6.8.1.x86_64
    Problem: problem with installed package libavformat56-2.8.11-25.5.1.x86_64
    Problem: problem with installed package libavformat57-3.3-6.8.1.x86_64
    Problem: problem with installed package libavresample3-3.3-6.8.1.x86_64
    Problem: problem with installed package libavutil54-2.8.11-25.5.1.x86_64
    Problem: problem with installed package libavutil55-3.3-6.8.1.x86_64
    Problem: problem with installed package libecore1-1.18.4-229.1.x86_64
    Problem: problem with installed package libector1-1.18.4-229.1.x86_64
    Problem: problem with installed package libedje1-1.18.4-229.1.x86_64
    Problem: problem with installed package libeet1-1.18.4-229.1.x86_64
    Problem: problem with installed package libeeze1-1.18.4-229.1.x86_64
    Problem: problem with installed package libefl1-1.18.4-229.1.x86_64
    Problem: problem with installed package libefreet1-1.18.4-229.1.x86_64
    Problem: problem with installed package libefreet_mime1-1.18.4-229.1.x86_64
    Problem: problem with installed package libefreet_trash1-1.18.4-229.1.x86_64
    Problem: problem with installed package libeina1-1.18.4-229.1.x86_64
    Problem: problem with installed package libeio1-1.18.4-229.1.x86_64
    Problem: problem with installed package libeldbus1-1.18.4-229.1.x86_64
    Problem: problem with installed package libelocation1-1.18.4-229.1.x86_64
    Problem: problem with installed package libelua1-1.18.4-229.1.x86_64
    Problem: problem with installed package libembryo1-1.18.4-229.1.x86_64
    Problem: problem with installed package libemile1-1.18.4-229.1.x86_64
    Problem: problem with installed package libemotion1-1.18.4-229.1.x86_64
    Problem: problem with installed package libeo1-1.18.4-229.1.x86_64
    Problem: problem with installed package libeolian1-1.18.4-229.1.x86_64
    Problem: problem with installed package libethumb1-1.18.4-229.1.x86_64
    Problem: problem with installed package libethumb_client1-1.18.4-229.1.x86_64
    Problem: problem with installed package libevas1-1.18.4-229.1.x86_64
    Problem: problem with installed package libfreexl1-1.0.2-18.2.x86_64
    Problem: problem with installed package libgdal20-2.1.3-42.2.x86_64
    Problem: problem with installed package libgeos_c1-3.5.1-19.1.x86_64
    Problem: problem with installed package libhdf4-4.2.11-39.5.x86_64
    Problem: problem with installed package libhdf5_fortran100-1.10.0-43.3.x86_64
    Problem: problem with installed package libhdf5_hl100-1.10.0-43.3.x86_64
    Problem: problem with installed package libhdf5_hl_cpp100-1.10.0-43.3.x86_64
    Problem: problem with installed package libhdf5hl_fortran100-1.10.0-43.3.x86_64
    Problem: problem with installed package libhogweed4-3.3-62.2.x86_64
    Problem: problem with installed package libicu-devel-58.2-0.1.x86_64
    Problem: problem with installed package libkcddb16-16.07.0-5.3.x86_64
    Problem: problem with installed package libmad0-0.15.1b-9.2.x86_64
    Problem: problem with installed package libmbim-1.14.0-23.1.x86_64
    Problem: problem with installed package libmlt++3-6.4.1-9.8.x86_64
    Problem: problem with installed package libmlt6-6.4.1-9.8.x86_64
    Problem: problem with installed package libmlt6-data-6.4.1-9.8.noarch
    Problem: problem with installed package libmlt6-modules-6.4.1-9.8.x86_64
    Problem: problem with installed package libmp3lame0-3.99.5-1016.1.x86_64
    Problem: problem with installed package libmpg123-0-1.24.0-8.1.x86_64
    Problem: problem with installed package libnettle6-3.3-62.2.x86_64
    Problem: problem with installed package libopenblas_pthreads0-0.2.19-32.7.x86_64
    Problem: problem with installed package libpostproc53-2.8.11-25.5.1.x86_64
    Problem: problem with installed package libpostproc54-3.3-6.8.1.x86_64
    Problem: problem with installed package libproj-devel-4.9.3-27.3.x86_64
    Problem: problem with installed package libproj12-4.9.3-27.3.x86_64
    Problem: problem with installed package libshp1-1.3.0-7.3.x86_64
    Problem: problem with installed package libspatialindex4-1.8.5-6.2.x86_64
    Problem: problem with installed package libspatialite7-4.3.0a-9.7.x86_64
    Problem: problem with installed package libstoken1-0.81-12.4.x86_64
    Problem: problem with installed package libswresample1-2.8.11-25.5.1.x86_64
    Problem: problem with installed package libswresample2-3.3-6.8.1.x86_64
    Problem: problem with installed package libswscale3-2.8.11-25.5.1.x86_64
    Problem: problem with installed package libswscale4-3.3-6.8.1.x86_64
    Problem: problem with installed package libtwolame0-0.3.13-3.1.x86_64
    Problem: problem with installed package libuv1-1.10.0-0.1.x86_64
    Problem: problem with installed package libvlc5-2.2.4-29.3.x86_64
    Problem: problem with installed package libvlccore8-2.2.4-29.3.x86_64
    Problem: problem with installed package libvulkan_intel-13.0.3-67.1.x86_64
    Problem: problem with installed package mbimcli-bash-completion-1.14.0-23.1.x86_64
    Problem: problem with installed package melt-6.4.1-9.8.x86_64
    Problem: problem with installed package melt6-6.4.1-9.8.x86_64
    Problem: problem with installed package memcached-1.4.39-2.1.x86_64
    Problem: problem with installed package movit-data-1.5.0-2.1.noarch
    Problem: problem with installed package postgresql-init-10-0.1.noarch
    Problem: problem with installed package proj-4.9.3-27.3.x86_64
    Problem: problem with installed package python-Brownie-0.5.1-17.6.noarch
    Problem: problem with installed package python-Jinja2-2.9.6-73.4.noarch
    Problem: problem with installed package python-Twisted-16.4.0-55.2.x86_64
    Problem: problem with installed package python-argparse-1.4.0-52.2.noarch
    Problem: problem with installed package python-attrs-16.0.0-3.2.noarch
    Problem: problem with installed package python-bonobo-2.28.1-41.5.x86_64
    Problem: problem with installed package python-docutils-0.13.1-59.11.noarch
    Problem: problem with installed package python-funcsigs-1.0.2-12.1.noarch
    Problem: problem with installed package python-gdal-2.1.2-42.14.x86_64
    Problem: problem with installed package python-gevent-1.2.1-36.55.x86_64
    Problem: problem with installed package python-gnomecanvas-2.28.1-41.5.x86_64
    Problem: problem with installed package python-gpgme-0.1-220.3.x86_64
    Problem: problem with installed package python-ldap-2.4.45-103.1.x86_64
    Problem: problem with installed package python-orbit-2.24.0-30.5.x86_64
    Problem: problem with installed package python-pam-0.5.0-162.2.x86_64
    Problem: problem with installed package python-psutil-5.0.0-77.1.x86_64
    Problem: problem with installed package python-py-1.4.34-55.2.noarch
    Problem: problem with installed package python-pyasn1-modules-0.0.8-35.3.noarch
    Problem: problem with installed package python-pycryptopp-0.7.1.869544967005693312591928092448767568728501330214-3.30.x86_64
    Problem: problem with installed package python-pygame-1.9.1-29.57.x86_64
    Problem: problem with installed package python-pyliblzma-0.5.3-13.3.x86_64
    Problem: problem with installed package python-pyserial-3.0.1-27.25.noarch
    Problem: problem with installed package python-python-openid-2.2.5-22.2.noarch
    Problem: problem with installed package python-service_identity-16.0.0-6.3.noarch
    Problem: problem with installed package python-setuptools-28.3.0-86.1.noarch
    Problem: problem with installed package python-simplejson-3.11.1-62.4.x86_64
    Problem: problem with installed package python-txsocksx-1.15.0.2-7.2.noarch
    Problem: problem with installed package python-zope.interface-4.3.1-39.6.x86_64
    Problem: problem with installed package python3-numpy-1.12.0-64.2.x86_64
    Problem: problem with installed package stoken-0.81-12.4.x86_64
    Problem: problem with installed package terminology-1.0.0-55.1.x86_64
    Problem: problem with installed package terminology-theme-dark-1.0.0-55.1.x86_64
    Problem: problem with installed package terminology-theme-misc-1.0.0-55.1.x86_64
    Problem: problem with installed package terminology-theme-openSUSE-20151216-35.30.noarch
    Problem: problem with installed package terminology-theme-openSUSE-oliveleaf-20160314-17.4.noarch
    Problem: problem with installed package torbrowser-launcher-0.2.6-9.4.noarch
    Problem: problem with installed package udunits-2.1.9-3.2.x86_64
    Problem: problem with installed package unetbootin-0.0.655-19.1.x86_64
    Problem: problem with installed package vlc-codec-gstreamer-2.2.4-29.3.x86_64
    Problem: problem with installed package vlc-noX-2.2.4-29.3.x86_64
    Problem: problem with installed package vlc-qt-2.2.4-29.3.x86_64
    Problem: problem with installed package wgrib-1.8.1.2a-3.1.x86_64
    Problem: problem with installed package wine-2.21-715.5.x86_64
    Problem: problem with installed package wine-32bit-2.21-715.5.x86_64
    Problem: problem with installed package wine-gecko-2.47-55.12.noarch
    Problem: problem with installed package wxWidgets-3_0-devel-3.0.2-1.86.x86_64
    Problem: problem with installed package wxWidgets-3_0-plugin-sound_sdlu-3_0-3.0.2-1.86.x86_64
    Problem: problem with installed package wxWidgets-lang-2.8.12-30.44.noarch
    Problem: libopenssl-1_0_0-devel-1.0.2n-1.1.x86_64 conflicts with libopenssl-devel > 1.0.2n provided by libopenssl-devel-1.1.0g-1.1.noarch
    Problem: openssl-1.1.0g-1.1.noarch requires openssl-1_1_0 = 1.1.0g, but this requirement cannot be provided
    Problem: openssl-1.0.2m-1.1.noarch requires openssl-1_0_0 = 1.0.2m, but this requirement cannot be provided

    Problem: problem with installed package PlayOnLinux-4.2.10-10.1.noarch
    Solution 1: install PlayOnLinux-4.2.12-2.2.noarch (with vendor change)
    obs://build.opensuse.org/home:regataos --> openSUSE

    Choose the above solution using '1' or skip, retry or cancel [1/s/r/c] (c):

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,645
    Blog Entries
    14

    Default Re: LibreOffice Wont Open

    I told you not to use anything else but 'zypper dup'. Why then run 'zypper update' ?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,645
    Blog Entries
    14

    Default Re: LibreOffice Wont Open

    Plus, you have mistakes in your repo URLS. And, what is a PowerPC repo doing in your TW install?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #8
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: LibreOffice Wont Open

    tell us your repo list as it seams broken
    Code:
    zypper lr -d
    first fix your bad repo's then re-run
    Code:
    zypper dup
    nothing else

  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,475

    Exclamation Re: LibreOffice Wont Open

    As a further reference, you may find the following thread to be of interest -- especially the solution: <https://forums.opensuse.org/showthre...ening-document>.

  10. #10
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,645
    Blog Entries
    14

    Default Re: LibreOffice Wont Open

    Quote Originally Posted by dcurtisfra View Post
    As a further reference, you may find the following thread to be of interest -- especially the solution: <https://forums.opensuse.org/showthre...ening-document>.
    Don, I think that before getting there, the OP needs to fix a borked system, or reinstall and stick to some basic rules that are well documented.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •