Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: KDE start niet meer op (HELP....)

  1. #1
    Join Date
    Mar 2016
    Location
    Veendam The Netherlands
    Posts
    42

    Default KDE start niet meer op (HELP....)

    Hallo,
    Ik heb het volgende probleem en hoop dat iemand op dit forum mij kan helpen het op te lossen.
    Ik heb gisteren wat CAD programma's (LibreCAD en BRL-CAD) geinstalleerd en waarschijnlijk
    is er toen iets mis gegaan.
    Na de koffie kwam ik terug bij mijn computer (met 64 bits OpenSuSE Leap 42.1 met KDE) en zag een foutmelding
    die ik (volgens die melding) als volgt op kon lossen.
    Eerst "CRTL-ALT-F2", daarna aanmelden (als root) dan "loginctl unlock-sessions" ingeven en dan "CTRL-ALT-F7".
    Toen werkte alles weer normaal, na het uit en weer inschakelen van de PC wordt er nu echter niet doorgestart naar KDE,
    maar stopt alles bij een inlog prompt in text modus.
    Ik weet niet hoe KDE dan gestart moet worden, commando's als "kdm" en "startkde" werken niet.
    Bij "startx" krijg ik de melding "Server already running" en nog wat andere informatie.
    Een van beide boven genoemde CAD programma's zal dit waarschijnlijk veroorzaakt hebben.
    Bij de installatie van (volgens mij) BRL-CAD werden er ook programma's met "plasma" in de bestandsnaam geinstalleerd.
    En waarschijnlijk is er ook een "opensuse_leap_42.2/graphics.repo" geinstalleerd.
    Als ik repo's installeer zijn dat 42.1 versies dus ik heb het vermoeden dat de 42.2 repo ook gisteren is toegevoegd.

    Als ik een andere linux versie uit het boot (grub ?) menu kies, start KDE wel op, alleen heb ik dan niet de beschikking
    over mijn eerder al geinstalleerde programma's.
    Hoe is dit op een veilige manier op te lossen ?
    De plasma desktop opnieuw installeren ? (maar hoe ?), een snapshot (volgens mij worden die aangemaakt) terugzetten
    (geen idee hoe ik dat moet doen) of is dit ook op een andere manier te repareren ?
    Als ik na inloggen een "ls" commando geef, komen mijn bestanden gewoon in beeld.
    Die zijn er dus gelukkig waarschijnlijk allemaal nog.

    Wie helpt ?

    Groet,
    Flash2005


    (OpenSuSE Leap 42.1 met KDE.)

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,742

    Default Re: KDE start niet meer op (HELP....)

    Een vrij uitgebriede beschrijving, maar omdat je zelf zegt dat de installatie van een paar producten mogelijk de oorzaak is, zouden wij graag willen weten hoe en waarvan je die hebt geïnstalleerd.

    Van een repository? Zo ja, welke? Het lijkt dat je daar iets van 42.2 hebt gebruikt omdat je zo'n repo ook ziet.
    Henk van Velden

  3. #3
    Join Date
    Mar 2016
    Location
    Veendam The Netherlands
    Posts
    42

    Default Re: KDE start niet meer op (HELP....)

    Hallo,

    Ik heb deze repo in elk geval niet zelf toegevoegd.
    Ik zorg er altijd voor dat ik altijd repo's toevoeg van de versie die ik gebruik.
    Dat die 42.2 versie er dus nu tussen staat is vreemd.

    BRL-CAD is geinstalleerd van een van een "tar.gz" bestand.I
    Dat bestand heb ik gedownload op "https://sourceforge.net/projects/brlcad/files/BRL-CAD%20for%20Linux/".

    LibreCAD zou het kunnen zijn, dat programma is vanaf een repo of vanaf een website middels "1 Click Install" geinstalleerd.
    Bij "1 Click install" worden er nog wel eens repo's toegevoegd.

    Er is niet met zekerheid te zeggen welk het programma het is geweest.

    Ik gebruik nu OpenSuSE Leap 42.1, ik zag op de OpenSuSE website dat Leap 42.3 al uit is.
    Zou upgraden naar deze versie een optie zijn ?
    Is het verstandig om dat te doen op een systeem dat nu niet goed werkt ?
    Ik ben daar zelf wat huiverig voor.

    Groet,
    Flash2005

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,742

    Default Re: KDE start niet meer op (HELP....)

    1.
    Bij een zgn. 1-click install krijg je volgens mij de vraag of je geabonneerd wilt blijven op de desbetreffende repo. Als je dat dus bent, heb je dat zelf gedaan.

    2.
    Die 42.2 repo bij een 42.1 systeem is vragen om problemen. Normaal zou de oplossing zijn om de repo te verwijderen en een zypper dup te doen om alles wat daar vandaan is gekomen weer opnieuw van 42.1 repos te laden.
    In dit geval hebt je echter het probleem dat je een ongesupporte versie hebt. De repos van 42.1 zijn er dus niet meer.
    Het hoeft geen probleem te zijn om een ongesupporte versie te draaien, maar dan moet je ook alles bevriezen. Zo'n systeem kan nog jaren vooruit (afgezien van veiligheidsgaten) als je maar niets aan de software verandert.
    Henk van Velden

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: KDE start niet meer op (HELP....)

    Ik zou in jouw geval de gelegenheid te baat nemen en upgraden naar 42.3 ( hoeft niet eerst naar 42.2, ook het pad 42.1 -> 42.3 wordt getest in openqa ).
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6
    Join Date
    Mar 2016
    Location
    Veendam The Netherlands
    Posts
    42

    Default Re: KDE start niet meer op (HELP....)

    Hallo

    Ik ben al bezig geweest om bestanden naar een USB HDD over te zetten.
    Er staan 2 linux installaties (allebei Leap 42.1) op mijn PC.
    Waarschijnlijk zal dat met een herinstallatie een keer gebeurd zijn.

    Er staat een versie op"/dev.sdb2" (is een SSD) en een versie op "/dev/sda" (is een HDD).
    De SSD versie start niet door naar KDE maar krijg ik een text prompt.
    De HDD versie werkt wel middels die versie heb ik backups gemaakt, en gebruik ik op dit moment.


    Ik heb flink wat data verplaatst naar een USB HDD.
    Daarna heb ik die USB HDD verwijderd, door de USB stekker uit mijn PC te trekken.
    (Eerst netjes afgekoppeld in Linux natuurlijk)
    Maar als ik dan probeer te upgraden naar 'Leap 42.3" krijg ik de volgende foutmelding.
    "Partitie "/" heeft xxxx MB/ GB meer schijfruimte nodig.
    Deselecteer pakketten of verwijder gegevens of tijdelijke bestanden voordat u het systeem gaat bijwerken."

    Dus ga ik weer bestanden verplaatsen naar USB HDD, en herhaal de upgrade vanaf DVD.
    De eerste keer dat ik de foutmelding kreeg was er ongeveer 700 MB meer schijfruimte nodig.

    Na het opnieuw (2e keer) verplaatsen naar USB HDD zou de foutmelding weg moeten zijn of in elk geval lager dan 700 MB moeten zijn.
    Het vreemde is dat dat getal niet kleiner wordt maar hoger !

    Ik heb de "verplaats naar USB HDD aktie / DVD upgrade" nu 3x uitgevoerd, en het getal stijgt van 700 MB, naar 1.1 GB naar nu 1.319 GB.
    Heel vreemd, dat getal zou toch lager moeten worden ?

    Ik werk vanaf de Leap versie op de HDD met Dolphin in SuperUser modus met zichtbare verborgen bestanden, de prullebak wordt uiteraard altijd leeg gemaakt.
    (Meestal is die prullebak trouwens leeg, omdat ik bestanden verplaats en dan komt er natuurlijk niets in de prullebak terecht.)

    Hoe is dit op te lossen ?
    Vreemd.... Heel vreemd..... :-)


    Groet,
    Flash 2005

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: KDE start niet meer op (HELP....)

    Quote Originally Posted by Flash2005 View Post
    Hallo

    Ik ben al bezig geweest om bestanden naar een USB HDD over te zetten.
    Er staan 2 linux installaties (allebei Leap 42.1) op mijn PC.
    Waarschijnlijk zal dat met een herinstallatie een keer gebeurd zijn.

    Er staat een versie op"/dev.sdb2" (is een SSD) en een versie op "/dev/sda" (is een HDD).
    De SSD versie start niet door naar KDE maar krijg ik een text prompt.
    De HDD versie werkt wel middels die versie heb ik backups gemaakt, en gebruik ik op dit moment.


    Ik heb flink wat data verplaatst naar een USB HDD.
    Daarna heb ik die USB HDD verwijderd, door de USB stekker uit mijn PC te trekken.
    (Eerst netjes afgekoppeld in Linux natuurlijk)
    Maar als ik dan probeer te upgraden naar 'Leap 42.3" krijg ik de volgende foutmelding.
    "Partitie "/" heeft xxxx MB/ GB meer schijfruimte nodig.
    Deselecteer pakketten of verwijder gegevens of tijdelijke bestanden voordat u het systeem gaat bijwerken."

    Dus ga ik weer bestanden verplaatsen naar USB HDD, en herhaal de upgrade vanaf DVD.
    De eerste keer dat ik de foutmelding kreeg was er ongeveer 700 MB meer schijfruimte nodig.

    Na het opnieuw (2e keer) verplaatsen naar USB HDD zou de foutmelding weg moeten zijn of in elk geval lager dan 700 MB moeten zijn.
    Het vreemde is dat dat getal niet kleiner wordt maar hoger !

    Ik heb de "verplaats naar USB HDD aktie / DVD upgrade" nu 3x uitgevoerd, en het getal stijgt van 700 MB, naar 1.1 GB naar nu 1.319 GB.
    Heel vreemd, dat getal zou toch lager moeten worden ?

    Ik werk vanaf de Leap versie op de HDD met Dolphin in SuperUser modus met zichtbare verborgen bestanden, de prullebak wordt uiteraard altijd leeg gemaakt.
    (Meestal is die prullebak trouwens leeg, omdat ik bestanden verplaats en dan komt er natuurlijk niets in de prullebak terecht.)

    Hoe is dit op te lossen ?
    Vreemd.... Heel vreemd..... :-)


    Groet,
    Flash 2005
    De verkaring: je hebt een btrfs root filesystem, en dat maakt snapshots aan bij elke poging die je doet tot upgraden. Met de YaST Snapper module kun je eerst 's al die snapshots verwijderen, daarna de upgrade uitvoeren.
    Als het goed is heb je /home op een aparte partitie staan. Daarvan dingen verwijderen heeft geen zin, het probleem bij de upgrade zit op je rootpartitie.
    Wat je niet duidelijk beschrijft is welke bestanden je precies naar USB verplaatst.

    Waarom verander je niet de repos via YaST, gewoon van 42.1 en 42.2 overal 42.3 maken, en dan in een terminal-venster
    Code:
    zypper ref && zypper dup
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #8
    Join Date
    Mar 2016
    Location
    Veendam The Netherlands
    Posts
    42

    Default Re: KDE start niet meer op (HELP....)

    Hallo,


    Ik heb gebruikers data verplaatst zoals tekst bestanden, foto's, fims, PDF-jes, dus geen systeem bestanden.
    Verder een paar mappen met spelletje's die ik al heel lang niet heb gespeeld.
    Ik heb uiteraard bewust geen systeem bestanden verplaatst, en bestanden waar van ik niet zeker ben waar ze bij horen.

    Ik heb inderdaad een "btrfs" bestandssysteem, en in Yast Snapper staan inderdaad (7 regels) snapshots.
    Een paar daarvan zijn van vandaag dus dat klopt helemaal.
    Bij een paar snapshots staat "important = yes"
    Is het handig om de oude versies (van 09-05-2017 en 09-07-2017) eerst te laten staan, en alleen eerst de snapshots van vandaag en gisteren te verwijderen ?
    Mocht ik dan nog geen ruimte genoeg hebben, kan ik de oudere versies ook nog verwijderen.
    Of is dat niet mogelijk of verstandig ?

    Ik heb nu 2 Linux versies op mijn PC staan. (een op HDD en een op SDD).
    Ik werk nu op de HDD Linux versie, staan in Snapper alleen de snapshots van de HDD Linux versie of ook van de SDD Linux versie ?

    De repo's wijzigen van 42.1 naar 42.3 wordt een probleem.
    Alleen de SSD Linux versie heeft repo's, op de HDD Linux versie zijn geen repo's aanwezig.
    Om de repo's te wijzigen heb ik (als noob zijnde) KDE nodig en die start in de SSD Linux versie niet op.
    Daar komt nog bij dat als mij dat al zou lukken de upgrade via een internet verbinding verloopt.
    En dat kan natuurlijk een keer mis gaan, ik doe het liever via de DVD dat vind ik net even veiliger. :-)

    Groet,
    Flash2005

  9. #9
    Join Date
    Mar 2016
    Location
    Veendam The Netherlands
    Posts
    42

    Default Re: KDE start niet meer op (HELP....)

    Hallo,


    Helaas werkt het nog niet.
    Ik heb alle snapshots verwijderd in Yast Snapper, behalve de oudste 2 regels.
    Ik heb nog even in de prullenbak gekeken (als root en als normale user) maar daar stond niets in.
    Blijkbaar worden snapshots als ze in Yast Snapper worden verwijderd direct definitief verwijderd.

    Daarna weer een upgrade vanaf DVD gedaan, maar nu krijg ik de melding dat er 1.569 GB meer schijfruimte nodig is.
    Ik boot vanaf DVD, kies voor "Upgrade" kies de SDD Linux versie (/dev/sdb2) op de SSD en daarna komt bovenstaande foutmelding in beeld.

    Yast Snapper draai ik in KDE in een linux versie die op de HDD (/dev/sda7) staat.
    De Linux versie die problemen geeft (geen KDE) staat op een SSD (/dev/sdb2).

    In een vorige post op dit forum heb ik wat schijfinformatie gegeven.
    Op de onderstaande link kun je die post nog eens nalezen.
    https://forums.opensuse.org/showthre...ight=Flash2005

    Die commando's heb ik nu weer gedraaid met het onderstaande resultaat.

    linux-6adt:/ # sudo gdisk -l /dev/sda
    GPT fdisk (gdisk) version 0.8.8

    Partition table scan:
    MBR: MBR only
    BSD: not present
    APM: not present
    GPT: not present


    ***************************************************************
    Found invalid GPT and valid MBR; converting MBR to GPT format
    in memory.
    ***************************************************************

    Disk /dev/sda: 3907029168 sectors, 1.8 TiB
    Logical sector size: 512 bytes
    Disk identifier (GUID): 2CFBC29A-F5DC-46A0-AC70-9487E2B9BFAB
    Partition table holds up to 128 entries
    First usable sector is 34, last usable sector is 3907029134
    Partitions will be aligned on 2048-sector boundaries
    Total free space is 10349 sectors (5.1 MiB)

    Number Start (sector) End (sector) Size Code Name
    5 4096 321535 155.0 MiB 8300 Linux filesystem
    6 323584 4530175 2.0 GiB 8200 Linux swap
    7 4532224 88422399 40.0 GiB 8300 Linux filesystem
    8 88424448 3907028991 1.8 TiB 8300 Linux filesystem


    linux-6adt:/ # sudo gdisk -l /dev/sda5
    GPT fdisk (gdisk) version 0.8.8

    Partition table scan:
    MBR: MBR only
    BSD: not present
    APM: not present
    GPT: not present


    ***************************************************************
    Found invalid GPT and valid MBR; converting MBR to GPT format
    in memory.
    ***************************************************************

    Disk /dev/sda5: 317440 sectors, 155.0 MiB
    Logical sector size: 512 bytes
    Disk identifier (GUID): A92086AE-FFA2-4949-B970-D79A223708D6
    Partition table holds up to 128 entries
    First usable sector is 34, last usable sector is 317406
    Partitions will be aligned on 2048-sector boundaries
    Total free space is 317373 sectors (155.0 MiB)

    Number Start (sector) End (sector) Size Code Name


    linux-6adt:/ # sudo gdisk -l /dev/sda6
    GPT fdisk (gdisk) version 0.8.8

    Partition table scan:
    MBR: not present
    BSD: not present
    APM: not present
    GPT: not present

    Creating new GPT entries.
    Disk /dev/sda6: 4206592 sectors, 2.0 GiB
    Logical sector size: 512 bytes
    Disk identifier (GUID): 929A09A3-823B-4A7E-9CAD-3F63F6996D4D
    Partition table holds up to 128 entries
    First usable sector is 34, last usable sector is 4206558
    Partitions will be aligned on 2048-sector boundaries
    Total free space is 4206525 sectors (2.0 GiB)

    Number Start (sector) End (sector) Size Code Name


    linux-6adt:/ # sudo gdisk -l /dev/sda7
    GPT fdisk (gdisk) version 0.8.8

    Partition table scan:
    MBR: not present
    BSD: not present
    APM: not present
    GPT: not present

    Creating new GPT entries.
    Disk /dev/sda7: 83890176 sectors, 40.0 GiB
    Logical sector size: 512 bytes
    Disk identifier (GUID): EB8B598E-2972-4DD0-A04F-02C3D1991AE9
    Partition table holds up to 128 entries
    First usable sector is 34, last usable sector is 83890142
    Partitions will be aligned on 2048-sector boundaries
    Total free space is 83890109 sectors (40.0 GiB)

    Number Start (sector) End (sector) Size Code Name


    linux-6adt:/ # sudo gdisk -l /dev/sda8
    GPT fdisk (gdisk) version 0.8.8

    Partition table scan:
    MBR: not present
    BSD: not present
    APM: not present
    GPT: not present

    Creating new GPT entries.
    Disk /dev/sda8: 3818604544 sectors, 1.8 TiB
    Logical sector size: 512 bytes
    Disk identifier (GUID): C45914D9-748E-442A-8E9F-6BF4ADEB9900
    Partition table holds up to 128 entries
    First usable sector is 34, last usable sector is 3818604510
    Partitions will be aligned on 2048-sector boundaries
    Total free space is 3818604477 sectors (1.8 TiB)

    Number Start (sector) End (sector) Size Code Name


    linux-6adt:/ # sudo gdisk -l /dev/sdb2
    GPT fdisk (gdisk) version 0.8.8

    Partition table scan:
    MBR: not present
    BSD: not present
    APM: not present
    GPT: not present

    Creating new GPT entries.
    Disk /dev/sdb2: 83890176 sectors, 40.0 GiB
    Logical sector size: 512 bytes
    Disk identifier (GUID): 04512AC4-183F-42D6-95FB-683D4B665774
    Partition table holds up to 128 entries
    First usable sector is 34, last usable sector is 83890142
    Partitions will be aligned on 2048-sector boundaries
    Total free space is 83890109 sectors (40.0 GiB)

    Number Start (sector) End (sector) Size Code Name


    linux-6adt:/ # sudo gdisk -l /dev/sdb
    GPT fdisk (gdisk) version 0.8.8

    Partition table scan:
    MBR: protective
    BSD: not present
    APM: not present
    GPT: present

    Found valid GPT with protective MBR; using GPT.
    Disk /dev/sdb: 500118192 sectors, 238.5 GiB
    Logical sector size: 512 bytes
    Disk identifier (GUID): A812A192-49A4-4FC0-AFF3-DACD78E22D1F
    Partition table holds up to 128 entries
    First usable sector is 34, last usable sector is 500118158
    Partitions will be aligned on 2048-sector boundaries
    Total free space is 2669 sectors (1.3 MiB)

    Number Start (sector) End (sector) Size Code Name
    1 2048 321535 156.0 MiB EF00 primary
    2 321536 84211711 40.0 GiB 0700 primary
    3 84211712 500117503 198.3 GiB 0700 primary


    Het commando "fstab" geeft helaas de volgende foutmelding.

    linux-6adt:/ # fstab
    If 'fstab' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf fstab
    linux-6adt:/ #

    WIe helpt ? :-)

    Groet,
    Flash2005

  10. #10
    Join Date
    Mar 2016
    Location
    Veendam The Netherlands
    Posts
    42

    Default Re: KDE start niet meer op (HELP....)

    Hallo,


    ik heb "df" nog even gedraaid, met het onderstaande resultaat.

    df
    Bestandssysteem 1K-blokken Gebruikt Beschikbaar Geb% Aangekoppeld op
    devtmpfs 16424880 0 16424880 0% /dev
    tmpfs 16431540 1168 16430372 1% /dev/shm
    tmpfs 16431540 2468 16429072 1% /run
    tmpfs 16431540 0 16431540 0% /sys/fs/cgroup
    /dev/sda7 41945088 5641160 35013400 14% /
    /dev/sda7 41945088 5641160 35013400 14% /.snapshots
    /dev/sda7 41945088 5641160 35013400 14% /var/tmp
    /dev/sda7 41945088 5641160 35013400 14% /var/spool
    /dev/sda7 41945088 5641160 35013400 14% /tmp
    /dev/sda7 41945088 5641160 35013400 14% /srv
    /dev/sda7 41945088 5641160 35013400 14% /var/opt
    /dev/sda7 41945088 5641160 35013400 14% /usr/local
    /dev/sda7 41945088 5641160 35013400 14% /opt
    /dev/sda7 41945088 5641160 35013400 14% /var/log
    /dev/sda7 41945088 5641160 35013400 14% /var/lib/named
    /dev/sda7 41945088 5641160 35013400 14% /var/lib/pgsql
    /dev/sda7 41945088 5641160 35013400 14% /var/lib/mariadb
    /dev/sda7 41945088 5641160 35013400 14% /var/lib/mysql
    /dev/sda7 41945088 5641160 35013400 14% /var/lib/libvirt/images
    /dev/sda7 41945088 5641160 35013400 14% /var/crash
    /dev/sda7 41945088 5641160 35013400 14% /var/lib/mailman
    /dev/sda7 41945088 5641160 35013400 14% /boot/grub2/x86_64-efi
    /dev/sda7 41945088 5641160 35013400 14% /boot/grub2/i386-pc
    /dev/sda5 158540 184 158356 1% /boot/efi
    /dev/sda8 1908369996 24215912 1884154084 2% /home
    /dev/sdb2 41945088 32300256 9431184 78% /run/media/<naam user>/c8c23425-b81d-4f77-98d5-3928d32b958a
    /dev/sdb3 207851360 42522104 165329256 21% /run/media/<naam user>/e8368054-f934-446e-b0a1-89878ee79dac

    De map "/run/media/user/c8c23425-b81d-4f77-98d5-3928d32b958a" op "/dev/sdb2" is blijkbaar nogal vol.
    Ik heb die map in Terminal geopend, alleen staat er niets in.
    Dus vraag ik mij af hoe ik die data zichtbaar maak, wat voor data het is en of het gewist kan worden. :-)

    Groet,
    Flash 2005

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •