Results 1 to 6 of 6

Thread: Upgrade and Gstreamer provider change

  1. #1

    Default Upgrade and Gstreamer provider change

    Hello,
    I tried to make an upgrade to Tumbleweed, but I had some conflicts with Gstreamer plugins:
    Code:
    2 Probleme:
    Problem: gstreamer-plugins-ugly-lang-1.12.3-2.2.noarch benötigt gstreamer-plugins-ugly = 1.12.3, kann jedoch nicht zur Verfügung gestellt werden
    Problem: gstreamer-plugins-bad-lang-1.12.3-6.1.noarch benötigt gstreamer-plugins-bad = 1.12.3, kann jedoch nicht zur Verfügung gestellt werden
    
    Problem: gstreamer-plugins-ugly-lang-1.12.3-2.2.noarch benötigt gstreamer-plugins-ugly = 1.12.3, kann jedoch nicht zur Verfügung gestellt werden
      Gelöschte Anbieter: gstreamer-plugins-ugly-1.12.3-4.7.x86_64
    Nicht installierbare Anbieter: gstreamer-plugins-ugly-1.12.3-2.2.i586[repo-oss]
                       gstreamer-plugins-ugly-1.12.3-2.2.x86_64[repo-oss]
     Lösung 1: gstreamer-plugins-ugly-1.12.3-2.2.x86_64 installieren (mit Anbieterwechsel)
      http://packman.links2linux.de --> openSUSE
     Lösung 2: gstreamer-plugins-ugly-lang-1.12.4-4.1.noarch installieren (mit Anbieterwechsel)
      openSUSE --> http://packman.links2linux.de
     Lösung 3: veraltetes gstreamer-plugins-ugly-1.12.3-4.7.x86_64 beibehalten
     Lösung 4: gstreamer-plugins-ugly-lang-1.12.3-2.2.noarch durch Ignorieren einiger Abhängigkeiten brechen
    
    Wählen Sie aus den obigen Lösungen mittels Nummer oder Sie (u)eberspringen, (w)iederholen oder brechen (a)b [1/2/3/4/u/w/a] (a): 1
    
    Problem: gstreamer-plugins-bad-lang-1.12.3-6.1.noarch benötigt gstreamer-plugins-bad = 1.12.3, kann jedoch nicht zur Verfügung gestellt werden
      Gelöschte Anbieter: gstreamer-plugins-bad-1.12.3-7.12.x86_64
    Nicht installierbare Anbieter: gstreamer-plugins-bad-1.12.3-6.1.i586[repo-oss]
                       gstreamer-plugins-bad-1.12.3-6.1.x86_64[repo-oss]
     Lösung 1: gstreamer-plugins-bad-1.12.3-6.1.x86_64 installieren (mit Anbieterwechsel)
      http://packman.links2linux.de --> openSUSE
     Lösung 2: gstreamer-plugins-bad-lang-1.12.4-4.1.noarch installieren (mit Anbieterwechsel)
      openSUSE --> http://packman.links2linux.de
     Lösung 3: veraltetes gstreamer-plugins-bad-1.12.3-7.12.x86_64 beibehalten
     Lösung 4: gstreamer-plugins-bad-lang-1.12.3-6.1.noarch durch Ignorieren einiger Abhängigkeiten brechen
    
    Wählen Sie aus den obigen Lösungen mittels Nummer oder Sie (u)eberspringen, (w)iederholen oder brechen (a)b [1/2/3/4/u/w/a] (a): 1
    Abhängigkeiten werden aufgelöst...
    Distributions-Aktualisierungen werden verarbeitet...
    2 Probleme:
    Problem: gstreamer-plugins-bad-orig-addon-1.12.4-4.1.x86_64 benötigt gstreamer-plugins-bad >= 1.12.4, kann jedoch nicht zur Verfügung gestellt werden
    Problem: gstreamer-plugins-ugly-orig-addon-1.12.4-4.1.x86_64 benötigt gstreamer-plugins-ugly >= 1.12.4, kann jedoch nicht zur Verfügung gestellt werden
    
    Problem: gstreamer-plugins-bad-orig-addon-1.12.4-4.1.x86_64 benötigt gstreamer-plugins-bad >= 1.12.4, kann jedoch nicht zur Verfügung gestellt werden
      Nicht installierbare Anbieter: gstreamer-plugins-bad-1.12.4-4.1.i586[Packman]
                       gstreamer-plugins-bad-1.12.4-4.1.x86_64[Packman]
     Lösung 1: Deinstallation von gstreamer-plugins-bad-orig-addon-1.12.3-7.12.x86_64
     Lösung 2: veraltetes gstreamer-plugins-bad-orig-addon-1.12.3-7.12.x86_64 beibehalten
     Lösung 3: gstreamer-plugins-bad-1.12.3-6.1.x86_64 nicht installieren
     Lösung 4: gstreamer-plugins-bad-orig-addon-1.12.4-4.1.x86_64 durch Ignorieren einiger Abhängigkeiten brechen
    
    Wählen Sie aus den obigen Lösungen mittels Nummer oder Sie (u)eberspringen, (w)iederholen oder brechen (a)b [1/2/3/4/u/w/a] (a):
    I don't want to break my installation, so any help with the right choice of options would be appreciated
    Thank you very much!

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Upgrade and Gstreamer provider change

    some more info
    what is your current OS
    Code:
    cat /etc/os-release
    what are your repo's
    Code:
    zypper lr -d

  3. #3

    Default Re: Upgrade and Gstreamer provider change

    Thank you.
    The version is:
    Code:
    # VERSION="20171129"
    ID=opensuse
    ID_LIKE="suse"
    VERSION_ID="20171129"
    PRETTY_NAME="openSUSE Tumbleweed"
    And the repos are:
    Code:
    Repository-Prioritäten treten in Kraft:       (Siehe 'zypper lr -P' für Details)
          70 (erhöhte Priorität)  :  1 Repository 
          99 (Standard-Priorität) :  3 Repositorys
    
    # | Alias        | Name                        | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ    | URI                                                                 | Dienst
    --+--------------+-----------------------------+-----------+-----------------+----------------+-----------+--------+---------------------------------------------------------------------+-------
    1 | Packman      | Packman                     | Ja        | (r ) Ja         | Ja             |   70      | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/ |       
    2 | repo-debug   | openSUSE-Tumbleweed-Debug   | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/debug/tumbleweed/repo/oss/             |       
    3 | repo-non-oss | openSUSE-Tumbleweed-Non-Oss | Ja        | (r ) Ja         | Ja             |   99      | yast2  | http://download.opensuse.org/tumbleweed/repo/non-oss/               |       
    4 | repo-oss     | openSUSE-Tumbleweed-Oss     | Ja        | (r ) Ja         | Ja             |   99      | yast2  | http://download.opensuse.org/tumbleweed/repo/oss/                   |       
    5 | repo-source  | openSUSE-Tumbleweed-Source  | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/source/tumbleweed/repo/oss/            |       
    6 | repo-update  | openSUSE-Tumbleweed-Update  | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/update/tumbleweed/

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Upgrade and Gstreamer provider change

    This is what I did:
    Code:
    zypper dup --from Packman && zypper dup
    IIRC after that the upgrade went smoothly.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: Upgrade and Gstreamer provider change

    Thank you, but what's the difference with the normal dup command please?

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,721

    Default AW: Upgrade and Gstreamer provider change

    The Standard for zypper dup in Tumbleweed is now:
    Code:
    zypper dup --no-allow-vendor-change
    So if you want to change the Vendor (Repo), you have to do that explicit.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •