Results 1 to 7 of 7

Thread: Qualcom Atheros wireless network adapter -- cannot turn it on

  1. #1

    Default Qualcom Atheros wireless network adapter -- cannot turn it on

    New to openSUSE. Recently installed Leap 42.3 on desktop Dell. The wireless adapter is a Qualcom Atheros QCA9565/AR9565. Although the ethernet connection works fine, there is no connectivity indicator icon in the tray at the bottom of the screen, so I cannot turn on the wireless network adapter.

    I'm not even sure if the appropriate driver is installed. I opened YAST and poked around, and it looks correctly configured, but I'm not experienced enough to be sure.

    Leads to these questions:

    1) How can I turn on the wireless network adapter? When I was running Ubuntu on this machine, the wireless manager simply scanned the area, I selected my wireless account and put my password in a dialog box, and it worked. I understand that KDE is different...but I can't get it to work.

    2) Is there a widget or something that I can select to manage my wireless connectivity?

    3) How can I ensure that the proper drivers are installed? Perhaps this is the problem?


    Any suggestions would be greatly appreciated. Best, pino

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,703
    Blog Entries
    1

    Default Re: Qualcom Atheros wireless network adapter -- cannot turn it on

    The first thing to know is that openSUSE provides two frameworks for managing network connections: Wicked and NetworkManager. Running one of the following will help tell which is in use currently...
    Code:
    ps -A|egrep -i "net|wick"
    or
    Code:
    systemctl status network
    For wireless connectivity (and changing network environments frequently), NetworkManager is the way to go, and will provide the graphical icon you're referring to. To change to NM fire up yast...

    YaST > System > Network Settings > Global Options Tab, choose NetworkManager to manage the network

    Reference:
    https://doc.opensuse.org/documentati...ec.nm.activate

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,703
    Blog Entries
    1

    Default Re: Qualcom Atheros wireless network adapter -- cannot turn it on

    For the hardware side of things you can check the chipset and driver details using
    Code:
    /sbin/lspci -nnk |grep '\[02' -A3
    *This will report all network class (02) devices connected to a PCI bus.

    Alternatively, the hwinfo command...
    Code:
    /usr/sbin/hwinfo --netcard
    You can check if network device nodes (including wireless) are present with
    Code:
    ip a
    Last edited by deano_ferrari; 14-Dec-2017 at 14:12.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,336
    Blog Entries
    15

    Default Re: Qualcom Atheros wireless network adapter -- cannot turn it on

    On Thu 14 Dec 2017 08:06:02 PM CST, deano ferrari wrote:

    For the hardware side of things you can check the chipset and driver
    details using

    Code:
    --------------------
    sbin/lspci -nnk |grep '\[02' -A3
    --------------------

    *This will report all network class (02) devices connected to a PCI bus.

    Alternatively, the hwinfo command...

    Code:
    --------------------
    /usr/sbin/hwinfo --netcard
    --------------------


    You can check if wireless device nodes are presnt with

    Code:
    --------------------
    ip a
    --------------------


    Hi
    Could also be a physical switch or a soft block so also need to check
    with rfkill (needs installing).

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2|GNOME 3.20.2|4.4.92-18.36-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  5. #5

    Default Re: Qualcom Atheros wireless network adapter -- cannot turn it on

    Quote Originally Posted by deano_ferrari View Post
    The first thing to know is that openSUSE provides two frameworks for managing network connections: Wicked and NetworkManager. Running one of the following will help tell which is in use currently...
    Code:
    ps -A|egrep -i "net|wick"
    or
    Code:
    systemctl status network
    For wireless connectivity (and changing network environments frequently), NetworkManager is the way to go, and will provide the graphical icon you're referring to. To change to NM fire up yast...

    YaST > System > Network Settings > Global Options Tab, choose NetworkManager to manage the network

    Reference:
    https://doc.opensuse.org/documentati...ec.nm.activate


    Thank you, Deano! This worked!

  6. #6

    Default Re: Qualcom Atheros wireless network adapter -- cannot turn it on

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Could also be a physical switch or a soft block so also need to check
    with rfkill (needs installing).

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2|GNOME 3.20.2|4.4.92-18.36-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


    Thanks, Malcolm!

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,703
    Blog Entries
    1

    Default Re: Qualcom Atheros wireless network adapter -- cannot turn it on

    Quote Originally Posted by pinoverde View Post
    Thank you, Deano! This worked!
    Glad to have been of guidance.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •