Results 1 to 8 of 8

Thread: Tumbleweed Boot Error (Dependency Failed for Swap)

  1. #1

    Default Tumbleweed Boot Error (Dependency Failed for Swap)

    Hello everyone!

    please I need help ������






    Thank you

  2. #2

    Default Re: Tumbleweed Boot Error (Dependency Failed for Swap)

    There is dev id mismatch from the grub boot file. How do I fix this problem?


  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,672
    Blog Entries
    3

    Default Re: Tumbleweed Boot Error (Dependency Failed for Swap)

    You will need to be able to access the system to get information. You can do that by booting to a live CD (or live USB) from just about any linux. Or use the Tumbleweed live rescue CD. Alternatively, you can boot into your install media in rescue mode. Fixing the problem will also require access and chroot access. So the Tumbleweed live rescue or the install media in rescue mode are best for that.

    Grub seems to take your swap to be "/dev/sda1".

    What is the output from
    Code:
    grep swap /etc/fstab
    and what is the output from
    Code:
    blkid
    (maybe from "blkid /dev/sda1" could be sufficient if that is the correct swap device).
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,672
    Blog Entries
    3

    Default Re: Tumbleweed Boot Error (Dependency Failed for Swap)

    I later realized that my reply may have been too brief if you are relatively inexperienced.

    So let's try again.

    I am assuming, based on your output, that your root partition is "/dev/sda2" and your swap partition is "/dev/sda1".

    From your rescue boot, login as root (usually doesn't require a password, though that depends on which media you are using).

    Then:
    Code:
    fsck /dev/sda2
    mount /dev/sda2 /mnt
    grep swap /mnt/etc/fstab
    blkid /dev/sda1
    and post the output.

    I'm mainly looking for the output from the last two commands. You can skip the output from the others if that makes it easier.

    I can make a guess as to what happened. Possibly you reformatted the swap partition. That could happen in several ways, but the most likely would be that you tried installing some other distro in a spare partition, and that install reformatted the swap partition. And that would change the UUID of that swap partition.

    While you are logged into the rescue boot, here's something that you could try. You could attempt to edit "/mnt/etc/fstab". I would normally use "vi" for that, but if you are not familiar with "vi", then see if "nano" is available in that rescue setup. It should be very easy to use "nano".

    While editing, find the line for swap. And insert the "#" character at the beginning. That comments out the line. And then see if maybe your system will boot without swap. If you can boot that way, it will be easier to fix things from a more familiar environment.

    To exit the rescue session, use either
    Code:
    shutdown -r now
    to reboot, or
    Code:
    shutdown -h now
    to halt the system.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  5. #5

    Default Re: Tumbleweed Boot Error (Dependency Failed for Swap)

    I run the commands you described, however “grew swap /etc/fstab” returns no output

    https://i.imgur.com/RvVsXhu.jpg

    blkid output
    https://i.imgur.com/Cl5Dob2.jpg

    blkid /dev/sda1
    https://i.imgur.com/KFYGBVV.jpg

    fsck /dev/sda2

    https://i.imgur.com/ks0ax9I.jpg

    grep swap /mnt/etc/fstab

    https://i.imgur.com/gefo8mZ.jpg


    Also, "/mnt/etc/fstab" returns permission denied

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,672
    Blog Entries
    3

    Default Re: Tumbleweed Boot Error (Dependency Failed for Swap)

    Quote Originally Posted by redmoon View Post
    I run the commands you described,
    Your output does not show any obvious problems. The UUID of swap seems to match what you are using.

    Try this:

    During boot, hit the 'e' key. (I think you have experience with that).
    On the grub2 edit screen, scroll down to the line that begins with "linux" (following some spaces).
    Scroll over to the "splash=silent". And use your delete key or backspace key, as needed, to delete "splash=silent". Maybe also delete "quiet". Then continue booting with CTRL-x.

    You should see a noisy boot screen. Then see if there are other messages with more details of what is going wrong. Or take a picture of the lines leading up to the failure.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  7. #7

    Default Re: Tumbleweed Boot Error (Dependency Failed for Swap)

    Quote Originally Posted by nrickert View Post
    Your output does not show any obvious problems. The UUID of swap seems to match what you are using.

    Try this:

    During boot, hit the 'e' key. (I think you have experience with that).
    On the grub2 edit screen, scroll down to the line that begins with "linux" (following some spaces).
    Scroll over to the "splash=silent". And use your delete key or backspace key, as needed, to delete "splash=silent". Maybe also delete "quiet". Then continue booting with CTRL-x.

    You should see a noisy boot screen. Then see if there are other messages with more details of what is going wrong. Or take a picture of the lines leading up to the failure.



    After editing the grub2 from boot menu, A blurry (Noisy)boot screen appears:

    https://i.imgur.com/2lboqg8.jpg


    then the system stuck here


    https://i.imgur.com/qGdmn01.jpg


    https://i.imgur.com/a9WISD4.jpg

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,672
    Blog Entries
    3

    Default Re: Tumbleweed Boot Error (Dependency Failed for Swap)

    I suggest that you file a bug report. You can use this link:
    openSUSE:Submitting bug reports

    In your report, I suggest you provide a link to this forum thread.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •