Quote Originally Posted by tannington View Post
You are not alone... I've just tried to use gparted and see exactly the same behaviour fails to start, and from the command line:

"(gpartedbin:9789): Gtk-WARNING **: cannot open display: "

I last used gparted around 6 months ago, there's been a lot of snapshots since then so I've no idea when this "problem" was first introduced. (Currently on 20171212).

Changing the gtk theme per @GooeyGirls's post https://forums.opensuse.org/showthre...97#post2847597 makes no difference. Had been using "Default", tried Breeze and Adwata, with a reboot on each occasion for good measure.

Googling for the "Gtk-WARNING **: cannot open display: " returns several hits, all of which seem to indicate this is caused by the Xserver not running and/or running under Wayland.

I'm not using Wayland and X is running...

Affects both existing users _and_ a new test user, so it looks like a system level rather than user problem.


@FlameBait

Any idea which snapshot may have introduced this? Perhaps a clue there... Or have you made any progress with it?
Hi
Did you create a test user and try it there as well to eliminate user settings vs system settings.

If you open a terminal and switch to root user with su - (not su or sudo), does it work then?