Results 1 to 2 of 2

Thread: VLC Player Doesn't Support Some Codecs (I Guess)

  1. #1

    Default VLC Player Doesn't Support Some Codecs (I Guess)

    When I first installed it it said "VLC is not supposed to be run as root. Sorry. If you need to use real-time priorities and/or privileged TCP ports you can use vlc-wrapper (make sure it is Set-UID root and cannot be run by non-trusted users first)."

    Then I wrote
    Code:
    sed -i 's/geteuid/getppid/' /usr/bin/vlc
    to terminal and it launched. But now I got these errors.

    Code:
     Codec not supported:
     VLC could not decode the format "h264" (H264 - MPEG-4 AVC (part 10))
     Codec not supported:
     VLC could not decode the format "mp4a" (MPEG AAC Audio)
     
    
    I don't know what to do how can I solve it?

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: VLC Player Doesn't Support Some Codecs (I Guess)

    to get patented codecs working you need to add and do a full vendor change with the packman repo
    Code:
    zypper ar -f ftp://packman.inode.at/suse/openSUSE_Tumbleweed/ packman
    zypper dup --from packman
    zypper in vlc-codecs libxine2-codecs
    vlc-codecs and libxine2-codecs do not exists in obs and a vendor change will not pull them so you need to install them manually

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •