More or less fresh install of openSUSE 42.3 but unused for about 3 to 4 months.
When I boot up, package kit would start running automatically and stay for hours on "Checking updates".

Killed package kit using:
Code:
sudo killall packagekitd
Then tried using Yast online update. It gets stuck on "Loading Package Manager".

Tried
Code:
zypper update
Absolutely no output.

Checked repository URL's and enabled/autorefresh only the basic four repositories. Retried Yast and zypper. Same results.

Changed network management from "wicked" to NetworkManager as suggested in another thread. No effect.

Now if I try to enter Yast - Software repositories (this is after logging out and logging in again after Yast gets stuck), I get:
"System management is locked by the application with pid 20039 (/usr/bin/ruby). Close this application before trying again.
The only ruby I've heard of (other than the gemstone and the one who took her lips to town) is a programming language and I've never ever used it.

Before, installing openSUSE 42.3, I had briefly installed 42.2 (or perhaps 42.1) I cant remember and had similar problems with updates - which was solved by adding an omitted file separator in the URL for the nvidia repo (unbelievable but true and I had not even entered the URL manually).

There are times perhaps when the repos are not available but this has now happened multiple times over several days.

I successfully (and continuously) used openSUSE 13.1 for over two years - only having to use my Windows 7 system once in the middle after a power failure messed up an update. But after 9/10 months of trying on and off, I have yet to open my account with Leap - there is always some problem or the other and the GUI is laggy and "just doesn't feel right".

I'd be grateful if anyone can help.