Results 1 to 6 of 6

Thread: Blank screen with NVIDIA driver

  1. #1
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Blank screen with NVIDIA driver

    I finally broke down and installed 42.3. Install went fine. Runs fine with nouveau. Installed NVIDIA G04 the easy way and get blank screen. Also tried GO3. Have not tried the hard way. Card 630 based and runs fine with G04 in 42.2 which is still installed in parallel. Can't move to 42.3 until I can get the driver to work. Any ideas I've missed?

  2. #2
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    2,238

    Default Re: Blank screen with NVIDIA driver

    Just a wild guess, pointing to a difference in 42.3: drm-kmp-default needs to be uninstalled before proprietary driver installation. Quoting from the release notes:
    1.5 Changes for Users Installing the Nvidia Driver Manually Report Bug #




    On openSUSE Leap 42.3, you need to uninstall the package drm-kmp-default first, before you can manually install Nvidia drivers using the .run shell script archive:
    zypper rm drm-kmp-default
    If you install the RPMs provided by Nvidia, you will not be affected by this issue, because in that case the package drm-kmp-default is replaced during the driver installation automatically.
    If you decide to uninstall Nvidia's driver later, make sure to reinstall the package drm-kmp-default.
    For more information, see https://bugzilla.suse.com/show_bug.cgi?id=1044816.


    Edit: I see you installed "the easy way", so you should not be affected by this, sorry for reading too fast.
    Tumbleweed Gnome on i7 4720HQ + Geforce GTX960M
    testing Leap 15.3

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: Blank screen with NVIDIA driver

    Ok that works seems like it may be needed with 42.3 thought it was a TW problem

    How I did it

    1) made sure DRM-KMP package removed (it was probably while I was hacking at things)

    2) ran mkinitrd ( did not do that before may be a needed step)

    3) installed NVIDIA driver packages rebooted and things worked

    Now I can start configuring for the move

    Note I keep 2 root partitions and rotate them with versions so always a fresh install with the oldest as backup if needed. I don't mount my home until I am sure the new is stable.

  4. #4
    Join Date
    Apr 2018
    Location
    New England
    Posts
    32

    Default Re: Blank screen with NVIDIA driver

    Please excuse me because I'm a newbie at this. I've recently installed openSuSE Leap 42.3 on a Lenovo P70.

    The P70 has the NVIDIA Quadro M4000M 4GB graphics card on it. i7-6820HQ processor, 17.3 inch screen with 3840x2160 resolution. Non-Touch

    Upon first boot, the GNOME desktop came up without a problem. I could navigate with ease.
    When I tried to change the screen resolution because the text was too small, the screen went blank. I could not get the GNOME desktop back. I was forced to hard reset and reboot. Subsequent reboots show the boot progress graphically at the bottom of the screen, but when the GNOME desktop would typically start, I get the blank or black screen.

    This thread has been helpful to a point. I was able to to the <Ctrl>+ALT+F1 to get a command prompt. Text is like 5 pitch. Very difficult to read.

    This thread has descriptions on how to download and install a new NVIDIA driver. But I take it one has to be familiar with the zypper commands?

    I've tried, from this post to assemble a list of commands. Here is what I came up with.

  5. #5
    Join Date
    Apr 2018
    Location
    New England
    Posts
    32

    Default Re: Blank screen with NVIDIA driver

    apologies... here are is my command sequence...

    zypper rm drm-kmp-default

    should there be a reboot here?

    mkinitrd

    zypper ar-f http://download.nvidia.com/opensuse/leap/42.3/ nVidia_Drivers
    zypper ref

    zypper in x11-video-nvidiaG04 nvidia-glG04 nvidia-gfxG04-kmp-default

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: Blank screen with NVIDIA driver

    Note that if this is a notebook with hybrid graphics (Intel+Nvidia) known as Optimus you must use bumblebee unless you have a way of turning off the Intel GPU in the BIOS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •