Results 1 to 5 of 5

Thread: Unable to update via zypper since yesterday

  1. #1

    Default Unable to update via zypper since yesterday

    Hello,

    afters yesterdays update via "zypper up", I can't update anymore opensuse LEAP 42.3.

    I am getting the following error:
    zypper: symbol lookup error: /usr/lib64/libproxy.so.1: undefined symbol: _ZN9libmodman14module_manager8load_dirENSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEb

    Of course I searched the web first, but the solutions provided does not work.
    The main solution was to download:
    rpm -Uvh --oldpackage http://download.opensuse.org/tumblew...7.7.x86_64.rpm
    https://forums.opensuse.org/showthre...defined-symbol

    But I might misunderstood something - usually I am just using Terminal to update via zypper.

    Code:
    zypper lr -d
    Repository priorities are without effect. All enabled repositories share the same priority.
    
    #  | Alias                               | Name                                                    | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                       | Service
    ---+-------------------------------------+---------------------------------------------------------+---------+-----------+---------+----------+--------+---------------------------------------------------------------------------+--------
     1 | download.opensuse.org-non-oss       | Haupt-Repository (NON-OSS)                              | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/         |        
     2 | download.opensuse.org-non-oss_1     | Aktualisierungs-Repository (Nicht-Open-Source-Software) | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.3/non-oss/                    |        
     3 | download.opensuse.org-oss           | Haupt-Repository (OSS)                                  | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/oss/             |        
     4 | download.opensuse.org-oss_1         | Hauptaktualisierungs-Repository                         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.3/oss                         |        
     5 | download.videolan.org               | download.videolan.org                                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.videolan.org/pub/videolan/vlc/SuSE/Leap_42.3              |        
     6 | http-download.opensuse.org-5b1d95e6 | home:psmt                                               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/psmt/openSUSE_Tumbleweed/ |        
     7 | http-download.opensuse.org-ea10d5ef | openSUSE:Tumbleweed                                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/  |        
     8 | openSUSE-Leap-42.3-0                | openSUSE-Leap-42.3-0                                    | No      | ----      | ----    |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-VBOX_CD-ROM_VB2-01700376               |        
     9 | repo-debug                          | openSUSE-Leap-42.3-Debug                                | No      | ----      | ----    |   99     | yast2  | http://download.opensuse.org/debug/distribution/leap/42.3/repo/oss/       |        
    10 | repo-debug-non-oss                  | openSUSE-Leap-42.3-Debug-Non-Oss                        | No      | ----      | ----    |   99     | yast2  | http://download.opensuse.org/debug/distribution/leap/42.3/repo/non-oss/   |        
    11 | repo-debug-update                   | openSUSE-Leap-42.3-Update-Debug                         | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/update/leap/42.3/oss/                  |        
    12 | repo-debug-update-non-oss           | openSUSE-Leap-42.3-Update-Debug-Non-Oss                 | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/update/leap/42.3/non-oss/              |        
    13 | repo-source                         | openSUSE-Leap-42.3-Source                               | No      | ----      | ----    |   99     | yast2  | http://download.opensuse.org/source/distribution/leap/42.3/repo/oss/      |        
    14 | repo-source-non-oss                 | openSUSE-Leap-42.3-Source-Non-Oss                       | No      | ----      | ----    |   99     | yast2  | http://download.opensuse.org/source/distribution/leap/42.3/repo/non-oss/  |
    The system was upgrade some time ago from 42.2 to 42.3.

    Can you help me resolve the issue?
    I am unable to start Firefox, etc. due to this error.

    Many thanks for your help.

    Best regards


    Carlos

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,793
    Blog Entries
    14

    Default Re: Unable to update via zypper since yesterday

    The first thing I notice is that you are installing a Tumbleweed package on Leap, the second that you have a Tumbleweed repo active. Which IMNSHO is asking for trouble. Do not mix repos for different versions. it will definitely break things, if not now, than later.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Unable to update via zypper since yesterday

    OK. Is there a solution to fix this or do I need to new install?

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,793
    Blog Entries
    14

    Default Re: Unable to update via zypper since yesterday

    Quote Originally Posted by behlaucarlos View Post
    OK. Is there a solution to fix this or do I need to new install?
    Replace the TW repo by it's 42.3 equivalent and run
    Code:
    zypper dup --no-allow-vendor-change
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,213

    Default Re: Unable to update via zypper since yesterday

    Quote Originally Posted by Knurpht View Post
    Replace the TW repo by it's 42.3 equivalent and run ...
    In this case that may not work, as from the OP's first post it looks as if zypper itself is broken.


    @behlaucarlos

    If "zypper dup --no-allow-vendor-change" still fails, what versions of "libmodman1", "libproxy1", and "zypper" have you currently installed?

    Code:
    rpm -qi libmodman1 libproxy1 zypper
    Regards, Paul

    Tumbleweed (Snapshot: 20190916) KDE Plasma 5
    Non-Tumbling Tumblweed (20150508) KDE 4 - Resurrected
    2x Leap 15.1 KDE Plasma 5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •