Results 1 to 10 of 10

Thread: Copying files doesn't work in Dolphin

  1. #1

    Default Copying files doesn't work in Dolphin

    This is really strange! I can't copy certain .ogg files to external usb. It looks like some drm-protection.
    Files created with audacity can be moved, but with Audio Recorder - no.
    This is a "Gnome" audio recorder by the way.
    On the other hand, I can copy big files and small files of other types.
    Something is wrong with .ogg.
    But it's happenning in KDE - Dolphin.
    What would you say?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    22,040

    Default Re: Copying files doesn't work in Dolphin

    While I understand you have a problem, your description is not very useful. "I can't copy" can mean a lot of things (amongst others that you can not type because of frozen fingers, very unlikely, but it fits your description).

    So please what do you exactly do (Ia guess from your further description using Dolphin some "click and drag", but guessing is not something to base advices on) and what happens that gives you the impression that the file is not copied?
    Henk van Velden

  3. #3
    Join Date
    Nov 2016
    Location
    Johannesburg, South Africa
    Posts
    38

    Default Re: Copying files doesn't work in Dolphin

    Quote Originally Posted by hcvv View Post
    While I understand you have a problem, your description is not very useful. "I can't copy" can mean a lot of things (amongst others that you can not type because of frozen fingers, very unlikely, but it fits your description).

    So please what do you exactly do (Ia guess from your further description using Dolphin some "click and drag", but guessing is not something to base advices on) and what happens that gives you the impression that the file is not copied?
    Can you please try again from command line with root access (sudo or su). Then post output here please in case it doesn't work. AFAIK Dolphin in Leap doesn't offer root access by default and sometimes certain files require elevated privileges. Not always clear why.

  4. #4
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,320

    Default Re: Copying files doesn't work in Dolphin

    Have a look at the properties of the files you cannot copy; some programs automatically set new files to be read only by the owner. In this case, a USB (unless it uses FAT or NTFS) will belong to another user and so you cannot copy those files from one user to another.

  5. #5

    Default Re: Copying files doesn't work in Dolphin

    Okay sorrys to be more exact: Dolphin says it "Could not write to" mounted flash drive. Same with super-privileges.
    Owner of usb flash is user (standard). So everything can be written except *.ogg files.
    After making 2 attempts, with Superconsole too, a second messsage:
    Code:
    org.kde.baloo: "/org/freedesktop/UDisks2/block_devices/sdb"
    QObject::connect: invalid null parameter
    "/org/freedesktop/UDisks2/block_devices/sdb1" has new interfaces: ("org.freedesktop.UDisks2.Block", "org.freedesktop.UDisks2.Filesystem", "org.freedesktop.UDisks2.Partition")
    org.kde.baloo: "/org/freedesktop/UDisks2/block_devices/sdb1"
    org.kde.baloo: "/org/freedesktop/UDisks2/block_devices/sdb1"
    QLayout: Attempting to add QLayout "" to PhononWidget "", which already has a layout
    org.kde.baloo: true "/org/freedesktop/UDisks2/block_devices/sdb1"
    
    But first message was suspicious too:
    Code:
    ark.main: "audio/x-vorbis+ogg" is not a supported mimetype
    
    I don't know why "baloo" blocks device.
    "I can't copy" can mean a lot of things (amongst others that you can not type because of frozen fingers, very unlikely, but it fits your description).
    Oh no, I can't copy but because of frozen head need to wait and warm drinks.

    What would you say?

  6. #6
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,640

    Default Re: Copying files doesn't work in Dolphin

    A few things come to mind:

    1) If you zip the ogg file then you can copy the zipped file? You probably can zip it by right-clicking the ogg file in dolphin and choosing compress from the context list. After copying it to external USB can you copy and unzip it OK? If so, comparing the original and copy, are there any permissions difference?

    2) Did you try with another USB device? Your USB Flash/Disk/Whatever may be defective, or have defective sectors where it's trying to write (improbable, but...)

    3) Try another USB port/cable? Even if it works for other files, it's worth a (long) shot.

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    22,040

    Default Re: Copying files doesn't work in Dolphin

    My suggestions as that it is time to remove all the fog a GUI creates.

    Thus try from the command line with
    Code:
    cp /path/to/file.ogg /path/to/usbdevice/file.ogg
    (the real pathes to be filled in by the OP of course)
    and to see what the meta information of the original file is:
    Code:
    ls -l /path/to/file.ogg
    Henk van Velden

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    16,713
    Blog Entries
    13

    Default Re: Copying files doesn't work in Dolphin

    You're misinterpreting the messages. Baloo is a file indexer, has nothing to do with copying files. And /dev/sdb1 is a block_device. The term block has nothing to do with blocking things. The mime-type message neither.
    But, if the filesystem is FAT or NTFS, have a look at the filenames. Do they contain "weird" characters?

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    22,040

    Default Re: Copying files doesn't work in Dolphin

    Quote Originally Posted by Knurpht View Post
    Do they contain "weird" characters?
    That is why I ask for the ls -l.
    Henk van Velden

  10. #10

    Default Re: Copying files doesn't work in Dolphin

    Hi,
    Now I see how weird my posts sounded, after trying commands&other things. For some reason, Recorder began naming files like '14:15:23.ogg' by default instead of usual '14_15_23.ogg'. Didn't even notice that. This is wrong characters indeed - Windows would never let me create such files.
    Easy part is left - renaming about 30 files.
    Gracias !

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •