Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Zypper dup: Problem libopenssl

  1. #1

    Default Zypper dup: Problem libopenssl

    Hy!

    Have here

    Code:
    zypper lr -P
    # | Alias                               | Name                        | Enabled | GPG Check | Refresh | Priority
    --+-------------------------------------+-----------------------------+---------+-----------+---------+---------
    9 | repo-update                         | openSUSE-Tumbleweed-Update  | Yes     | (r ) Yes  | Yes     |   55    
    3 | libdvdcss                           | libdvdcss                   | Yes     | (r ) Yes  | Yes     |   62    
    1 | http-download.opensuse.org-b14cd22f | KDE:Frameworks5             | Yes     | (r ) Yes  | Yes     |   99    
    2 | http-download.opensuse.org-f3d031d1 | KDE:Extra                   | Yes     | (r ) Yes  | Yes     |   99    
    4 | openSUSE-20161219-0                 | openSUSE-20161219-0         | Yes     | (r ) Yes  | Yes     |   99    
    5 | packman                             | packman                     | Yes     | (r ) Yes  | Yes     |   99    
    6 | repo-debug                          | openSUSE-Tumbleweed-Debug   | No      | ----      | ----    |   99    
    7 | repo-non-oss                        | openSUSE-Tumbleweed-Non-Oss | Yes     | (r ) Yes  | Yes     |   99    
    8 | repo-source                         | openSUSE-Tumbleweed-Source  | No      | ----      | ----    |   99
    on a TW 64bit with KDE and with

    Code:
    zypper dup
    I get

    Code:
    zypper dup                                                                      
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.                           
    Retrieving repository 'KDE:Frameworks5' metadata ...................................................................................[done]
    Building repository 'KDE:Frameworks5' cache ........................................................................................[done]
    Retrieving repository 'KDE:Extra' metadata .........................................................................................[done]
    Building repository 'KDE:Extra' cache ..............................................................................................[done]
    Retrieving repository 'packman' metadata ...........................................................................................[done]
    Building repository 'packman' cache ................................................................................................[done]
    Loading repository data...                                                                    
    Reading installed packages...                                                                 
    Computing distribution upgrade...                                                             
                                                                                                  
    Problem: libopenssl-1_0_0-devel-1.0.2m-1.1.x86_64 conflicts with libopenssl-devel > 1.0.2m provided by libopenssl-devel-1.1.0g-1.1.noarch
     Solution 1: deinstallation of libopenssl-1_0_0-devel-1.0.2m-1.1.x86_64                       
     Solution 2: deinstallation of libopenssl-devel-1.0.2m-1.1.noarch
     Solution 3: keep obsolete libopenssl-devel-1.0.2m-1.1.noarch
    
    Choose from above solutions by number or cancel [1/2/3/c] (c):
    What to make out of this? Never seen before...
    Kind regards

    raspu

  2. #2

    Default Re: Zypper dup: Problem libopenssl

    Bad/missing obsoletes field in rpm spec and/or unfinished rebuilds of rpms depending on those two packages. Safe option is to wait until packages are fixed and dependencies are in a consistent state. If you are feeling reckless, you can always rpm -e --nodeps the two offending packages and do a dup afterwards. Done this on my computers and have not noticed any bad side effects. This is no recommendation, though. If anything breaks, do not blame me.

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,728

    Default Re: Zypper dup: Problem libopenssl

    BTW, you show zypper lr -P instead of what is always asked here:
    Code:
    zypper lr -d
    Now there are no URLs in the list and that is what is the most important. All other identifications like Name and Alias can be whatever you like and thus different on every system. The URLs show where the repos are.
    Henk van Velden

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,728

    Default Re: Zypper dup: Problem libopenssl

    Henk van Velden

  5. #5

    Default Re: Zypper dup: Problem libopenssl

    Ey, ey, Sir:

    Code:
    zypper lr -d
    Repository priorities in effect:                                                                          (See 'zypper lr -P' for details)
          55 (raised priority)  :  1 repository  
          62 (raised priority)  :  1 repository  
          99 (default priority) :  5 repositories
    
    # | Alias                               | Name                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                       | Service
    --+-------------------------------------+-----------------------------+---------+-----------+---------+----------+--------+-------------------------------------------------------------------------------------------+--------
    1 | http-download.opensuse.org-b14cd22f | KDE:Frameworks5             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Factory/              |        
    2 | http-download.opensuse.org-f3d031d1 | KDE:Extra                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/KDE_Frameworks5_openSUSE_Tumbleweed/ |        
    3 | libdvdcss                           | libdvdcss                   | Yes     | (r ) Yes  | Yes     |   62     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/                                       |        
    4 | openSUSE-20161219-0                 | openSUSE-20161219-0         | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/tumbleweed/repo/oss/                                         |        
    5 | packman                             | packman                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/                       |        
    6 | repo-debug                          | openSUSE-Tumbleweed-Debug   | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/tumbleweed/repo/oss/                                   |        
    7 | repo-non-oss                        | openSUSE-Tumbleweed-Non-Oss | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/tumbleweed/repo/non-oss/                                     |        
    8 | repo-source                         | openSUSE-Tumbleweed-Source  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/tumbleweed/repo/oss/                                  |        
    9 | repo-update                         | openSUSE-Tumbleweed-Update  | Yes     | (r ) Yes  | Yes     |   55     | rpm-md | http://download.opensuse.org/update/tumbleweed/
    Kind regards

    raspu

  6. #6

    Default Re: Zypper dup: Problem libopenssl

    Quote Originally Posted by hcvv View Post
    maybe, but the thread titel is... not that elucidating... :-D

    And the "solution" appears somewhat... for the brave?
    Kind regards

    raspu

  7. #7
    Join Date
    Aug 2008
    Location
    Belgium
    Posts
    275

    Default Re: Zypper dup: Problem libopenssl

    Hello,

    i had the same problem and chose to remove the libopenssl-1_0_0-devel-1.0.2m-1.1.x86_64 :
    Thereafter zypper found more problems related to qt4 development package. I chose to answer every time to remove the development packages (qt4 devel and ssl1.0.0 devel) and ended with 18 packages that should be removed (all devel). Thereafter the Zypper dup ran without problem an no problems after reboot

    Regards
    Philippe
    Tumbleweed (x86_64) Kernel 5.14 with KDE plasma

  8. #8
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,721

    Default AW: Zypper dup: Problem libopenssl


  9. #9
    Join Date
    Apr 2017
    Location
    Piemont
    Posts
    274

    Default Re: Zypper dup: Problem libopenssl

    I have solved with> solution n1
    loyalty returns to those who practice it

  10. #10

    Default Re: Zypper dup: Problem libopenssl

    To be true I have no idea which application required this devel-thing and therefore I have no idea what might break. I will wait some days and how things develop...
    Kind regards

    raspu

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •