I prefer to use the more stable Leap instead of Tumbleweed. However I would also like to use the newest stable linux kernel, but cannot since Leap NVIDIA driver is pre-built for the Leap version of the Linux kernel.

Thankfully NVIDIA drivers are now finally available for Tumbleweed:
http://http.download.nvidia.com/opensuse/tumbleweed
These are pre-built for kernel 4.14.0-1

Would this driver work on Leap when using kernel 4.14.3 from Kernel Stable repository?
http://download.opensuse.org/repositories/Kernel:/stable/standard/