Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: SIM-card not recognized

  1. #1

    Default SIM-card not recognized

    When I insert a SIM-card on my Lenovo Thinkpad x1 carbon, it doesn't recognized the SIM-card. The SIM-card does work on my phone.
    Do I need to enable/install something or does the OS not support SIM-card?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    16,817
    Blog Entries
    1

    Default Re: SIM-card not recognized

    Quote Originally Posted by kFelix View Post
    When I insert a SIM-card on my Lenovo Thinkpad x1 carbon, it doesn't recognized the SIM-card. The SIM-card does work on my phone.
    Do I need to enable/install something or does the OS not support SIM-card?
    It's the broadband modem device itself that needs to be considered here. To start with let's see how it is reported...

    Code:
    lsusb
    Code:
    usb-devices
    It's likely that using a more recent kernel will be required in order for the kernel to support it, and there may still be other issues to getting it handled properly. If you want to try this, follow the instructions I provided in this post. When you reboot, you'll be able to choose the desired kernel from the advanced options in the grub menu.

    FWIW, an Ubuntu thread discussing similar...
    https://forums.lenovo.com/t5/Linux-D...4/td-p/3720487
    Last edited by deano_ferrari; 02-Dec-2017 at 00:19.

  3. #3

    Default Re: SIM-card not recognized

    Quote Originally Posted by deano_ferrari View Post
    It's the broadband modem device itself that needs to be considered here. To start with let's see how it is reported...

    Code:
    lsusb
    Code:
    usb-devices
    It's likely that using a more recent kernel will be required in order for the kernel to support it, and there may still be other issues to getting it handled properly. If you want to try this, follow the instructions I provided in this post. When you reboot, you'll be able to choose the desired kernel from the advanced options in the grub menu.

    FWIW, an Ubuntu thread discussing similar...
    https://forums.lenovo.com/t5/Linux-D...4/td-p/3720487
    Hi, sorry for the late answer but i already had that rep, don't think that kernel is the problem. Not sure but, I am not using any usb devices for the SIM-card is more like a port. Anyway, this is what i get from lsusb and usb-devices:
    Code:
    Bus 001 Device 002: ID 8087:8001 Intel Corp. 
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 002 Device 004: ID 04f2:b45d Chicony Electronics Co., Ltd 
    Bus 002 Device 003: ID 8087:0a2a Intel Corp. 
    Bus 002 Device 002: ID 138a:0017 Validity Sensors, Inc. Fingerprint Reader
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Code:
    T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh= 3
    D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
    P:  Vendor=1d6b ProdID=0002 Rev=04.14
    S:  Manufacturer=Linux 4.14.2-1-default ehci_hcd
    S:  Product=EHCI Host Controller
    S:  SerialNumber=0000:00:1d.0
    C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
    I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
    
    T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=480 MxCh= 8
    D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
    P:  Vendor=8087 ProdID=8001 Rev=00.03
    C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
    I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
    
    T:  Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh=11
    D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
    P:  Vendor=1d6b ProdID=0002 Rev=04.14
    S:  Manufacturer=Linux 4.14.2-1-default xhci-hcd
    S:  Product=xHCI Host Controller
    S:  SerialNumber=0000:00:14.0
    C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA                                                                                                                                                                                                                                          
    I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub                                                                                                                                                                                                             
                                                                                                                                                                                                                                                                                  
    T:  Bus=02 Lev=01 Prnt=01 Port=05 Cnt=01 Dev#=  2 Spd=12  MxCh= 0                                                                                                                                                                                                             
    D:  Ver= 1.10 Cls=ff(vend.) Sub=11 Prot=ff MxPS= 8 #Cfgs=  1                                                                                                                                                                                                                  
    P:  Vendor=138a ProdID=0017 Rev=00.78                                                                                                                                                                                                                                         
    S:  SerialNumber=d6fdfbaa07be                                                                                                                                                                                                                                                 
    C:  #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=100mA                                                                                                                                                                                                                                        
    I:  If#= 0 Alt= 0 #EPs= 4 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)                                                                                                                                                                                                          
                                                                                                                                                                                                                                                                                  
    T:  Bus=02 Lev=01 Prnt=01 Port=06 Cnt=02 Dev#=  3 Spd=12  MxCh= 0                                                                                                                                                                                                             
    D:  Ver= 2.01 Cls=e0(wlcon) Sub=01 Prot=01 MxPS=64 #Cfgs=  1                                                                                                                                                                                                                  
    P:  Vendor=8087 ProdID=0a2a Rev=00.01                                                                                                                                                                                                                                         
    C:  #Ifs= 2 Cfg#= 1 Atr=e0 MxPwr=100mA                                                                                                                                                                                                                                        
    I:  If#= 0 Alt= 0 #EPs= 3 Cls=e0(wlcon) Sub=01 Prot=01 Driver=btusb                                                                                                                                                                                                           
    I:  If#= 1 Alt= 0 #EPs= 2 Cls=e0(wlcon) Sub=01 Prot=01 Driver=btusb                                                                                                                                                                                                           
                                                                                                                                                                                                                                                                                  
    T:  Bus=02 Lev=01 Prnt=01 Port=07 Cnt=03 Dev#=  4 Spd=480 MxCh= 0                                                                                                                                                                                                             
    D:  Ver= 2.00 Cls=ef(misc ) Sub=02 Prot=01 MxPS=64 #Cfgs=  1                                                                                                                                                                                                                  
    P:  Vendor=04f2 ProdID=b45d Rev=00.29                                                                                                                                                                                                                                         
    S:  Manufacturer=Chicony Electronics Co.,Ltd.                                                                                                                                                                                                                                 
    S:  Product=Integrated Camera                                                                                                                                                                                                                                                 
    S:  SerialNumber=0x0001                                                                                                                                                                                                                                                       
    C:  #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=500mA                                                                                                                                                                                                                                        
    I:  If#= 0 Alt= 0 #EPs= 1 Cls=0e(video) Sub=01 Prot=00 Driver=uvcvideo                                                                                                                                                                                                        
    I:  If#= 1 Alt= 0 #EPs= 0 Cls=0e(video) Sub=02 Prot=00 Driver=uvcvideo                                                                                                                                                                                                        
                                                                                                                                                                                                                                                                                  
    T:  Bus=03 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=5000 MxCh= 4                                                                                                                                                                                                            
    D:  Ver= 3.00 Cls=09(hub  ) Sub=00 Prot=03 MxPS= 9 #Cfgs=  1                                                                                                                                                                                                                  
    P:  Vendor=1d6b ProdID=0003 Rev=04.14                                                                                                                                                                                                                                         
    S:  Manufacturer=Linux 4.14.2-1-default xhci-hcd                                                                                                                                                                                                                              
    S:  Product=xHCI Host Controller                                                                                                                                                                                                                                              
    S:  SerialNumber=0000:00:14.0                                                                                                                                                                                                                                                 
    C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA                                                                                                                                                                                                                                          
    I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
    Here is what i get from NetworkManager --debug
    Code:
    <info>  [1512633710.1181] NetworkManager (version 1.8.4) is starting... (after a restart)
    <info>  [1512633710.1182] Read config: /etc/NetworkManager/NetworkManager.conf
    <info>  [1512633710.1229] manager[0x5640d12a5130]: monitoring kernel firmware directory '/lib/firmware'.
    <info>  [1512633710.1235] policy: hostname management mode: default
    <info>  [1512633710.1237] dns-mgr[0x5640d12b0160]: init: dns=default, rc-manager=netconfig
    <info>  [1512633710.1245] rfkill1: found WiFi radio killswitch (at /sys/devices/pci0000:00/0000:00:1c.1/0000:04:00.0/ieee80211/phy0/rfkill1) (driver iwlwifi)
    <info>  [1512633710.1247] manager[0x5640d12a5130]: rfkill: WiFi hardware radio set enabled
    <info>  [1512633710.1247] manager[0x5640d12a5130]: rfkill: WWAN hardware radio set enabled
    <error> [1512633710.1255] bus-manager: could not acquire the NetworkManager service as it is already taken
    <error> [1512633710.1255] failed to start the dbus service.
    <info>  [1512633710.1263] exiting (error)
    I have tried rfkill unblock all just to see if it was blocked. Nothing changed.
    Well I could be wrong since I am here asking for help hehe.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    16,817
    Blog Entries
    1

    Default Re: SIM-card not recognized

    Quote Originally Posted by kFelix View Post
    Hi, sorry for the late answer but i already had that rep, don't think that kernel is the problem. Not sure but, I am not using any usb devices for the SIM-card is more like a port. Anyway, this is what i get from lsusb and usb-devices:
    Code:
    Bus 001 Device 002: ID 8087:8001 Intel Corp. 
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 002 Device 004: ID 04f2:b45d Chicony Electronics Co., Ltd 
    Bus 002 Device 003: ID 8087:0a2a Intel Corp. 
    Bus 002 Device 002: ID 138a:0017 Validity Sensors, Inc. Fingerprint Reader
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Ok, but often these internal mobile broadband devices are attached to the USB subsystem. However I agree that doesn't appear to be the case here.

    This might be it...
    Code:
    T:  Bus=02 Lev=01 Prnt=01 Port=05 Cnt=01 Dev#=  2 Spd=12  MxCh= 0                                                                                                                                                                                                             
    D:  Ver= 1.10 Cls=ff(vend.) Sub=11 Prot=ff MxPS= 8 #Cfgs=  1                                                                                                                                                                                                                  
    P:  Vendor=138a ProdID=0017 Rev=00.78                                                                                                                                                                                                                                         
    S:  SerialNumber=d6fdfbaa07be                                                                                                                                                                                                                                                 
    C:  #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=100mA                                                                                                                                                                                                                                        
    I:  If#= 0 Alt= 0 #EPs= 4 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)
    No driver loaded though...

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    16,817
    Blog Entries
    1

    Default Re: SIM-card not recognized

    Others have reported similar issues with getting this hardware working...

    https://askubuntu.com/questions/7479...roadband-modem

    Looks like work in progress.

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    16,817
    Blog Entries
    1

    Default Re: SIM-card not recognized

    Quote Originally Posted by deano_ferrari View Post
    Ok, but often these internal mobile broadband devices are attached to the USB subsystem. However I agree that doesn't appear to be the case here.

    This might be it...
    Code:
    T:  Bus=02 Lev=01 Prnt=01 Port=05 Cnt=01 Dev#=  2 Spd=12  MxCh= 0                                                                                                                                                                                                             
    D:  Ver= 1.10 Cls=ff(vend.) Sub=11 Prot=ff MxPS= 8 #Cfgs=  1                                                                                                                                                                                                                  
    P:  Vendor=138a ProdID=0017 Rev=00.78                                                                                                                                                                                                                                         
    S:  SerialNumber=d6fdfbaa07be                                                                                                                                                                                                                                                 
    C:  #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=100mA                                                                                                                                                                                                                                        
    I:  If#= 0 Alt= 0 #EPs= 4 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)
    No driver loaded though...
    Scratch that - it's a Validity Sensors, Inc fingerprint reader.
    Last edited by deano_ferrari; 07-Dec-2017 at 01:29.

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    16,817
    Blog Entries
    1

    Default Re: SIM-card not recognized

    Strange that it doesn't show up in your lsusb output. Disabled in the UEFI BIOS perhaps?

  8. #8

    Default Re: SIM-card not recognized

    Quote Originally Posted by deano_ferrari View Post
    Strange that it doesn't show up in your lsusb output. Disabled in the UEFI BIOS perhaps?
    Just went and checked my BIOS, nothing strange there. All kind of ports about network/wireless was enabled. Only thing that may or may not affect the problem is BIOS version. It's from 2015 Jan. (The month they released the laptop). I am not 100% sure, but it seems like the factory version should support the port.

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    16,707
    Blog Entries
    13

    Default Re: SIM-card not recognized

    ° Appreciate my reply? Click the star and let me kow why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  10. #10

    Default Re: SIM-card not recognized

    Quote Originally Posted by Knurpht View Post
    Hi,
    It didn't work. Had to create the file :
    Code:
    /etc/modprobe.d/avoid-mbib.conf
    But still nothing changed after a reboot. :/
    Checked lsusb and usb-devices both was the same

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •