Results 1 to 6 of 6

Thread: Package Dependency Conflict

  1. #1
    Join Date
    Aug 2010
    Location
    UK
    Posts
    368

    Question Package Dependency Conflict

    Major hairy;

    Code:
    Loading repository data...                                                                                                                                                                                                                                                      
    Reading installed packages...                                                                                                                                                                                                                                                   
    Computing distribution upgrade...                                                                                                                                                                                                                                               
    2 Problems:                                                                                                                                                                                                                                                                     
    Problem: libopenssl-1_0_0-devel-1.0.2m-1.1.x86_64 conflicts with libopenssl-devel > 1.0.2m provided by libopenssl-devel-1.1.0g-1.1.noarch                                                                                                                                       
    Problem: libopenssl-1_0_0-devel-1.0.2m-1.1.x86_64 requires openssl-1_0_0 = 1.0.2m, but this requirement cannot be provided                                                                                                                                                      
                                                                                                                                                                                                                                                                                    
    Problem: libopenssl-1_0_0-devel-1.0.2m-1.1.x86_64 conflicts with libopenssl-devel > 1.0.2m provided by libopenssl-devel-1.1.0g-1.1.noarch                                                                                                                                       
     Solution 1: deinstallation of libopenssl-1_0_0-devel-1.0.2m-1.1.x86_64                                                                                                                                                                                                         
     Solution 2: deinstallation of libopenssl-devel-1.0.2m-1.1.noarch                                                                                                                                                                                                               
     Solution 3: keep obsolete libopenssl-devel-1.0.2m-1.1.noarch                                                                                                                                                                                                                   
                                                                                                                                                                                                                                                                                    
    Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c): 
    Vintage IBM ThinkPad T21 (my first) laptop 1GHz PIII [T22 heatsink] ~ Silicon Heaven [RIP]
    X200 Lenovo ThinkPad (Libreboot) ~ Xubuntu 19.10
    X250 Lenovo Thinkpad ~ openSUSE Tumbleweed KDE
    C2D Micro ATX Tower (2nd Main Board) ~ Linux Mint 19.2 Tina

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,157

    Default Re: Package Dependency Conflict

    Please copy/paste your terminal text as complete as possible. That is in this (and many other cases) including the prompts (before and after) and the command. Now we have only some output, be we have no idea what you are trying to do.
    Henk van Velden

  3. #3
    Join Date
    Aug 2010
    Location
    UK
    Posts
    368

    Default Re: Package Dependency Conflict

    Quote Originally Posted by hcvv View Post
    Please copy/paste your terminal text as complete as possible. That is in this (and many other cases) including the prompts (before and after) and the command. Now we have only some output, be we have no idea what you are trying to do.
    Code:
    sudo zypper dup
    Keeping obsolete package twice proved to be simplest option in order to proceed with update. But unless updated repo then kick in again.
    Vintage IBM ThinkPad T21 (my first) laptop 1GHz PIII [T22 heatsink] ~ Silicon Heaven [RIP]
    X200 Lenovo ThinkPad (Libreboot) ~ Xubuntu 19.10
    X250 Lenovo Thinkpad ~ openSUSE Tumbleweed KDE
    C2D Micro ATX Tower (2nd Main Board) ~ Linux Mint 19.2 Tina

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,296
    Blog Entries
    2

    Default Re: Package Dependency Conflict

    Generally,
    zypper will offer options with the first option more than likely the recommended.

    In your specific case, it's simply a matter that a more recent version of libopenssl-devel is offered, but cannot be installed unless the older version is removed first.

    The libopenssl-devel package is often used to install/build apps that require ssl security and integration.
    If you keep the older package, it will mean either that such apps won't build (fail) or build with the old package which means not including any patches or features introduced in the newer package.

    So,
    Keeping the old version won't likely break your system as a whole but some app you have installed that uses that package either didn't get upgraded(re-built) or maybe never was marked for upgrade which means no effect at all on your system.

    HtH,
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,854
    Blog Entries
    14

    Default Re: Package Dependency Conflict

    I did some searching and found that the 1_0_0 package is newer, so opted for #2 .
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6
    Join Date
    Aug 2010
    Location
    UK
    Posts
    368

    Default Re: Package Dependency Conflict

    Code:
    zypper rm libopenssl-devel
    reinstall package, zypper then offered to replace package, everything else was a rabbit warren.
    Vintage IBM ThinkPad T21 (my first) laptop 1GHz PIII [T22 heatsink] ~ Silicon Heaven [RIP]
    X200 Lenovo ThinkPad (Libreboot) ~ Xubuntu 19.10
    X250 Lenovo Thinkpad ~ openSUSE Tumbleweed KDE
    C2D Micro ATX Tower (2nd Main Board) ~ Linux Mint 19.2 Tina

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •