Results 1 to 9 of 9

Thread: Zypper Update - The following 261 package updates will NOT be installed. Nothing to do.

  1. #1

    Unhappy Zypper Update - The following 261 package updates will NOT be installed. Nothing to do.

    I have OpenSuse 42.2 and wanted to bring everything up to date before attempting a distribution upgrade to 42.3.
    I did a "zypper up", restarted the computer a while later.
    I then did zypper up again and received this:
    -Start----------------------------------------------------------------------
    # zypper up
    Retrieving repository 'Main Update Repository' metadata ...............................................................................................................................[done]
    Building repository 'Main Update Repository' cache ....................................................................................................................................[done]
    Retrieving repository 'openSUSE:Leap:42.2:Update' metadata ............................................................................................................................[done]
    Building repository 'openSUSE:Leap:42.2:Update' cache .................................................................................................................................[done]
    Loading repository data...
    Reading installed packages...

    The following 261 package updates will NOT be installed:
    alsa alsa-oss alsa-oss-32bit alsa-plugins alsa-plugins-jack-32bit alsa-plugins-pulse alsa-plugins-pulse-32bit alsa-utils audacious audacious-lang audacious-plugins audacious-plugins-extra
    audacious-plugins-lang audacity audacity-lang bind-utils cyrus-sasl cyrus-sasl-crammd5 cyrus-sasl-digestmd5 cyrus-sasl-gssapi cyrus-sasl-plain dnsmasq dvd+rw-tools ffmpeg
    gdk-pixbuf-loader-libopenraw gstreamer gstreamer-0_10-fluendo-mp3 gstreamer-lang gstreamer-plugins-bad gstreamer-plugins-bad-lang gstreamer-plugins-base gstreamer-plugins-base-lang
    gstreamer-plugins-good gstreamer-plugins-good-lang gstreamer-plugins-libav gstreamer-plugins-ugly gstreamer-plugins-ugly-lang hexchat hexchat-lang iscsiuio jack krb5 lcms2 libEMF1
    libFLAC++6 libFLAC8 libFLAC8-32bit libSoundTouch0 liba52-0 libao-plugins4 libao4 libasound2 libasound2-32bit libaudcore5 libaudgui5 libaudiofile1 libaudqt2 libaudtag3 libavc1394-0
    libavcodec56 libavcodec57 libavdevice57 libavfilter6 libavformat56 libavformat57 libavresample3 libavutil54 libavutil55 libbluray2 libbs2b0 libburn4 libcaca0 libcdda_interface0
    libcdda_paranoia0 libcddb2 libcdio16 libcdio_cdda2 libcdio_paranoia2 libcelt0-2 libchromaprint1 libclastfm0 libdc1394-22 libdiscid0 libdmapsharing-3_0-2 libdv4 libdvbpsi10 libdvdnav4
    libdvdread4 libebml4 libesd0 libexempi3 libffado2 libfftw3-3 libfluidsynth1 libftgl2 libglyr1 libgme0 libgpod-lang libgpod-tools libgpod4 libgsm1 libgstadaptivedemux-1_0-0
    libgstallocators-1_0-0 libgstapp-1_0-0 libgstaudio-1_0-0 libgstbadaudio-1_0-0 libgstbadbase-1_0-0 libgstbadvideo-1_0-0 libgstbasecamerabinsrc-1_0-0 libgstcodecparsers-1_0-0
    libgstfft-1_0-0 libgstgl-1_0-0 libgstmpegts-1_0-0 libgstpbutils-1_0-0 libgstphotography-1_0-0 libgstreamer-1_0-0 libgstriff-1_0-0 libgstrtp-1_0-0 libgstrtsp-1_0-0 libgstsdp-1_0-0
    libgsttag-1_0-0 libgsturidownloader-1_0-0 libgstvideo-1_0-0 libid3tag0 libiso9660-10 libisoburn1 libisofs6 libjack0 libjack0-32bit libkate1 liblash1 liblcms1 liblcms2-2 liblilv-0-0
    liblrdf2 libmad0 libmatroska6 libmbim libmbim-glib4 libmikmod3 libmjpegutils-2_0-0 libmms0 libmpcdec5 libmpg123-0 libmusicbrainz4 libmusicbrainz5-1 libndp0 libofa0 libogg0 libogg0-32bit
    liboggkate1 libopenraw1 libopus0 libopus0-32bit libpostproc53 libpostproc54 libpulse-mainloop-glib0 libpulse0 libqca2 libqjson0 libqmi-tools libquicktime0 libquvi-0_9-0_9_4
    libquvi-scripts libraw1394-11 libsamplerate0 libsamplerate0-32bit libsasl2-3 libschroedinger-1_0-0 libserd-0-0 libshout3 libsndfile1 libsndfile1-32bit libsord-0-0 libsox3 libsoxr0
    libspeex1 libspeex1-32bit libspeexdsp1 libsratom-0-0 libswresample1 libswresample2 libswscale3 libswscale4 libtag1 libtag_c0 libteamdctl0 libtheora0 libtheoradec1 libtheoraenc1
    libtirpc-netconfig libtirpc3 libtorrent-rasterbar9 libtwolame0 libvamp-hostsdk3 libvcdinfo0 libverto1 libvisual libvlc5 libvlccore8 libvorbis0 libvorbis0-32bit libvorbisenc2
    libvorbisenc2-32bit libvorbisfile3 libvpx4 libwavpack1 libwebrtc_audio_processing1 libwx_baseu-suse-nostl3 libwx_baseu_net-suse-nostl3 libwx_baseu_xml-suse-nostl3
    libwx_gtk2u_adv-suse-nostl3 libwx_gtk2u_core-suse-nostl3 libwx_gtk2u_html-suse-nostl3 libwx_gtk2u_qa-suse-nostl3 libzbar0 libzvbi0 mbimcli-bash-completion mjpegtools mpg123-esound
    mpg123-jack mpg123-openal mpg123-pulse open-iscsi openssh openssh-askpass openssh-helpers pulseaudio pulseaudio-bash-completion pulseaudio-lang pulseaudio-module-bluetooth
    pulseaudio-module-jack pulseaudio-module-lirc pulseaudio-module-x11 pulseaudio-module-zeroconf pulseaudio-utils python-txsocksx qbittorrent qbittorrent-nox radvd rp-pppoe rpcbind rsync
    sox taglib tftp tnftp udhcp utils-libnfs vcdimager vlc vlc-codec-gstreamer vlc-noX vlc-qt vokoscreen vorbis-tools vorbis-tools-lang vpnc vsftpd w3m xorriso

    Nothing to do.
    ----------------------------------------------------------------------End-

    It looks like a bit of a mess to me. Can anyone help me work out whats going on with this and resolve it?

    Thankyou

    Jesse

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,352
    Blog Entries
    3

    Default Re: Zypper Update - The following 261 package updates will NOT be installed. Nothing to do.

    There's probably something amiss.

    I am seeing around 10-20 packages listed that way. In my case, they are packages from "packman" while the higher version numbered package is in the oss or update repo. The "zypper up" command won't switch from one repo to another.

    Maybe there is something similar to that happening in your case. Perhaps those packages came from a repo that you have disabled. And if that's the case, then it is probably safe to ignore the message.

    An alternative would be to update to 42.3 using the DVD installer. That might be a safer choice in this case.
    openSUSE Leap 15.1; KDE Plasma 5;

  3. #3
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Zypper Update - The following 261 package updates will NOT be installed. Nothing to do.

    what's your repo list
    Code:
    zypper lr -d
    afaik if you are planning an upgrade to 42.3 there is no real need to update 42.2 (I know the wiki says so but for the life of me I can't think of a good reason it might actually break the upgrade process as it did for me with some packman package because the 42.3 wore lover build versions then 42.2's I got stuck with some old packages that needed manual force update)

  4. #4

    Default Re: Zypper Update - The following 261 package updates will NOT be installed. Nothing to do.

    Thanks. I will have a look at repositories.

    Code:
    zypper lr -d
    is at: http://pasted.co/71915056

  5. #5

    Default Re: Zypper Update - The following 261 package updates will NOT be installed. Nothing to do.

    Quote Originally Posted by I_A View Post
    afaik if you are planning an upgrade to 42.3 there is no real need to update 42.2 (I know the wiki says so but for the life of me I can't think of a good reason it might actually break the upgrade process as it did for me with some packman package because the 42.3 wore lover build versions then 42.2's I got stuck with some old packages that needed manual force update)
    Ok, I guess I should look at the build versions in the list of not upgraded packages and compare them with 42.3?

    Is there an easy way someone can think of to list (and maybe compare with 42.3) the versions for each of the packages in the "The following 261 package updates will NOT be installed:" list?

    And why would using a DVD to upgrade to 42.3 be better than the "zypper dup" from net?

    Thanks

  6. #6

    Default Re: Zypper Update - The following 261 package updates will NOT be installed. Nothing to do.

    Quote Originally Posted by nrickert View Post
    There's probably something amiss.

    I am seeing around 10-20 packages listed that way. In my case, they are packages from "packman" while the higher version numbered package is in the oss or update repo. The "zypper up" command won't switch from one repo to another.

    Maybe there is something similar to that happening in your case. Perhaps those packages came from a repo that you have disabled. And if that's the case, then it is probably safe to ignore the message.

    An alternative would be to update to 42.3 using the DVD installer. That might be a safer choice in this case.
    Thanks. I just realised this one was disabled at update prior to reboot as it was giving errors and could not be used.
    Code:
    18 | http-download.opensuse.org-faf6f3ff | home:Kenzy:packages                     | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/repositories/home:/Kenzy:/packages/openSUSE_Leap_42.2/

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,352
    Blog Entries
    3

    Default Re: Zypper Update - The following 261 package updates will NOT be installed. Nothing to do.

    Quote Originally Posted by motiv8d View Post
    Thanks. I just realised this one was disabled at update prior to reboot as it was giving errors and could not be used.
    Code:
    18 | http-download.opensuse.org-faf6f3ff | home:Kenzy:packages                     | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/repositories/home:/Kenzy:/packages/openSUSE_Leap_42.2/
    That could explain some of 261 packages. Anything you were getting from that repo is probably out-of-date, but can't be updated because of the repo-change (or, technically, the vendor change).

    And why would using a DVD to upgrade to 42.3 be better than the "zypper dup" from net?
    You would be running the software from the DVD while doing the update. So any problems in the software on your computer should not cause failures during the upgrade.

    However, looking at that list of packages, they all seem be desktop or multimedia related. So the base system used to do the upgrade should be fine. As long as you are doing the upgrade at a command line, and not within GUI software, you will probably be okay.
    openSUSE Leap 15.1; KDE Plasma 5;

  8. #8
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Zypper Update - The following 261 package updates will NOT be installed. Nothing to do.

    you have 30 reposetories some of them disabled as nrickert said home:Kenzyackages is probobly the culprit as LEAP has vendor stickiness newer packages from 3rd party repo's are not installed by default
    as you're upgrading to 42.3 it's time to clean house I'd recommend doing a live upgrade not a DVD as that's how I've been doing my upgrades since 13.1
    remove all reposetories add 42.3's main oss and non-os repo's the update, packman and nvidia repo's and do zypper dup
    I'll suggest reading the opensuse wiki about it
    https://en.opensuse.org/SDB:System_upgrade#Command_line
    if doing an upgrade do it in text mode with no X windows active (press ctrl+alt+F1)
    or in simple words remove all repositories
    add oss non-oss update packman and nvidia
    Code:
    zypper rr *
    zypper ar -f https://download.opensuse.org/distribution/leap/42.3/repo/oss/suse/ oss-42.3
    zypper ar -f https://download.opensuse.org/distribution/leap/42.3/repo/non-oss/suse/ non-oss-42.3
    zypper ar -f http://download.opensuse.org/update/leap/42.3/oss update-oss-42.3
    zypper ar -f http://download.opensuse.org/update/leap/42.3/non-oss update-non-oss-42.3
    zypper ar -f http://packman.inode.at/suse/openSUSE_Leap_42.3 packman
    zypper ar -f http://download.nvidia.com/opensuse/leap/42.3 nvidia
    zypper dup
    reboot add the extra repositories you might need or use
    you can also change your 42.2 repo's to point to 42.3 in yast software sources you can edit the repo URL's but do not have any other repositories except the main oss non-oss and update enabled during an upgrade as something might go wrong

  9. #9

    Default Re: Zypper Update - The following 261 package updates will NOT be installed. Nothing to do.

    Ok thanks. I will take a backup and see how an upgrade with repos cleaned up goes :-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •