Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: power management settings

  1. #1
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    467

    Default power management settings

    I turned off all power management settings yet, after some time my notebook continues to go to a screen requiring password.
    How do I not go to this screen?

  2. #2
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,273

    Default Re: power management settings

    Quote Originally Posted by sergelli View Post
    I turned off all power management settings yet, after some time my notebook continues to go to a screen requiring password.
    How do I not go to this screen?
    Notebook itself perhaps... any setting in the BIOS? I once had an old Hewlett Packard, albeit a desktop, that did that.

    If not... What desktop environment are you using?
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191018) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  3. #3
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    467

    Default Re: power management settings

    Quote Originally Posted by tannington View Post
    Notebook itself perhaps... any setting in the BIOS? I once had an old Hewlett Packard, albeit a desktop, that did that.

    If not... What desktop environment are you using?
    I am using the KDE
    My noteBook is an Asus 2 years old and the BIOS don't shows that issue

  4. #4
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,273

    Default Re: power management settings

    Quote Originally Posted by sergelli View Post
    I am using the KDE
    Hmm... strange. Seems to work for me OK, although this a desktop, I don't know how, or if, power management may be different on a laptop/notebook.

    Just checked on a system running 42.3

    System Settings -> Power Management -> Energy Saving

    I've set "Suspend Session" "After" to 1min for the purposes of testing, with the action performed as "Lock Screen"

    If "Suspend Session" is ticked then the screen locks as expected.

    After un-ticking "Suspend Session" and "Apply" the screen remains unlocked as expected.

    Does the same thing happen if you create a new test user?
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191018) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  5. #5
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    467

    Default Re: power management settings

    Quote Originally Posted by tannington View Post
    Hmm... strange. Seems to work for me OK, although this a desktop, I don't know how, or if, power management may be different on a laptop/notebook.

    Just checked on a system running 42.3

    System Settings -> Power Management -> Energy Saving

    I've set "Suspend Session" "After" to 1min for the purposes of testing, with the action performed as "Lock Screen"

    If "Suspend Session" is ticked then the screen locks as expected.

    After un-ticking "Suspend Session" and "Apply" the screen remains unlocked as expected.

    Does the same thing happen if you create a new test user?
    With a new test user it not happen.

  6. #6
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,273

    Default Re: power management settings

    Quote Originally Posted by sergelli View Post
    With a new test user it not happen.
    Try renaming "~/.config/powermanagementprofilesrc" of the non-working user to, for example, "~/.config/powermanagementprofilesrc.old"

    Then log in as the non-working user and set the Power Management options as you require, a new "powermanagementprofilesrc" will be created.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191018) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  7. #7
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    467

    Default Re: power management settings

    Quote Originally Posted by tannington View Post
    Try renaming "~/.config/powermanagementprofilesrc" of the non-working user to, for example, "~/.config/powermanagementprofilesrc.old"

    Then log in as the non-working user and set the Power Management options as you require, a new "powermanagementprofilesrc" will be created.
    I tried the above and many others to try to solve the problem with power management. Nothing solved.

    I also noticed that there are other problems that can not find solution, for example the double-click on the desktop does not work

    I have 4 other machines in my job, all with Leap and different from when I operated with OpenSuse 13.2 or older, now with Leap all machines have some kind of insoluble problem

    So I decided to try with other Linux distributions with this noteBook
    If the problems continue, I will re-use Leap

    But, thank you so much for the effort.

  8. #8
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: power management settings

    I think this is an issue with sddm
    I know it sounds silly but I'm pretty sure it's sddm asking for a user password (it's the same login screen as sddm uses after boot)
    this has been bugging me for some time now (especially sddm having Num Lock set to off by default) but I've been too lazy to investigate (the Num Lock is solvable by editing /etc/sddm.conf but updates undo changes)

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,399
    Blog Entries
    1

    Default Re: power management settings

    Quote Originally Posted by sergelli View Post
    I tried the above and many others to try to solve the problem with power management. Nothing solved.
    It's not a power management configuration issue. Check the screen-locking settings...

    System Settings > Desktop Behaviour > Screen Locking

    The pertinent Plasma 5 config file is ~/.config/kscreenlockerrc

  10. #10
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    467

    Default Re: power management settings

    Quote Originally Posted by deano_ferrari View Post
    It's not a power management configuration issue. Check the screen-locking settings...

    System Settings > Desktop Behaviour > Screen Locking

    The pertinent Plasma 5 config file is ~/.config/kscreenlockerrc
    As I said before, there were other problems (double click on the desktop) and also the screen-locking settings never made the changes

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •