Results 1 to 4 of 4

Thread: Unable to file browse Windows SMB share after disable support for SMB v1

  1. #1

    Question Unable to file browse Windows SMB share after disable support for SMB v1

    After I disable the support for SMB v1 file share on my Windows Server 2008 R2 machine, I am no longer able to browse the Windows share from my Leap 42.1 (kernel 4.1.39-56).
    I use the GUI on this LEAP machine to do the network file share browsing.
    Is there a way to force the LEAP machine to use the newer SMB protocol?
    My Windows Server machine is now only supporting SMB v2 and higher.

    Please kindly assist.
    Thank you.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,706
    Blog Entries
    1

    Default Re: Unable to file browse Windows SMB share after disable support for SMB v1

    Quote Originally Posted by pasiit View Post
    After I disable the support for SMB v1 file share on my Windows Server 2008 R2 machine, I am no longer able to browse the Windows share from my Leap 42.1 (kernel 4.1.39-56).
    I use the GUI on this LEAP machine to do the network file share browsing.
    Is there a way to force the LEAP machine to use the newer SMB protocol?
    My Windows Server machine is now only supporting SMB v2 and higher.

    Please kindly assist.
    Thank you.
    What does the following report?
    Code:
    testparm -vs|grep client
    You should be able to specify (in smb.conf global section) using....
    Code:
    client min protocol = SMB2
    client max protocol = SMB3

  3. #3

    Thumbs up Re: Unable to file browse Windows SMB share after disable support for SMB v1

    Quote Originally Posted by deano_ferrari View Post
    What does the following report?
    Code:
    testparm -vs|grep client
    You should be able to specify (in smb.conf global section) using....
    Code:
    client min protocol = SMB2
    client max protocol = SMB3
    Awesome, adding the
    Code:
    client min protocol = SMB2
    client max protocol = SMB3
    in to the /etc/samba/smb.conf did help to resolve the issue.
    I am now able to connect to the Windows Server.

    Thank you very much.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,706
    Blog Entries
    1

    Default Re: Unable to file browse Windows SMB share after disable support for SMB v1

    Glad to have been of assistance.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •