Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Libre office crashes when opening document

  1. #1

    Default Libre office crashes when opening document

    Since a week ago libreoffice 5.3.5.2-3.4 crashes when opening files. I can start writer or calc but when I open existing file both calc and writer crash. I tried already deleting the libreoffice directory in ~/.cache and ~/.config.

    It happens with any writer or calc document and I can open the documents in Caligra Sheets

    I'm running 42.3 Leap with all current updates. I'm using pacman repo at higher priority for the multimedia files. I did zypper dup using pacman but after this I had no problems. Also I'm using Firefox repo for Firefox 57.

  2. #2

    Default Re: Libre office crashes when opening document

    I also tried adding libreoffice 5.4 opensuse leap repo and doing a dup. This hasn't helped. I removed repo and updated (downgraded back to 5.3) and installed libreoffice-kde manually. This hasn't helped either.

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    16,725
    Blog Entries
    13

    Default Re: Libre office crashes when opening document

    Please post output of
    Code:
    zypper lr -d
    To exclude a user config: create a new user, login as that user and try to reproduce the crash. If it doesn't crash for the new user, the culprit is in your homedir. If it does crash, try starting lowriter from a terminal window, make it crash and have a look at the messages in the terminal window.

    Question; how did you use zypper dup ? Just plain, or with a --from parameter?
    ° Appreciate my reply? Click the star and let me kow why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: Libre office crashes when opening document

    Quote Originally Posted by Knurpht View Post
    Please post output of
    Code:
    zypper lr -d
    To exclude a user config: create a new user, login as that user and try to reproduce the crash. If it doesn't crash for the new user, the culprit is in your homedir. If it does crash, try starting lowriter from a terminal window, make it crash and have a look at the messages in the terminal window.

    Question; how did you use zypper dup ? Just plain, or with a --from parameter?
    Doesn't crash with new user. Interestingly you need to use yast, useradd is insufficient to add a user.
    I used zypper dup -f (--force) 1

    How do I go best about removing my account and not loosing data? In root terminal move my files elsewhere (I don't think I have room for 2 copies or 100GB will take a while)? Then remove and recreate user?
    Is there some way I could fix this by simply removing some configs?

    Here is the output
    Code:
    # | Alias                          | Name                                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                          | Service
    --+--------------------------------+---------------------------------------------+---------+-----------+---------+----------+--------+------------------------------------------------------------------------------+--------
    1 | download.nvidia.com-leap       | nVidia Graphics Drivers                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.nvidia.com/opensuse/leap/42.3                                |        
    2 | http-packman.inode.at-04e64fa4 | Packman Repository                          | Yes     | (r ) Yes  | Yes     |   50     | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_42.3/                             |        
    3 | mozilla                        | Mozilla based projects (openSUSE_Leap_42.3) | Yes     | (r ) Yes  | No      |   50     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_42.3/        |        
    4 | openSUSE-42.3-0                | openSUSE-42.3-0                             | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/oss/                |        
    5 | repo-non-oss                   | openSUSE-Leap-42.3-Non-Oss                  | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/            |        
    6 | repo-update                    | openSUSE-Leap-42.3-Update                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.3/oss/                           |        
    7 | repo-update-non-oss            | openSUSE-Leap-42.3-Update-Non-Oss           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.3/non-oss/                       |        
    8 | skype-stable                   | skype (stable)                              | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://repo.skype.com/rpm/stable/                                           |        
    9 | snappy                         | snappy                                      | Yes     | (r ) Yes  | No      |   99     | rpm-md | http://download.opensuse.org/repositories/system:/snappy/openSUSE_Leap_42.3/ |

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 9
    Posts
    14,592

    Default Re: Libre office crashes when opening document

    Remove the LO config files in the user's home maybe also clear the users .cache files. Might also be in the desktop config/cache files. If no problem with second user it is not a package problem.

  6. #6
    Join Date
    Mar 2015
    Location
    Viçosa, Brasil
    Posts
    210

    Default Re: Libre office crashes when opening document

    I'm also having this issue in 42.3. So, as suggested, I deleted the LO config files in home. Let's see...
    --
    Biostatistics and Data Science
    https://bio-data.github.io/

  7. #7
    Join Date
    Feb 2010
    Location
    Upstate New York, USA
    Posts
    478

    Default Re: Libre office crashes when opening document

    Running LibreOffice 5.3.7.2-4.1 (from http://download.opensuse.org/reposit...USE_Leap_42.3/) without incident. Prior to upgrading to this repo, sporadic failures in Calc were experienced at LibreOffice 5.3.5.2-3.4 from the Leap Update repo.
    Lap: Gateway NV79, i5-430, 4GB, 2 x 500GB HD, Intel GMA HD
    openSUSE 13.1 x64 + 42.3 x64, KDE 4.14.10, Ubuntu 16.04LTS, Windows 7

    Test:: openSUSE 42.3, KDE Plasma, Windows/XP/SP3 guest and a Ubuntu 10.04.3 LTS boarder

  8. #8

    Default Re: Libre office crashes when opening document

    I pinpointed the issue to ~/.mozilla/firefox/randomprofilename.default folder. As soon as I move it away the problem goes away.

    I logged out, moved my homedir to / as root and deleted and recreated the user. Then I logged in desktop session as user and started moving my files back. Of course I also wanted to move browser caches and other stuff but when I tried opening documents problem happened again. Then I moved stuff step by step and tested after each move.

  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    1,247

    Default Re: Libre office crashes when opening document

    Quote Originally Posted by poshleon View Post
    I pinpointed the issue to ~/.mozilla/firefox/randomprofilename.default folder. As soon as I move it away the problem goes away.
    I'm having difficulty understanding why the Mozilla Firefox browser files are causing LibreOffice to crash.
    • However, performing a case-insensitive search (with 'grep') in the ~/.config/ directory for 'mozilla' revealed that, the LibreOffice configuration files do in fact mention "Mozilla".

    Be that as it may, please be aware that, beginning with LibreOffice version 5.3, Type 1 (Postscript) fonts are no longer supported.
    Only TrueType (TTF) and OpenType (OTF) fonts are currently supported by LibreOffice.

    • Do the files you're attempting to open contain (embedded) Type 1 (Postscript) fonts or, are they attempting to load Type 1 (Postscript) fonts?

  10. #10

    Default Re: Libre office crashes when opening document

    I am also having this problem.
    I did a fresh install of leap 42.2, then added leap 42.3 oss and non-oss base and update repos, then did zypper dup.

    >zypper lr -u
    Repository priorities in effect: (See 'zypper lr -P' for details)
    99 (default priority) : 4 repositories

    # | Alias | Name | Enabled | GPG Check | Refresh | URI
    --+------------------+------------------+---------+-----------+---------+-------------------------------------------------------------------
    1 | 42.3_noss | repo-noss | Yes | (r ) Yes | Yes | http://download.opensuse.org/distrib.../repo/non-oss/
    2 | 42.3_noss_update | repo_noss_update | Yes | (r ) Yes | Yes | http://download.opensuse.org/update/leap/42.3/non-oss/
    3 | 42.3_repo | repo-oss | Yes | (r ) Yes | Yes | http://download.opensuse.org/distrib...42.3/repo/oss/
    4 | 42.3_update | repo_update | Yes | (r ) Yes | Yes | http://download.opensuse.org/update/leap/42.3/oss/


    (I didn't do a fresh install of 42.3 because the installer wouldn't actually run)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •