Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Upgraded to Tumbleweed and now have this issues

  1. #1

    Default Upgraded to Tumbleweed and now have this issues

    Hi,
    So last night the updater app said something about updating some packages, little did I know that about 2000+ packages were being installed, somehow I messed up the repos and I jumped from Leap 42.3 to Tumbleweed.

    Now I'm having some issues.

    I can only boot on a previous kernel 4.4.92-31-default correctly, otherwise the latest one installed by Tumbleweed 4.14.0-1.8 crashes at boot with a ACPI error. I also have a nVidia GT210 graphics card and so I use the nvidia G03 driver.

    The icons on new KDE Plasma are missing on Desktop and the text under them is jagged. Please see attached screenshots.

    Can you guys help me sort my repos and correctly set up my machine.

    Here are my repos and other details

    Code:
    Repository priorities are without effect. All enabled repositories share the same priority.
    
    #  | Alias                               | Name                      | Enabled | GPG Check | Refresh
    ---+-------------------------------------+---------------------------+---------+-----------+--------
     1 | Packman_Tumbleweed                  | Packman Tumbleweed        | Yes     | (r ) Yes  | Yes    
     2 | Python_42.3                         | Python_42.3               | No      | ----      | ----   
     3 | Tumbleweed NON-OSS                  | Tumbleweed NON-OSS        | Yes     | (r ) Yes  | No     
     4 | Tumbleweed OSS                      | Tumbleweed OSS            | Yes     | (r ) Yes  | No     
     5 | Tumbleweed Update OSS               | Tumbleweed Update OSS     | Yes     | (r ) Yes  | No     
     6 | download.opensuse.org-oss           | Main Repository (OSS)     | No      | ----      | ----   
     7 | download.opensuse.org-oss_1         | Main Update Repository    | No      | ----      | ----   
     8 | http-download.opensuse.org-03a89f56 | isv:ownCloud:desktop      | No      | ----      | ----   
     9 | http-download.opensuse.org-31685a96 | openSUSE:Factory          | No      | ----      | ----   
    10 | http-download.opensuse.org-d5d4464c | openSUSE:Leap:42.3:Update | No      | ----      | ----   
    11 | http-download.opensuse.org-f11bf96c | home:pbek:QOwnNotes       | No      | ----      | ----   
    12 | nVidia_Tumbleweed                   | nVidia Tumbleweed         | No      | ----      | ----   
    13 | nvidia                              | nvidia                    | Yes     | (r ) Yes  | Yes
    Code:
    zypper se -iv kernel-default
    Loading repository data...
    Reading installed packages...
    
    S  | Name                 | Type    | Version     | Arch   | Repository        
    ---+----------------------+---------+-------------+--------+------------------
    i+ | kernel-default       | package | 4.14.0-1.8  | x86_64 | Tumbleweed OSS    
        name: kernel-default
    i+ | kernel-default       | package | 4.4.92-31.1 | x86_64 | (System Packages)
        name: kernel-default
    i+ | kernel-default       | package | 4.14.0-1.8  | x86_64 | (System Packages)
        name: kernel-default
    i+ | kernel-default-devel | package | 4.14.0-1.8  | x86_64 | Tumbleweed OSS    
        name: kernel-default-devel
    i+ | kernel-default-devel | package | 4.4.92-31.1 | x86_64 | (System Packages)
        name: kernel-default-devel
    i+ | kernel-default-devel | package | 4.14.0-1.8  | x86_64 | (System Packages)
        name: kernel-default-devel
    
    
    Code:
    zypper se -iv nvidia
    Loading repository data...
    Reading installed packages...
    
    S  | Name                          | Type    | Version                | Arch   | Repository        
    ---+-------------------------------+---------+------------------------+--------+------------------
    i+ | nvidia-computeG03             | package | 340.104-11.1           | x86_64 | nvidia            
        name: nvidia-computeG03
    i+ | nvidia-computeG03             | package | 340.104-11.1           | x86_64 | (System Packages)
        name: nvidia-computeG03
    i+ | nvidia-gfxG03-kmp-default     | package | 340.104_k4.4.76_1-11.1 | x86_64 | nvidia            
        name: nvidia-gfxG03-kmp-default
    i+ | nvidia-gfxG03-kmp-default     | package | 340.104_k4.4.76_1-11.1 | x86_64 | (System Packages)
        name: nvidia-gfxG03-kmp-default
    i+ | nvidia-glG03                  | package | 340.104-11.1           | x86_64 | nvidia            
        name: nvidia-glG03
    i+ | nvidia-glG03                  | package | 340.104-11.1           | x86_64 | (System Packages)
        name: nvidia-glG03
    i+ | nvidia-uvm-gfxG03-kmp-default | package | 340.104_k4.4.76_1-11.1 | x86_64 | nvidia            
        name: nvidia-uvm-gfxG03-kmp-default
    i+ | nvidia-uvm-gfxG03-kmp-default | package | 340.104_k4.4.76_1-11.1 | x86_64 | (System Packages)
        name: nvidia-uvm-gfxG03-kmp-default
    i+ | x11-video-nvidiaG03           | package | 340.104-11.1           | x86_64 | nvidia            
        name: x11-video-nvidiaG03
    i+ | x11-video-nvidiaG03           | package | 340.104-11.1           | x86_64 | (System Packages)
        name: x11-video-nvidiaG03
    
    
    Code:
    uname -a
    Linux linux-jspa.site 4.4.92-31-default #1 SMP Sun Oct 22 06:56:24 UTC 2017 (1d80e8a) x86_64 x86_64 x86_64 GNU/Linux
    
    
    https://imgur.com/a/CaHyZ
    OpenSUSE Leap 42.2 x64 KDE

  2. #2
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,070

    Default Re: Upgraded to Tumbleweed and now have this issues

    So, first off, what do you want to use, Tumbleweed, or 42.3?

    Be aware that the nvidia support using the TW repositories is G04 only.

    If you want to stick with 42.3 then, boot from the previous kernel, change all repositories back to those for 42.3, log out and then perform a "zypper dup" from the command line; that should restore your 42.3 system.

    If you want to use TW then, boot from the previous kernel, remove the nvidia drivers so you are using the OSS drivers. Ensure only TW repositories are enabled, *excluding nvidia*, log out and then perform a "zypper dup" from the command line; that should give you a working TW system.

    For TW any future updates you perform must be by "zypper dup" from the command line, no other way.
    Regards, Paul

    Tumbleweed (Snapshot: 20190612) KDE Plasma 5
    Leap 15.0 KDE Plasma 5
    [Non-Tumbling Tumblweed (20150508) KDE 4 - Resurrected]

  3. #3

    Default Re: Upgraded to Tumbleweed and now have this issues

    Quote Originally Posted by tannington View Post
    So, first off, what do you want to use, Tumbleweed, or 42.3?

    Be aware that the nvidia support using the TW repositories is G04 only.

    If you want to stick with 42.3 then, boot from the previous kernel, change all repositories back to those for 42.3, log out and then perform a "zypper dup" from the command line; that should restore your 42.3 system.

    If you want to use TW then, boot from the previous kernel, remove the nvidia drivers so you are using the OSS drivers. Ensure only TW repositories are enabled, *excluding nvidia*, log out and then perform a "zypper dup" from the command line; that should give you a working TW system.

    For TW any future updates you perform must be by "zypper dup" from the command line, no other way.
    I would like TW, I think!
    Are there any issues or major differences between the nvidia and the OSS nvidia GPU driver?

    I currently have only the TW repos enabled.
    OpenSUSE Leap 42.2 x64 KDE

  4. #4
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,070

    Default Re: Upgraded to Tumbleweed and now have this issues

    Quote Originally Posted by robertot5 View Post
    Are there any issues or major differences between the nvidia and the OSS nvidia GPU driver?
    That would largely depend upon the video card and applications you are using, it's a hard one to answer. Ask half a dozen different people and you'll probably get different replies... My own experience:

    I'm running an older 8600GTS card using the Nouveau OSS drivers and don't have any issues.

    I also have another machine with a newer GT710 card, that also worked OK with the OSS driver, although I'm currently using the G04 driver with it as the card runs a few degrees C cooler.

    The general consensus seems to be if it's a newer card and applications are graphics intensive, the proprietary drivers are better.

    If you do use the OSS drivers then hardware acceleration is provided by a separate package "Mesa-dri-nouveau", this is marked as "experimental" with quite a "scary" warning. Again, I'm using it with the 8600GTS without problem. I'd be inclined to not use it initially, then add the package and see how it goes, only removing it if you think it's causing problems. Without it any openGL rendering will be done by software emulation, thus increasing the CPU utilisation.

    You can of course use the proprietary drivers with TW, but they have to be installed "the hard way". https://en.opensuse.org/SDB:NVIDIA_the_hard_way
    Regards, Paul

    Tumbleweed (Snapshot: 20190612) KDE Plasma 5
    Leap 15.0 KDE Plasma 5
    [Non-Tumbling Tumblweed (20150508) KDE 4 - Resurrected]

  5. #5
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,070

    Default Re: Upgraded to Tumbleweed and now have this issues

    Quote Originally Posted by robertot5 View Post
    I currently have only the TW repos enabled.
    Sorry, forgot to add...

    With regard to the repositories you listed in the first post, use only 1, 3, 4, and 5 when you perform the zypper dup. If you need the owncloud and qownnotes repos ensure they're compatible with TW and add them back after you have a working TW installed.
    Regards, Paul

    Tumbleweed (Snapshot: 20190612) KDE Plasma 5
    Leap 15.0 KDE Plasma 5
    [Non-Tumbling Tumblweed (20150508) KDE 4 - Resurrected]

  6. #6

    Default Re: Upgraded to Tumbleweed and now have this issues

    On Fri, 24 Nov 2017 14:36:02 +0000, robertot5 wrote:

    > I would like TW, I think!
    > Are there any issues or major differences between the nvidia and the OSS
    > nvidia GPU driver?


    Just as a reference point: I have a box with an Nvidia GTX630 - similar
    hardware to yours - that ran with G03 Nvidia drivers. It's solid with
    the nouveau drivers, even the Mesa-dri-nouveau works well despite the
    scary warning ;-)

  7. #7

    Default Re: Upgraded to Tumbleweed and now have this issues

    Quote Originally Posted by robertot5 View Post
    The icons on new KDE Plasma are missing on Desktop and the text under them is jagged. Please see attached screenshots.
    Hi roberto5,
    Did you solve this issue? It happens to me as well in Tumbleweed.
    When I call kde SystemSettings, a window without icons shows up. I can regenerate the icons by clicking on "icons"
    and "Apply", but they last only for that session. When I quit systemSettings, the icons are gone again. Any ideas?
    Thanks,
    Mario

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,471
    Blog Entries
    14

    Default Re: Upgraded to Tumbleweed and now have this issues

    Quote Originally Posted by mnatiello View Post
    Hi roberto5,
    Did you solve this issue? It happens to me as well in Tumbleweed.
    When I call kde SystemSettings, a window without icons shows up. I can regenerate the icons by clicking on "icons"
    and "Apply", but they last only for that session. When I quit systemSettings, the icons are gone again. Any ideas?
    Thanks,
    Mario
    This might be related to the Mesa bug. Run 'zypper dup', then remove /var/lib/sddm/,cache and your users' ~/.cache, then reboot.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  9. #9

    Default Re: Upgraded to Tumbleweed and now have this issues

    Quote Originally Posted by Knurpht View Post
    This might be related to the Mesa bug. Run 'zypper dup', then remove /var/lib/sddm/,cache and your users' ~/.cache, then reboot.
    Thanks, but it makes no difference. I'm running kde5 but not plasma. I use another windowmanager.
    When I launch KDESystemSettings it appears with no icons. Well... there is ONE icon only, all other services show up with their
    names only. I may click on icons and apply the desired icon theme (the system thinks it's applied, "apply" is greyed out, but
    I can choose another icon theme and click "apply"), but they disappear again when I kill KDESystemSettings.
    Any help is welcome.

    MNatiello

  10. #10

    Default Re: Upgraded to Tumbleweed and now have this issues

    Quote Originally Posted by mnatiello View Post
    I'm running kde5 but not plasma.
    There is no "kde5".

    Ok, so you don't use Plasma, but what do you mean with "kde5"?
    Some KDE applications?

    I use another windowmanager.
    And which one?

    Why are you asking in this thread then, which was about problems with Plasma?

    When I launch KDESystemSettings it appears with no icons.
    That's "normal" if the icons are not in the used icon theme.
    Qt5 tries to adapt to the used desktop's settings. If you run it on an unsupported desktop, it probably uses "hicolor" which doesn't contain them.

    It may help to install qt5ct and configure another icon theme there.

    But if you don't use Plasma, systemsettings5 will be not very useful to you either, as that mainly contains the (Plasma) desktop's settings...
    The same applies to other KDE and Qt5 applications though.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •