Results 1 to 6 of 6

Thread: cntl-alt-backspace solves a non-working KDE but the problem is back on reboot

  1. #1
    Join Date
    Jun 2008
    Location
    London
    Posts
    174

    Default cntl-alt-backspace solves a non-working KDE but the problem is back on reboot

    It's a fresh install

    The menu and desktop short cuts are unresponsive until I kill the X server and restart (other stuff works)

    I've tried to cure it by deleting .kde4 but this does not solve the problem

    I've always steered away from fiddling with the X server, so have little experience of playing with it, but I assume there must be a corrupt config file?

    Confusingly, IceWM works

    Any advice gratefully received, thank you

  2. #2
    Join Date
    Jun 2008
    Location
    London
    Posts
    174

    Default Re: cntl-alt-backspace solves a non-working KDE but the problem is back on reboot

    Quote Originally Posted by gerrygavigan View Post

    Confusingly, IceWM works
    no, it doesn't, not before cntl-alt-backspace

  3. #3
    Join Date
    Jun 2008
    Location
    London
    Posts
    174

    Default Re: cntl-alt-backspace solves a non-working KDE but the problem is back on reboot

    Quote Originally Posted by gerrygavigan View Post

    The menu and desktop short cuts are unresponsive until I kill the X server and restart (other stuff works)
    and I cannot preserve my system keyboard settings - they revert to English (US) after every reboot after editing

    YaST->System->Language and YaST->Hardware->System Keyboard Layout (it was set to UK already, so I set it to something else first).

    /etc/sysconfig/language reports

    Code:
    # Local users will get RC_LANG as their default language, i.e. the
    # environment variable $LANG . $LANG is the default of all $LC_*-variables,
    # as long as $LC_ALL is not set, which overrides all $LC_-variables.
    # Root uses this variable only if ROOT_USES_LANG is set to "yes".
    #
    RC_LANG="en_GB.UTF-8"
    /etc/sysconfig/keyboard

    Code:
    # Keyboard mapping
    # (/usr/share/kbd/keymaps/)
    # e.g. KEYTABLE="de-latin1-nodeadkeys", "us" or empty for US settings
    #
    KEYTABLE=""
    Last edited by gerrygavigan; 23-Nov-2017 at 14:53. Reason: more info

  4. #4
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    3,374
    Blog Entries
    1

    Default Re: cntl-alt-backspace solves a non-working KDE but the problem is back on reboot

    .kde4 is not where current or recent versions of Plasma store much of anything. Plasma5 settings are mostly in ~/.config/, mixed up with many other personal settings. Your problem suggests to me a permissions problem in your homedir. If you login as a new user, is the trouble the same?

  5. #5
    Join Date
    Jun 2008
    Location
    London
    Posts
    174

    Default Re: cntl-alt-backspace solves a non-working KDE but the problem is back on reboot

    Quote Originally Posted by mrmazda View Post
    .kde4 is not where current or recent versions of Plasma store much of anything.
    Thank you replying and yes I thought .kde4 was a bit suspect


    Your problem suggests to me a permissions problem in your homedir. If you login as a new user, is the trouble the same?
    You are right a new user doesn't seem to experience the same problems.

    I am unsure why it is a permissions problem and why it is temporarily cured by killing the X server.

    I need to double check but if I log in as new user then log in as "me" I don't seem to get the KDE problems but the keyboard is still US

  6. #6
    Join Date
    Jun 2008
    Location
    London
    Posts
    174

    Default Re: cntl-alt-backspace solves a non-working KDE but the problem is back on reboot

    Quote Originally Posted by gerrygavigan View Post
    the keyboard is still US
    thanks to your hint I found out a bit more where Plasma 5 stores "stuff"

    in

    Code:
     home/[me]/.local/share/kded5/keyboard/session
    I found
    Code:
     
    layout_memory.xml
    and it contains

    Code:
    <LayoutMap SwitchMode="Global" version="1.0"><item currentLayout="gb"/></LayoutMap>
    but it is not being applied

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •