Hello!

First time posting here, so I hope I posted in the right section. Otherwise _do tell me_ where I should have posted it.

I recently installed Tumbleweed with Gnome and holy heck it's great. I uninstalled a couple of different programs that I didn't need and I also tabooed them, to make sure they wouldn't try to reinstall when I updated. I uninstalled and tabooed the following packages and patterns (with yast!):
  • xorg-x11-Xvnc
  • tigervnc-x11vnc
  • tigervnc
  • patterns-gnome-gnome-games
  • patterns-games
  • gnome-shell-search-provider-bijiben
  • bijiben-lang
  • bijiben


After doing this i went on and performed a
Code:
# zypper dup
and it returned the following:

Code:
The following 2044 elements are locked and wont be changed by any action:
Avaible:
bijiben bijiben-lang gnome-shell-search-provider-bijiben patterns-games-games
patterns-gnome-gnome_games tigervnc tigervnc-x11vnc xorg-x11-Xvnc
Installed:
---many packages ---- (read: Of course it didn't actually say that)
.... and 1936 further elements

Run 'zypper locks -s' for a complete list of locked elements

Nothing to do
(excuse me for mis-translations, my system is in danish, so I'm not 100% what it would have said in english!)

Now my question is if it's supposed to be this way? Or does it mean I borked something and now wont update properly? I have tried running
Code:
zypper dup
for the last couple of days and I would have imagined something would have gotten an update in this

Thank you
rtbj

(and thank you to everyone who contributed to this project. It seems like a really nice distribution. Everything is pretty polished, no funny business and still manages to be so up to date that it tickles my "shiny new stuff" syndrome. I will definitely be looking into getting Leap on my server when I get zypper and yast figured out.)