Results 1 to 3 of 3

Thread: Yast won't start any components in GUI nor start on command line

  1. #1

    Default Yast won't start any components in GUI nor start on command line

    I think this happened when I had ruby update itself not knowing it was used in Yast. The problem is I don't know how to recover from it. I did a
    Code:
    zypper dup
    to get everything back to normal but I still have the problem.

    For example, I click on any icon in the yast control center GUI and in the file
    Code:
    /var/log/YaST2/y2log
    gets the following errors:

    Code:
    [liby2] genericfrontend.cc(main):617 Launched YaST2 component 'y2base' 'sw_single' 'qt'
    [ui-component] YUIComponentCreator.cc(createInternal):124 Creating UI component for ""
    [liby2] genericfrontend.cc(main):806 YAST_IS_RUNNING is yes
    [Y2Ruby] binary/Y2RubyUtils.cc(y2_require):25 cannot require yast:no implicit conversion of false into String at /usr/lib64/ruby/site_ruby/2.1.0/rubygems/bundler_version_finder.rb:64:in `basename'
    [liby2] genericfrontend.cc(main):820 Finished YaST2 component 'y2base'
    [liby2] genericfrontend.cc(main):825 Exiting with client return value 'false'
    It's the ruby stuff that makes me think it was ruby updating that caused this but it could potentially be something else.

    Also, if I type yast on the command line it simply doesn't start and creates the same errors in the log file.

    Any help appreciated!

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,555

    Exclamation Re: Yast won't start any components in GUI nor start on command line

    Quote Originally Posted by Reg_gie View Post
    I did a
    Code:
    zypper dup
    to get everything back to normal but I still have the problem.
    It may be that, the issue is "zypper dup" together with some repositories which provide software which is no compatible with YaST.
    Please check the following:
    • "zypper repos --priority --uri" -- AKA "zypper lr -pu" -- check the repositories listed very carefully -- "zypper dup" functions correctly ONLY for the default openSUSE repositories with the possibly exception of the OFFICIAL update repositories.
    • Assuming that, any "rogue" repositories have been disabled, execute "zypper verify".
    • You may need to rebuild the RPM database: "rpm --rebuilddb".
    • When you have done all that and, you're certain that the installed Ruby is the package from the default openSUSE repositories, forcibly reinstall YaST and all the packages YaST depends on plus, the packages which depend on YaST:

    "zypper install --force --replacefiles --recommends --force-resolution yast2"
    Plus, everything else YaST which is listed by "zypper search --installed-only yast".

    Further information is available here: <https://en.opensuse.org/SDBffline_upgrade> and here: <https://en.opensuse.org/SDB:System_upgrade>.

    When you've done all that and, YaST is behaving as it should do, perform "rcrpmconfigcheck" and perform any needed housekeeping with respect to the system's configuration files.

    Possibly, your post with respect to a Java issue related to execution privileges and rights, is related to the houskeeping to be performed due to this issue.

  3. #3

    Default Re: Yast won't start any components in GUI nor start on command line

    After trying the above and more it was still no go.

    I finally just used
    Code:
    snapper rollback nnn
    and got to a point before the problem started. I backed up all my data first of course.

    Then I restored my data (not sure if it was necessary but it doesn't hurt) and everything was working as it should. I personally don't like not knowing the exact cause and precision fix of things like this but in this case expediency won out.

    One very nice thing I noticed about snapper rollback is that is automatically makes a current snapshot before it rolls back to a previous state.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •