Results 1 to 3 of 3

Thread: Syslog-ng Warning prefix option systemd-journal source

  1. #1

    Default Syslog-ng Warning prefix option systemd-journal source

    I've had this problem at least since leap 42.2 and it is on 5 machines. /var/log/messages gets an entry which reads:

    WARNING: Default value changed for the prefix() option of systemd-journal source in syslog-ng 3.8; old_value='', new_value='.journald.'

    However I can't find anything about systemd-journal in the syslog-ng configuration so I canm't work out where it wants me to change the prefix to avoid this message, which I realise isn't critical in the grand scheme of things.

  2. #2
    Join Date
    Jul 2008
    Location
    Hungary
    Posts
    8

    Default Re: Syslog-ng Warning prefix option systemd-journal source

    Quote Originally Posted by davidlwilcox View Post
    I've had this problem at least since leap 42.2 and it is on 5 machines. /var/log/messages gets an entry which reads:

    WARNING: Default value changed for the prefix() option of systemd-journal source in syslog-ng 3.8; old_value='', new_value='.journald.'

    However I can't find anything about systemd-journal in the syslog-ng configuration so I canm't work out where it wants me to change the prefix to avoid this message, which I realise isn't critical in the grand scheme of things.
    You can safely ignore it. You most likely use the system() source, which automatically finds local log source, the journal source in case of recent openSUSE releases.

    The journal contains many additional name-value pairs about log messages. From version 3.8 these are available with the ".journald." prefix.

  3. #3

    Default Re: Syslog-ng Warning prefix option systemd-journal source

    Thank you. I thought I could ignore it but it would be nice to get rid of the error.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •