Results 1 to 2 of 2

Thread: BTRFS Raid 5 Unable to mount

  1. #1

    Default BTRFS Raid 5 Unable to mount

    Hello, greetings from Malaysia. This is my first post on the forum, I usually tries to solve problems by searching around Google but this time I need some help.

    I'm currently running openSUSE Leap 42.3 and have a BTRFS Raid 5 setup with 4x 2TB WD Red disks. The volume has been running fine for more than 6 months.
    However, recently there was a power outage due to failure on the neighborhood's power generator. So the system ended up with a improper shutdown.

    Since then, I can no longer mount my volume.
    I tried searching around on Google and tried some of the suggested methods but to no avail.

    When I did a btrfs check on the volume, it reports the following error.
    parent transid verify failed on 45056000 wanted 293269 found 293270
    parent transid verify failed on 45056000 wanted 293269 found 293270
    parent transid verify failed on 45056000 wanted 293269 found 293270
    parent transid verify failed on 45056000 wanted 293269 found 293270
    Ignoring transid failure
    leaf parent key incorrect 45056000
    ERROR: cannot open file system
    btrfs rescue zero-log (This also have the same result with the btrfs check command)

    This command results reported that
    btrfs rescue super-recover
    All supers are valid, no need to recover
    The btrfs rescue chunk-recover command however seems to have make it even worse.
    Now I can no longer obtained the same result as what was reported above.

    I also tried booting into Windows and running the WD Diagnostic tools which reported 1 of the disk was having too much of bad sectors.
    I know this is likely due to the disk failure. But currently I do not have any 2TB disk as a replacement, only having some smaller 1TB disks.

    What I want to know is, is there any possibility to recover back the data on the drive at this moment?
    I am prepared to lost all the data, but there are still some data that I missed backing up which would seriously prefer to recover them if possible.

    Thank you for reading along. Please do let me know if you need any additional information.
    Greatly appreciate for any help.

  2. #2
    Join Date
    Jul 2008

    Default Re: BTRFS Raid 5 Unable to mount

    Hopefully it might help. When btrfs fs crashed the commands runned to recover was
    btrfs rescue zero-log /dev/YourpPartition
    btrfs rescue chunk-recover /dev/YourpPartition
    ... and the second command will take long time, really long time if it is big partition with spinning discs. On my SSD btrfs of 680 GB takes about an hour.

    Don't know how dagerous it is if a power outage happens during chunk recover.

    p.s. welcome to the forum

    EDIT: ... and use to mount and unmount the partition before shutdown or reboot.
    ASUS G46VW running openSUSE LEAP 15.2, Windows 8

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts